»  BC-BF Legacy Discussion »  Intake
#Installed cold air intake now having idle prob

Custom Search
Login | Register




Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: Installed cold air intake now having idle prob
PostPosted: Sun Apr 27, 2014 1:53 am 
In Neutral
Joined: Sun Apr 27, 2014 1:09 am
Posts: 4
So I have a 91 legacy turbo auto and I just installed an intake with a open air filter and like so many others I went specter anyhow after installing the car will start but it will not stay that way unless I hit the throttle I have checced all vac lines and maf the only thing I can think of is I added a breather filter to the 3/4 hose that leads from the front of the small air box to the intake manifold not sure if that's it bit any input is appreciated. (I'm sure there is something on this already but I can't find it at the moment)

_________________
91 Leggy turbo (Enos) Sec owner. 226000 mi and rolling
07 (JCW) Mini cooper s
91 leggy l fwd
94 Jeep cheroke sport (jep)


Profile  Offline
Reply with quote  
 Post subject: Re: Installed cold air intake now having idle prob
PostPosted: Sun Apr 27, 2014 2:30 am 
Fifth Gear
Joined: Mon Nov 06, 2006 3:41 am
Posts: 8351
Location: Tenino, WA
Why the breather filter? Plug it and see if that helps. I don't have the stock intake setup so I am having a difficult time picturing what you're referring to but it sounds like you've introduced a vacuum leak to your intake which will lean out your fuel mixture and that's never good.

_________________
98 Metro Hatch Daily Driver :)
91 SS EJ20G Engine/Tranny/Diff Swap Build Thread Here
"Your testes are close to your bottom but you still play with them all the time." Jeremy Clarkson


Profile  Offline
Reply with quote  
 Post subject: Re: Installed cold air intake now having idle prob
PostPosted: Sun Apr 27, 2014 9:29 pm 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 26966
Location: Houston, Tx
Welcome to the BBS.

The only 3/4" line I'm aware of is the IAC valve. This line needs to be put back to the way it was originally setup. Did you also remove the resonator box that went between the MAF sensor and turbo inlet elbow?

I'd recommend you go back to the stock airbox configuration and just remove the snorkel from the fender well. This does reduce some of the intake back pressure and gives you some intake noise.

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
Reply with quote  
 Post subject: Re: Installed cold air intake now having idle prob
PostPosted: Mon Apr 28, 2014 8:45 pm 
In Neutral
Joined: Sun Apr 27, 2014 1:09 am
Posts: 4
I did remove the res box the issue was both the stock box was broken and the resonator box was missing most of the posts for the lines to feed into. I am thinking it is the 3/4 line with the breather filter and i also have noticed that the plastic that runs from the intake into two lines leading to the valves had been broken and then rigged together by the previous owner.

_________________
91 Leggy turbo (Enos) Sec owner. 226000 mi and rolling
07 (JCW) Mini cooper s
91 leggy l fwd
94 Jeep cheroke sport (jep)


Profile  Offline
Reply with quote  
 Post subject: Re: Installed cold air intake now having idle prob
PostPosted: Tue Apr 29, 2014 3:52 pm 
Fifth Gear
Joined: Fri Jun 20, 2008 8:17 am
Posts: 6177
Location: Lakewood, Wa 98439
Can you post a picture of what you have done?

If you need the plastic line the goes to both valve covers, I have an extra one sitting in my garage.

_________________
91 L-TW Wagon with a full Swap -RIP
92 SS Prefaced, GD dash swapped, 22T/205 Hybrid 20 psi - BEAST!
93 SS Bone Stock Gone!
94 TW Bone Stock Gone!
91 SS 4EAT Sold!
98 LGT 4EAT
98 LGT Wagon 4EAT


Profile  Offline
Reply with quote  
 Post subject: Re: Installed cold air intake now having idle prob
PostPosted: Tue Apr 29, 2014 6:51 pm 
Fourth Gear
Joined: Sun Jun 10, 2007 4:35 am
Posts: 1730
Location: All over the place
I'm betting the key to at least get it to hold idle is to plumb that 3/4 line with the filter back into the intake. If the idle control valve is pulling unmetered air, it will essentially act as a "stall out the motor" valve. Then focus on fixing the other damaged lines.

_________________
93 Touring Wagon (EJ20G 5spd Swap) -- In storage while I work (and never get to play) in JDM-land.
00 Forester S/tb (predecesor to the XT) -- My JDM fling, dont tell my Touring Wagon!


Profile  Offline
Reply with quote  

Display posts from previous:  Sort by  

Post new topic Reply to topic  [ 6 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest

Panel

Top You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Dizayn Ercan Koc