»  BC-BF Legacy Discussion »  Engine
#Code 35 resolved still running rich

Custom Search
Login | Register




Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: Code 35 resolved still running rich
PostPosted: Wed Oct 12, 2016 9:37 pm 
First Gear
Joined: Mon Sep 16, 2013 1:28 pm
Posts: 83
Hey folks, quick question,


I had a code 35 Canister Purge Valve Solenoid pop up the other night and sure enough I had a really rough idle, misfires, and stalling the whole 9 yards. When I put a meter to the solenoid I got no reading at all just OL on my meter.

Flash forward, I just finished swapping out the solenoid for a working one, it showed about 42 ohms at a little over 70 degrees.

The engine was running smoothly for few moments, but then it seems like the mixture got enriched I could smell raw fuel, and the idle seemed low and rough.

I'm in the process of resetting the computer to see if that will readjust the mixture.

My question is this, can unplugging the canister purge valve solenoid cause your mixture to go out of balance? it was unplugged for about a day.


Profile  Offline
Reply with quote  
 Post subject: Re: Code 35 resolved still running rich
PostPosted: Thu Oct 13, 2016 5:26 pm 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 26948
Location: Houston, Tx
What is possible is that fuel vapors were stored in the charcoal canister and since they weren't being drawn into the engine that may be what you're smelling.

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
Reply with quote  
 Post subject: Re: Code 35 resolved still running rich
PostPosted: Thu Oct 13, 2016 7:08 pm 
First Gear
Joined: Mon Sep 16, 2013 1:28 pm
Posts: 83
Quick update. After leaving the computer to reset the 35 code disappeared and was replaced with a Code 15. I'll be trouble shooting the injector tomorrow.


Profile  Offline
Reply with quote  
 Post subject: Re: Code 35 resolved still running rich
PostPosted: Fri Oct 14, 2016 8:10 pm 
First Gear
Joined: Mon Sep 16, 2013 1:28 pm
Posts: 83
Turns out it was a bad injector. I swapped with a working one from my donor engine. No more misfires no more related codes.

I still have the issue where my RPMs drop really low and then climb back up after a few seconds.


Profile  Offline
Reply with quote  
 Post subject: Re: Code 35 resolved still running rich
PostPosted: Mon Oct 24, 2016 5:31 pm 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 26948
Location: Houston, Tx
When does the rpm fluctuation you describe occur and does it happen frequently?

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
Reply with quote  
 Post subject: Re: Code 35 resolved still running rich
PostPosted: Mon Mar 20, 2017 3:13 am 
First Gear
Joined: Sat Feb 01, 2014 10:49 pm
Posts: 56
Did you ever figure out what the idle issue was? I'm having the same problem. I have a whole new intake manifold to swap on with all new sensors and injectors and what not that are on it. I have code 35 flashing as well and my car idles rough. I think it's an injector as well.


Sent from my iPhone using Tapatalk


Profile  Offline
Reply with quote  

Display posts from previous:  Sort by  

Post new topic Reply to topic  [ 6 posts ] 


Who is online

Users browsing this forum: No registered users and 3 guests

Panel

Top You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Dizayn Ercan Koc