Search found 56 matches

by mr.blub.blubs142
Fri Aug 02, 2019 2:33 am
Forum: Car Lot
Topic: FS (Western WA): 91 legacy SS
Replies: 4
Views: 584

Re: FS (Western WA): 91 legacy SS

Car is no longer available
by mr.blub.blubs142
Thu Jul 25, 2019 1:32 am
Forum: Car Lot
Topic: FS (Western WA): 91 legacy SS
Replies: 4
Views: 584

Re: FS (Western WA): 91 legacy SS

Wowzers for some reason I wasn’t getting notifications on this. PMs replied to. Car currently pending sale.
by mr.blub.blubs142
Mon Jun 10, 2019 5:40 pm
Forum: Car Lot
Topic: FS (Western WA): 91 legacy SS
Replies: 4
Views: 584

FS (Western WA): 91 legacy SS

My turbo legacy has been sitting for quite some time with no love being shown it. With other vehicles and work, I am uncertain of when I’ll be able to finish putting it together. If someone is interested in the car, I’ll let it (and the spare parts) go for 1500. The shell has 240,000 on it, uncertai...
by mr.blub.blubs142
Tue May 14, 2019 8:11 pm
Forum: Parts Shed
Topic: WTB (Western WA):wagon hatch
Replies: 5
Views: 321

Re: WTB (Western WA):wagon hatch

Found a hatch. No longer in need one. Thanks for all the recommendations


Sent from my iPhone using Tapatalk
by mr.blub.blubs142
Sun May 12, 2019 6:18 pm
Forum: Parts Shed
Topic: WTB (Western WA):wagon hatch
Replies: 5
Views: 321

Re: WTB (Western WA):wagon hatch

I’ll check it out within the next few days if nothing else shows up!


Sent from my iPhone using Tapatalk
by mr.blub.blubs142
Sun May 12, 2019 2:44 am
Forum: Parts Shed
Topic: WTB (Western WA):wagon hatch
Replies: 5
Views: 321

WTB (Western WA):wagon hatch

My wagon got rear ended a few weeks ago and the hatch got warped a tiny bit from the impact. If anybody has a nice dent and rust free hatch they’d be willing to sell me it would be very much appreciated. I’d prefer one that’s mica ruby so that way I don’t have to worry about paint, but if the hatch ...
by mr.blub.blubs142
Fri Feb 01, 2019 7:27 pm
Forum: Parts Shed
Topic: Misc. parts
Replies: 19
Views: 1079

Re: Misc. parts

I’m interested in the door cards. How much you looking for them?


Sent from my iPhone using Tapatalk
by mr.blub.blubs142
Fri Oct 12, 2018 4:04 am
Forum: Parts Shed
Topic: got 'em thanks!
Replies: 10
Views: 1384

Re: need parts for '90 Wagon

I’m still trying to find the nice ones from my car. I’ll check the set in my parts car too. They probably are good too. We can always meet half way when I find them. Cheaper than shipping


Sent from my iPhone using Tapatalk
by mr.blub.blubs142
Thu Sep 27, 2018 4:24 am
Forum: Parts Shed
Topic: got 'em thanks!
Replies: 10
Views: 1384

Re: need parts for '90 Wagon

I might still have mine somewhere. They were perfect when I swapped to manual belts. Do you need both lap and shoulder belts?


Sent from my iPhone using Tapatalk
by mr.blub.blubs142
Sun Aug 05, 2018 4:01 am
Forum: Engine
Topic: Ac causing surging idle
Replies: 1
Views: 927

Ac causing surging idle

So I just developed a very odd problem and I’m hoping someone can lead me in the right direction. When my car is in park with the ac on, it idles super smooth. Once I put the car in drive, however, the idle becomes EXTREMELY rough, to the point of almost dying. The Ac still blows cold while this is ...
by mr.blub.blubs142
Mon Jul 02, 2018 6:03 pm
Forum: Parts Shed
Topic: WTB: momo hub adapter
Replies: 2
Views: 298

Re: WTB: momo hub adapter

I already have a hub adapter without cruise, but thanks for the offer!


Sent from my iPhone using Tapatalk
by mr.blub.blubs142
Sat Jun 30, 2018 12:26 am
Forum: Parts Shed
Topic: WTB: momo hub adapter
Replies: 2
Views: 298

WTB: momo hub adapter

I’m looking for the momo hub adapter with the built in cruise control switch. Lemme know if anybody has one that they’re looking to unload


Sent from my iPhone using Tapatalk
by mr.blub.blubs142
Tue May 15, 2018 7:02 am
Forum: Engine
Topic: machine shop
Replies: 10
Views: 1653

Re: machine shop

Not sure if you’d want to drive all the way down to chehalis, but Barry’s Quality Machine down here here is pretty damn good.


Sent from my iPhone using Tapatalk
by mr.blub.blubs142
Tue May 15, 2018 3:16 am
Forum: Engine
Topic: Rough idle when warm
Replies: 15
Views: 2343

Re: Rough idle when warm

I seemed to stubble upon what was causing my issue. After months of running issues with no check engine light, mine finally came on with a knock sensor code. I pulled the old one out and found tons of cracks all though it. I’ve put over 500 miles on my new one and haven’t had any issues. Sent from m...
by mr.blub.blubs142
Thu Apr 26, 2018 1:57 am
Forum: Parts Shed
Topic: ISO Auto shifter for 94 TW
Replies: 1
Views: 266

Re: ISO Auto shifter for 94 TW

I have a stock shifter knob if you’re interested. The wires for the manual button have been cut, but the knob itself is fine, button works great.


Sent from my iPhone using Tapatalk
by mr.blub.blubs142
Mon Apr 16, 2018 9:02 pm
Forum: Community Projects
Topic: WCSS 20
Replies: 10
Views: 1236

Re: WCSS 20

It’s only like an hour from my house, but I’ll probably still be camping


Sent from my iPhone using Tapatalk
by mr.blub.blubs142
Wed Apr 11, 2018 7:02 am
Forum: Community Projects
Topic: WCSS 20
Replies: 10
Views: 1236

Re: WCSS 20

The wagon will be there! Hopefully with a few new additions to up it’s game [emoji6]


Sent from my iPhone using Tapatalk
by mr.blub.blubs142
Wed Apr 11, 2018 2:58 am
Forum: Community Projects
Topic: WCSS 20
Replies: 10
Views: 1236

Re: WCSS 20

I’ll be there!


Sent from my iPhone using Tapatalk
by mr.blub.blubs142
Tue Apr 10, 2018 11:24 pm
Forum: Engine
Topic: Rough idle when warm
Replies: 15
Views: 2343

Re: Rough idle when warm

Kris, that would be much appreciated! I must admit, electrical is not my forte, so any help with electrical is always welcome


Sent from my iPhone using Tapatalk
by mr.blub.blubs142
Mon Apr 09, 2018 10:58 pm
Forum: Engine
Topic: Rough idle when warm
Replies: 15
Views: 2343

Re: Rough idle when warm

It’s an auto 91. Just for funsies, I swapped my stock air box out and put a pod filter on the car. When I did that, I looked down in the fender and saw quite a bit of mud built up in the intake. Maybe just not getting enough air? I haven’t had time yet to pull everything apart and clean it properly,...
by mr.blub.blubs142
Tue Apr 03, 2018 6:56 am
Forum: Engine
Topic: Rough idle when warm
Replies: 15
Views: 2343

Re: Rough idle when warm

So I swapped a working maf sensor I got from a junkyard and it seemed to help a little bit, but it’s still running pretty rough. It’s not consistently rough or throwing any codes which is making it difficult to find the cause. Every time I start the car when it’s warm, the rpms drop like the car is ...
by mr.blub.blubs142
Fri Mar 23, 2018 10:50 pm
Forum: Engine
Topic: Rough idle when warm
Replies: 15
Views: 2343

Re: Rough idle when warm

I cleaned up my IAC a while ago and it helped a little, but not much. I tested my alternator and it was a bit low on the charging. I’m thinking that’s probably it at the moment so I’m gonna swap in a spare I have to see if that helps. I haven’t messed with my grounds at all, so if it comes to that, ...
by mr.blub.blubs142
Wed Mar 14, 2018 2:53 am
Forum: Engine
Topic: Rough idle when warm
Replies: 15
Views: 2343

Re: Rough idle when warm

I finally got around to cleaning my maf and it made no difference to how the car ran. Still rough idle especially when the fans kick on. I’m kinda stumped since I’ve replaced or cleaned most electrical.


Sent from my iPhone using Tapatalk
by mr.blub.blubs142
Sat Feb 24, 2018 8:13 pm
Forum: Parts Shed
Topic: FOUND! wtb pre-face side trim front fender : LOCK please
Replies: 5
Views: 398

Re: WTB side trim front fender

I might have a set on my parts car. I’ll check today


Sent from my iPhone using Tapatalk
by mr.blub.blubs142
Thu Feb 22, 2018 4:01 pm
Forum: Engine
Topic: Rough idle when warm
Replies: 15
Views: 2343

Re: Rough idle when warm

Not yet. That was gonna be one of the next things to check


Sent from my iPhone using Tapatalk