»  BC-BF Legacy Discussion »  Intake
#My IACV keeps giving me problems

Custom Search
Login | Register




Post new topic Reply to topic  [ 15 posts ] 
Author Message
 Post subject: My IACV keeps giving me problems
PostPosted: Tue Apr 29, 2014 10:57 pm 
Third Gear
Joined: Wed Oct 26, 2011 7:02 am
Posts: 881
Location: Anchorage,Alaska
I've cleaned it dozens of times which helped but now it won't idle lower than 1200 rpms at lights. My CEL comes on throwing code 24 and sometimes when I start it runs really ruff like a misfire, always when it's hot but still idles at 1200 rpm's. Of course mine is a 90 5spd and they only put those on 90-91 5spd so finding a used one is difficult.

Things that I've done in the past to help the problem is:

Adjusted the idle down (I know not to touch the factory settings) till the throttle valve is completely shut and put a restrictor in the hose going to the intake pipe. That's help a lot at start up in the morning (w/out restriction it runs at 3500 rpm's when cold with restriction 2000 rpm's)

After the idle was adjusted down when it warm it use to idle at 850 rpm's but that was two years ago. It keeps creeping up and now I don't have any more tricks to throw at it.

I've ordered a new IAC from Subaru today to try to fix this problem and the price wasn't bad 124$. If any one has any suggestions or any other tricks let me know.

_________________
Charles

90' White/Gray Outback DD workhorse (670,xxx) miles
92' Onyx Metallic (430,xxx) Wife's DD
68' Barracuda formula S 340 4spd coupe (ongoing project)
66' Mustang 2+2 4spd wife's (ongoing project)


Profile  Offline
Reply with quote  
 Post subject: Re: My IACV keeps giving me problems
PostPosted: Thu May 01, 2014 12:02 am 
Third Gear
Joined: Tue Nov 27, 2007 2:43 am
Posts: 736
Location: tacoma washington
I posted a video a while back of a dude with the same problem, and he showed a good way of "cleaning" it. I have the exact same problem you do ive just accepted its a fact of life for old legacies. I managed to lessen the occurances of the IACV acting up on my car with routien stuff. Plugs Good wires, PCV, Coolant temp sensor. and fixed a few split wires on some sensor pig tails. Let us know how the new valve works out and man you got a cheap price.

_________________
1993 legacy ss "Shela"


Profile  Offline
Reply with quote  
 Post subject: Re: My IACV keeps giving me problems
PostPosted: Thu May 01, 2014 2:21 am 
Third Gear
Joined: Wed Oct 26, 2011 7:02 am
Posts: 881
Location: Anchorage,Alaska
It's defiantly frustrating, I use ngk plugs and wires coolant sensor is fairly new and PCV has been replaced. The car runs great starts in -70 temp with no problems. I believe I cleanest IAC on the board. I seafoam it every oil change in the winter and in the summer I remove it to clean it. It's never very dirty but yet it keeps climbing. I posted a pic in my journal of one of my cleanings in the snow. I hope the new IAC fixes it, I will let you know.

_________________
Charles

90' White/Gray Outback DD workhorse (670,xxx) miles
92' Onyx Metallic (430,xxx) Wife's DD
68' Barracuda formula S 340 4spd coupe (ongoing project)
66' Mustang 2+2 4spd wife's (ongoing project)


Last edited by rallyak on Tue May 06, 2014 5:44 pm, edited 1 time in total.

Profile  Offline
Reply with quote  
 Post subject: Re: My IACV keeps giving me problems
PostPosted: Thu May 01, 2014 4:02 pm 
Fifth Gear
Joined: Fri May 04, 2007 4:09 pm
Posts: 2235
Location: N. ID
Something I've noticed on my car is if I just replaced the top piece which is interchangeable with almost all the 2.2 and 2.5 IACs it'll help with that idle issue - it doesn't fix the coldstart issue with EJ 20 ECU - but it does help with the idle. good luck w/the new one.
And where did u get it for $124?

TD

_________________
Turbo Subies:
'87 GL-10 Turbo 4WD Wagon (pre-Loyale) - SOLD
'90 BJ, EJ22T/DOHC and 5-speed swap - SOLD
'04 FXT, Forged internals, VF39, STI TMIC, Cobb AP- SOLD
'93 Legacy SS - 5-speed, SOLD :-(
'02 WRX GG-SOLD
'96 BD - turbo'd-SOLD


Profile  Offline
Reply with quote  
 Post subject: Re: My IACV keeps giving me problems
PostPosted: Thu May 01, 2014 4:54 pm 
Third Gear
Joined: Wed Oct 26, 2011 7:02 am
Posts: 881
Location: Anchorage,Alaska
I don't think the top piece on mine is interchangeable with others, mine is two pin and and just a solenoid that goes up and down. I know my wife's is a different design, hers spins and adjustable I believe that is the common one. I'm getting my new one from my local subaru dealer, I hope he ordered the correct one but he did match it up with my vin.

_________________
Charles

90' White/Gray Outback DD workhorse (670,xxx) miles
92' Onyx Metallic (430,xxx) Wife's DD
68' Barracuda formula S 340 4spd coupe (ongoing project)
66' Mustang 2+2 4spd wife's (ongoing project)


Profile  Offline
Reply with quote  
 Post subject: Re: My IACV keeps giving me problems
PostPosted: Thu May 01, 2014 10:25 pm 
Fifth Gear
Joined: Fri May 04, 2007 4:09 pm
Posts: 2235
Location: N. ID
That part is close to $300 on other sites....but if it's for the '90 may be it's different??

_________________
Turbo Subies:
'87 GL-10 Turbo 4WD Wagon (pre-Loyale) - SOLD
'90 BJ, EJ22T/DOHC and 5-speed swap - SOLD
'04 FXT, Forged internals, VF39, STI TMIC, Cobb AP- SOLD
'93 Legacy SS - 5-speed, SOLD :-(
'02 WRX GG-SOLD
'96 BD - turbo'd-SOLD


Profile  Offline
Reply with quote  
 Post subject: Re: My IACV keeps giving me problems
PostPosted: Thu May 01, 2014 11:33 pm 
Third Gear
Joined: Tue Nov 27, 2007 2:43 am
Posts: 736
Location: tacoma washington
I know the price is crazy, wish it was the same for my 93 ss. IACV imo is the most dumb idiot thing on any car ever. I have a 93 S10 that has IACV problems too......................... must have just been 90's stuff.

_________________
1993 legacy ss "Shela"


Profile  Offline
Reply with quote  
 Post subject: Re: My IACV keeps giving me problems
PostPosted: Fri May 02, 2014 12:02 am 
Third Gear
Joined: Wed Oct 26, 2011 7:02 am
Posts: 881
Location: Anchorage,Alaska
It's basically a controlled vacuum leak, I think it dumb also.

_________________
Charles

90' White/Gray Outback DD workhorse (670,xxx) miles
92' Onyx Metallic (430,xxx) Wife's DD
68' Barracuda formula S 340 4spd coupe (ongoing project)
66' Mustang 2+2 4spd wife's (ongoing project)


Profile  Offline
Reply with quote  
 Post subject: Re: My IACV keeps giving me problems
PostPosted: Fri May 02, 2014 5:26 am 
Third Gear
Joined: Tue Nov 27, 2007 2:43 am
Posts: 736
Location: tacoma washington
i wish i could just block it off and not have more problems.

_________________
1993 legacy ss "Shela"


Profile  Offline
Reply with quote  
 Post subject: Re: My IACV keeps giving me problems
PostPosted: Fri May 02, 2014 5:27 pm 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 27111
Location: Houston, Tx
If you are getting a code for the IAC valve, than the actual solenoid part of the valve is probably what's bad and not the valve itself. There's no cleaning you can do to fix the solenoid. I would suspect the new valve should fix your problem.

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
Reply with quote  
 Post subject: Re: My IACV keeps giving me problems
PostPosted: Mon May 12, 2014 11:23 pm 
Third Gear
Joined: Wed Oct 26, 2011 7:02 am
Posts: 881
Location: Anchorage,Alaska
Well Subaru ordered the wrong part, it was the purge solenoid. I knew it was to good to be true. They checked the correct part # and guess what.... Discontinued. So I went digging through my parts and found a two pin IAC, but I remembered installing that one on my car and didn't work, the idle was way to high. So I took the solenoid off the top and the one on mine and found the spare was missing a spring. I install the new solenoid and all is good now. I don't think my IAC has ever worked properly since I've own it.

_________________
Charles

90' White/Gray Outback DD workhorse (670,xxx) miles
92' Onyx Metallic (430,xxx) Wife's DD
68' Barracuda formula S 340 4spd coupe (ongoing project)
66' Mustang 2+2 4spd wife's (ongoing project)


Profile  Offline
Reply with quote  
 Post subject: Re: My IACV keeps giving me problems
PostPosted: Wed May 14, 2014 3:30 am 
Third Gear
Joined: Tue Nov 27, 2007 2:43 am
Posts: 736
Location: tacoma washington
Right on man!! Glad it all worked out.

_________________
1993 legacy ss "Shela"


Profile  Offline
Reply with quote  
 Post subject: Re: My IACV keeps giving me problems
PostPosted: Tue Sep 09, 2014 1:01 am 
First Gear
Joined: Mon Jan 20, 2014 10:13 pm
Posts: 121
Location: Spokane WA
thread from the dead im gonna try this on my ej20g swap iv been having erratic iac issues aswell wish me luck

_________________
88 Honda civic wagon B20VTEC SWAP-RIP
85 Subaru loyal sedan-SOLD
95 Subaru impreza $500 BEATER-SOLD
91 Subaru legacy SS jdm ej20g swap

CHECK OUT MY ej20G BUILD HERE>> viewtopic.php?f=25&t=53766


Profile  Offline
Reply with quote  
 Post subject: Re: My IACV keeps giving me problems
PostPosted: Thu Sep 11, 2014 6:05 pm 
Third Gear
Joined: Tue Nov 27, 2007 2:43 am
Posts: 736
Location: tacoma washington
good luck man I've had IACV problems for 6+ years

_________________
1993 legacy ss "Shela"


Profile  Offline
Reply with quote  
 Post subject: Re: My IACV keeps giving me problems
PostPosted: Sat Sep 20, 2014 7:45 pm 
Second Gear
Joined: Mon Oct 06, 2008 5:25 pm
Posts: 504
Location: burlington, ontraio, canada
i've swapped the top part on my swapped car and its solved the warm idle issues. The 20g ecus don't like the cold/cold starts

_________________
Silver 99 Legacy GT Wagon
White 90 BC5 RS Type RA
Black 02 Legacy Outback GT Wagon
http://s684.beta.photobucket.com/user/d ... l/library/


Profile  Offline
Reply with quote  

Display posts from previous:  Sort by  

Post new topic Reply to topic  [ 15 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest

Panel

Top You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Dizayn Ercan Koc