»  BC-BF Legacy Discussion »  Intake
#Boost leaking from IACV?

Custom Search
Login | Register




Post new topic Reply to topic  [ 8 posts ] 
Author Message
 Post subject: Boost leaking from IACV?
PostPosted: Sun Jun 29, 2014 4:46 pm 
Fourth Gear
Joined: Sun Jun 10, 2007 4:35 am
Posts: 1732
Location: All over the place
I got a boost leak tester, and figured I would test my system to 20psi and see whats up, because while my BIG leaks are gone, my car still gets soggy over 15psi and I have a feeling its still leaking smaller amounts other places. I removed the 90* elbow on my turbo inlet, this way I wont be pressuring the PCV system and only testing from the turbo compressor forward, the parts that actually see boost. This also makes it easy to see if any air is coming back out of the BPV, PCV vent hoses, or the IACV hose when it shouldnt be.

So far, I can only notice two leak areas; the tiny little bleed fitting on my Hallman ES MBC, which is supposed to be there I suppose (although I didnt realize just how strong or loud that stream is at 15psi!), and the other is my IACV. It lets out a pretty noticeable amount of air. I stuck my thumb in the hose to plug it, and it pressurizes with the rest of the intake. When I changed the gasket on my IACV, I noticed there is what looks like a one way diaphram, though it also didnt look replaceable. It seems to me like boost leaking past would be a very bad thing, as it would have the same effect as the BPV being stuck open.

Anyone else know if it's normal to leak air out this way? Do I need a new one-way diaphram in the manifold?

_________________
93 Touring Wagon (EJ20G 5spd Swap) -- In storage while I work (and never get to play) in JDM-land.
00 Forester S/tb (predecesor to the XT) -- My JDM fling, dont tell my Touring Wagon!


Last edited by James614 on Mon Jun 30, 2014 2:30 pm, edited 1 time in total.

Profile  Offline
Reply with quote  
 Post subject: Re: Boost leaking from IACV?
PostPosted: Sun Jun 29, 2014 5:15 pm 
Fourth Gear
Joined: Sun Jun 10, 2007 4:35 am
Posts: 1732
Location: All over the place
Well, I bypassed my boost controller and tested again. Got to 17psi with my thumb plugging the IACV hose, and I blew something on the IACV itself, because it now leaks profusely through its body where the plastic motor housing meets the aluminum body. I took the top part off and the O-rings are still in pretty much immaculate shape, I have no idea what let go in it to make it start leaking like a siv suddenly. It seems to hold vacuum just fine still.

Before that happened, there didnt appear to be any leaks at 17psi, yay.

How bad would it be if I made a block off plate for the IACV, and adjusted my idle on the throttle body?

_________________
93 Touring Wagon (EJ20G 5spd Swap) -- In storage while I work (and never get to play) in JDM-land.
00 Forester S/tb (predecesor to the XT) -- My JDM fling, dont tell my Touring Wagon!


Profile  Offline
Reply with quote  
 Post subject: Re: Boost leaking from IACV?
PostPosted: Mon Jun 30, 2014 5:53 pm 
Third Gear
Joined: Wed Aug 22, 2007 9:27 pm
Posts: 787
Location: Denver, CO
Maybe the plunger failed. It should be easy to see once you take it off.

Personally I would try to fix or replace the IACV before screwing around with the TB plate adjustment.

_________________
maciek puszynski

01 Impreza | v6 STi RA | 5mt | ej236t
93 Legacy Turbo | TW | 4eat | ej22t
16 WRX | 6mt | fa20
98 Legacy GT | wagon | 5mt | ej25d


2.36L Turbo - RSTi Build


Profile  Offline
Reply with quote  
 Post subject: Re: Boost leaking from IACV?
PostPosted: Mon Jun 30, 2014 6:08 pm 
Fourth Gear
Joined: Sun Jun 10, 2007 4:35 am
Posts: 1732
Location: All over the place
I'm guessing the plunger is that one way diaphragm looking piece in manifold? Any idea what the part number might be? The IACV itself seems like its probably fine, just that plunger or whatever is letting pressure into it when it wasn't designed to hold it.

_________________
93 Touring Wagon (EJ20G 5spd Swap) -- In storage while I work (and never get to play) in JDM-land.
00 Forester S/tb (predecesor to the XT) -- My JDM fling, dont tell my Touring Wagon!


Profile  Offline
Reply with quote  
 Post subject: Re: Boost leaking from IACV?
PostPosted: Tue Jul 01, 2014 10:28 pm 
Fourth Gear
Joined: Sun Jun 10, 2007 4:35 am
Posts: 1732
Location: All over the place
Managed to get the part numbers for the two parts that sit under the IACV in the manifold. Cheap enough too, like $8/each. Im surprised that Ive never heard of whatever these are mentioned previously. Im going off the assumption that the ej22t uses the same parts as the ej20g here, since the design of the iacv hasnt really changed through the 90s im assuming these didnt either.

im running wastegate boost right now to avoid leaking past my iacv, the car feels like its easily down 50hp :(

_________________
93 Touring Wagon (EJ20G 5spd Swap) -- In storage while I work (and never get to play) in JDM-land.
00 Forester S/tb (predecesor to the XT) -- My JDM fling, dont tell my Touring Wagon!


Profile  Offline
Reply with quote  
 Post subject: Re: Boost leaking from IACV?
PostPosted: Sun Jul 27, 2014 1:42 am 
Fourth Gear
Joined: Sun Jun 10, 2007 4:35 am
Posts: 1732
Location: All over the place
Got the new diaphram and big donut seal installed a cople weeks ago. That fixed the leaking through the IACV body, and now it leaks through the IACV hose substantially less. Ive concluded that some leakage through here is inevitable at higher than 14 or so psi, but now its small enough that its probably negligible.

FWIW I believe my old donut seal was blown out by my improper test of plugging the IAC hose, and , y old diaphram seemed perfectly good save for a crap ton of carbon build, and probably would perform like new if cleaned.

_________________
93 Touring Wagon (EJ20G 5spd Swap) -- In storage while I work (and never get to play) in JDM-land.
00 Forester S/tb (predecesor to the XT) -- My JDM fling, dont tell my Touring Wagon!


Profile  Offline
Reply with quote  
 Post subject: Re: Boost leaking from IACV?
PostPosted: Fri Aug 22, 2014 7:24 pm 
First Gear
Joined: Mon Feb 27, 2012 6:20 pm
Posts: 50
Any chance you could provide those part numbers? I have only found used replacement ones and they are expensive to ship.


Profile  Offline
Reply with quote  
 Post subject: Re: Boost leaking from IACV?
PostPosted: Fri Aug 22, 2014 11:22 pm 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 27100
Location: Houston, Tx
Here are the two part #'s

22657AA010
22660AA000

You can find all the part #'s in this post

viewtopic.php?f=12&t=30531

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
Reply with quote  

Display posts from previous:  Sort by  

Post new topic Reply to topic  [ 8 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest

Panel

Top You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Dizayn Ercan Koc