Hybrid build high idle

Snorkus, filters, throttle bodies and intake manifolds.

Moderators: Helpinators, Moderators

Post Reply
xbmxxx
In Neutral
Posts: 31
Joined: Tue Apr 15, 2014 1:34 am

Hybrid build high idle

Post by xbmxxx »

Hi everyone, I am experiencing a high idle issue with my Legacy. It is a 22T block with 25D heads and a 20g intake manifold. Ever since first startup its idled high (2100ish) until operating temp, where it will eventually drop down to around 1000 but trips a CEL and idles rough in doing so. It seems to drive ok other then the idle issue.

Here is what I find weird, I was moving stuff around while cleaning the IACV and noticed that if I pinch the hose going to the rear engine breather from the turbo inlet elbow, it chokes out the car. If I kink the hose, it will kill the engine. I am unfamiliar with these engines, but very familiar with the newer 2.0 and 2.5 engines, and I know they will run with that hose removed or plugged. Seems very odd that there is that much airflow going through that hose.

So far I have:
hosed out the IACV with MAF cleaner
Cleaned the MAF
Smoke checked for Vacuum leaks
checked throttle cable adjustment.

any advice on what to do next is appreciated

wtdash
Fifth Gear
Posts: 2297
Joined: Fri May 04, 2007 4:09 pm
Location: N. ID

Re: Hybrid build high idle

Post by wtdash »

Hi,
EDIT: A Mod/Admin can combine your 2 threads....

What's the CEL when the idle falls to 1K?



What ECU? stock Ej22T
What injectors? 440's

TD
Turbo Subies:
'87 GL-10 Turbo 4WD Wagon (pre-Loyale) - SOLD
'90 BJ, EJ22T/DOHC and 5-speed swap - SOLD
'04 FXT, Forged internals, VF39, STI TMIC, Cobb AP- SOLD
'93 Legacy SS - 5-speed, SOLD :-(
'02 WRX GG-SOLD
'96 BD - turbo'd-SOLD

xbmxxx
In Neutral
Posts: 31
Joined: Tue Apr 15, 2014 1:34 am

Re: Hybrid build high idle

Post by xbmxxx »

I thought I deleted the other thread. My bad.

1993 Legacy Turbo ECU
1993 Legacy Turbo Pink Sidefeeds

Legacy777
Site Admin
Site Admin
Posts: 27612
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: Hybrid build high idle

Post by Legacy777 »

Are you still having a problem with this?

Just so I'm clear, if you pinch one of the PCV hoses it stalls the engine? If that is the case I think you may have some of the PCV hoses incorrectly hooked up.
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
2020 Outback Limted XT

If you need to get a hold of me please email me rather then pm

xbmxxx
In Neutral
Posts: 31
Joined: Tue Apr 15, 2014 1:34 am

Re: Hybrid build high idle

Post by xbmxxx »

this is how I have them. If I pinch off OR remove the hose to the inlet the car will not run at all.

Image

Legacy777
Site Admin
Site Admin
Posts: 27612
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: Hybrid build high idle

Post by Legacy777 »

This is how I recommend you hook up your PCV system. You need to have two separate connections going to the turbo inlet hose like I've shown in red.

http://main.experiencetherave.com/subar ... id_pcv.jpg
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
2020 Outback Limted XT

If you need to get a hold of me please email me rather then pm

xbmxxx
In Neutral
Posts: 31
Joined: Tue Apr 15, 2014 1:34 am

Re: Hybrid build high idle

Post by xbmxxx »

I will give that a shot. Thank you!

Post Reply