Wandering Idle and Vacuum "blip"

Snorkus, filters, throttle bodies and intake manifolds.

Moderators: Helpinators, Moderators

Post Reply
just-rust
First Gear
Posts: 230
Joined: Thu Dec 26, 2013 4:22 pm
Location: Minnesnowda

Wandering Idle and Vacuum "blip"

Post by just-rust » Wed Dec 10, 2014 9:00 pm

The idle was fine until recently when I blew the seals in my turbo. As expected, oil all over in the intake, TMIC, etc. I drained the intercooler, swapped a td04 in and seafoamed the IACV and pcv valve/intake. The car does run great when driving. Will drop RPM's almost to a stall when sitting every now and then but usually RPM's look like what is on the video (link below).

Also captured in the video, is a vacuum "blip" that I have noticed ever since I have hooked up the boost gauge. Just wondering if this is normal or if I should be investigating this. Anybody else have this happen? Must be the massive horsepower right? lol

Rusty 1991 EJ22T - VF28 - '07 wrx TMIC - MBC - Invidia DP - Walbro 255 SOLD
1992 Legacy SS 5mt, with some neat stuff on it

robertpaige
Fourth Gear
Posts: 1229
Joined: Tue Jul 31, 2012 10:32 pm
Location: Portland, Oregon.

Re: Wandering Idle and Vacuum "blip"

Post by robertpaige » Wed Dec 10, 2014 11:08 pm

Looks normal to me, are you sure you didn't tap the throttle on the blip?
Had more Legacy's than I know what to with...
Current: 92' SS

just-rust
First Gear
Posts: 230
Joined: Thu Dec 26, 2013 4:22 pm
Location: Minnesnowda

Re: Wandering Idle and Vacuum "blip"

Post by just-rust » Thu Dec 11, 2014 2:06 am

For sure. Had both feet away from the pedals. That happens if I am idling or at cruising speeds on the freeway or anything in-between. My curiosity finally got me to raise a question. Took me a few tries to capture that on video. It blips so randomly.
Rusty 1991 EJ22T - VF28 - '07 wrx TMIC - MBC - Invidia DP - Walbro 255 SOLD
1992 Legacy SS 5mt, with some neat stuff on it

Legacy777
Site Admin
Site Admin
Posts: 27548
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: Wandering Idle and Vacuum "blip"

Post by Legacy777 » Sun Dec 14, 2014 5:14 am

I have a theory....where did you tap into for your vacuum/boost gauge?

If you're tee'd into the line between the MAP sensor and pressure exchange solenoid it would exhibit the exact behavior in the video when the pressure exchange solenoid opens to let the MAP sensor check ambient pressure.
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm

just-rust
First Gear
Posts: 230
Joined: Thu Dec 26, 2013 4:22 pm
Location: Minnesnowda

Re: Wandering Idle and Vacuum "blip"

Post by just-rust » Sun Dec 14, 2014 6:04 am

That is exactly where it is drawing from. Thanks for answering that Josh!
Rusty 1991 EJ22T - VF28 - '07 wrx TMIC - MBC - Invidia DP - Walbro 255 SOLD
1992 Legacy SS 5mt, with some neat stuff on it

Legacy777
Site Admin
Site Admin
Posts: 27548
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: Wandering Idle and Vacuum "blip"

Post by Legacy777 » Sun Dec 14, 2014 6:18 am

You're welcome.

You need to tee into the line between the intake manifold and pressure exchange solenoid. That should take care of the vacuum blip. I'm not sure if it will change your idle though. You may also want to reset your ECU.
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm

just-rust
First Gear
Posts: 230
Joined: Thu Dec 26, 2013 4:22 pm
Location: Minnesnowda

Re: Wandering Idle and Vacuum "blip"

Post by just-rust » Tue Dec 16, 2014 7:35 pm

I reset the ECU and will move the boost T soon. So far I still have a stumble in the rpm. At this point I am not going to worry about it though (Meaning it is too cold out again) lol
Rusty 1991 EJ22T - VF28 - '07 wrx TMIC - MBC - Invidia DP - Walbro 255 SOLD
1992 Legacy SS 5mt, with some neat stuff on it

Post Reply