»  Archive »  BC-BF Legacyworks Archive
#'90' Subaru Legacy 2.2 L

Custom Search
Login | Register




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 3 posts ] 
Author Message
 Post subject: '90' Subaru Legacy 2.2 L
PostPosted: Sun Mar 09, 2003 8:59 pm 
The car has no power after starting. The engine idles great. When
this happens, I turn the engine off and back on again. The problem
disappears. But when I turn off the engine and go into a store for
awhile, the problem starts over again when I restart it. Help!!


Reply with quote  
 Post subject: '90' Subaru Legacy 2.2 L
PostPosted: Sun Mar 09, 2003 9:09 pm 
What do you mean it has no power? Can you be a little more descriptive.
Are there any more symptoms? Have you done a tune-up lately, plugs,
wires, filters, etc.

Josh


Reply with quote  
 Post subject: '90' Subaru Legacy 2.2 L
PostPosted: Mon Mar 10, 2003 10:59 am 
---
The car will not go over 1000 r.p.m.. Sometimes it comes out of it if
I keep the petal down. I changed the fuel filter last year. I need
to change the spark plugs and air filter. The car does run fine if I
turn the engine off and right back on.


Reply with quote  

Display posts from previous:  Sort by  

Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 3 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest

Panel

Top You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Dizayn Ercan Koc