I have a 91 wagon. Limp mode

Headlights to tailights and everything in between.

Moderators: Helpinators, Moderators

Post Reply
krkchrs
In Neutral
Posts: 3
Joined: Thu May 31, 2018 6:29 am

I have a 91 wagon. Limp mode

Post by krkchrs » Thu May 31, 2018 7:14 am

My automatic trans is stuck in limp mode. I can find any Info other that the handshake. My car will not do the handshake. I've looked everywhere on the web for a good electrical diagram to show me what powers the tcm and where the ecm comes in. I can find it.. looking for help!!! Please and thank you.. Image

Sent from my SAMSUNG-SM-G935A using Tapatalk

Legacy777
Site Admin
Site Admin
Posts: 27458
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: I have a 91 wagon. Limp mode

Post by Legacy777 » Tue Jun 05, 2018 6:05 pm

Welcome to the BBS.

These are the wiring diagrams for the 90 Legacy, but should be same/similar for the 91 model year.

http://main.experiencetherave.com/subar ... agrams.zip

Those should help with diagnostic work. My first question would be, does the power light come on at all when the ignition key is turned from off to the "ON" position? If not, the TCM is not getting power and that's where you should start.
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm

krkchrs
In Neutral
Posts: 3
Joined: Thu May 31, 2018 6:29 am

Re: I have a 91 wagon. Limp mode

Post by krkchrs » Tue Jun 05, 2018 7:29 pm

Thank you for this. I found a 92 and it got me far enough to rule out mist stuff. I found a cheap tcm and replaced it and that did the trick.

Sent from my SAMSUNG-SM-G935A using Tapatalk

Legacy777
Site Admin
Site Admin
Posts: 27458
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: I have a 91 wagon. Limp mode

Post by Legacy777 » Wed Jun 06, 2018 5:23 pm

Glad to hear you got it taken care of!
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm

krkchrs
In Neutral
Posts: 3
Joined: Thu May 31, 2018 6:29 am

Re: I have a 91 wagon. Limp mode

Post by krkchrs » Wed Jun 06, 2018 6:12 pm

Legacy777 wrote:Glad to hear you got it taken care of!
Thanks boss

Sent from my SAMSUNG-SM-G935A using Tapatalk

Post Reply