»  BC-BF Legacy Discussion »  Electrical
#Burning up MAF's

Custom Search
Login | Register




Post new topic Reply to topic  [ 18 posts ] 
Author Message
 Post subject: Burning up MAF's
PostPosted: Mon Nov 27, 2017 7:18 am 
First Gear
Joined: Sat Sep 19, 2009 6:21 am
Posts: 220
Location: Orem, UT
I'm getting pretty burnt out working on this car of mine.

I've swapped an EJ22t into my 90 Loyale and have been having an issue burning up MAF sensors. It seems to be getting worse, and I'm running out of sensors. I'm guessing it's in the wiring trim I did, like not enough grounds or something but I'm not exactly sure.

Looking for any suggestions or tips, I really want to start driving this thing again.

_________________
07 Outback XT VF52
94 Legacy Sport, VF23, 550 RobTune, various other things
93 Legacy Touring Wagon EJ205 management and dash swap (in progress)
90 Loyale Turbo, EJ Turbo Swap, 2" lift
82 Brat, EJ22 swap, RX AWD trans w/ LSD rear, 5 lug 4 wheel disc.


Profile  Offline
Reply with quote  
 Post subject: Re: Burning up MAF's
PostPosted: Fri Dec 01, 2017 7:17 am 
Fifth Gear
Joined: Fri May 04, 2007 4:09 pm
Posts: 2251
Location: N. ID
you've checked the Voltage @ the MAF wiring? Probably could use a resistor (?) to lower to the 5V or whatever it should be. What does Wiring Trim mean? Merged harness?

_________________
Turbo Subies:
'87 GL-10 Turbo 4WD Wagon (pre-Loyale) - SOLD
'90 BJ, EJ22T/DOHC and 5-speed swap - SOLD
'04 FXT, Forged internals, VF39, STI TMIC, Cobb AP- SOLD
'93 Legacy SS - 5-speed, SOLD :-(
'02 WRX GG-SOLD
'96 BD - turbo'd-SOLD


Profile  Offline
Reply with quote  
 Post subject: Re: Burning up MAF's
PostPosted: Mon Jan 29, 2018 12:44 am 
First Gear
Joined: Sat Sep 19, 2009 6:21 am
Posts: 220
Location: Orem, UT
wtdash wrote:
you've checked the Voltage @ the MAF wiring? Probably could use a resistor (?) to lower to the 5V or whatever it should be. What does Wiring Trim mean? Merged harness?


I get battery voltage at the MAF sensor and have 5v at pin 5, and I also have a good ground.
As far as the harness trim, I simply trimmed the Legacy harness down to just the engine related wiring. I did not merge the harness (wish I did though).

_________________
07 Outback XT VF52
94 Legacy Sport, VF23, 550 RobTune, various other things
93 Legacy Touring Wagon EJ205 management and dash swap (in progress)
90 Loyale Turbo, EJ Turbo Swap, 2" lift
82 Brat, EJ22 swap, RX AWD trans w/ LSD rear, 5 lug 4 wheel disc.


Profile  Offline
Reply with quote  
 Post subject: Re: Burning up MAF's
PostPosted: Mon Apr 23, 2018 6:22 pm 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 27267
Location: Houston, Tx
Are you still having issues with MAF's?

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
Reply with quote  
 Post subject: Re: Burning up MAF's
PostPosted: Sat May 05, 2018 6:41 pm 
First Gear
Joined: Sat Sep 19, 2009 6:21 am
Posts: 220
Location: Orem, UT
Legacy777 wrote:
Are you still having issues with MAF's?


Yes, I haven't really done anything with it over the winter. But one thing that I did not mention before that I think may be related is that my fuel pump howls, sometimes it goes away. But I thought it was the factory pump so I upgraded to a Deatschwerks pump and still howls. So I'm wondering if it's not just isolated to just the MAF, but that the MAF is just the weakest part.

_________________
07 Outback XT VF52
94 Legacy Sport, VF23, 550 RobTune, various other things
93 Legacy Touring Wagon EJ205 management and dash swap (in progress)
90 Loyale Turbo, EJ Turbo Swap, 2" lift
82 Brat, EJ22 swap, RX AWD trans w/ LSD rear, 5 lug 4 wheel disc.


Profile  Offline
Reply with quote  
 Post subject: Re: Burning up MAF's
PostPosted: Mon May 07, 2018 6:32 pm 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 27267
Location: Houston, Tx
Hmmm, that's interesting about the howling fuel pump. If you've replaced the pump, are you sure it's the fuel pump that is howling?

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
Reply with quote  
 Post subject: Re: Burning up MAF's
PostPosted: Tue May 08, 2018 7:00 am 
First Gear
Joined: Sat Sep 19, 2009 6:21 am
Posts: 220
Location: Orem, UT
Legacy777 wrote:
Hmmm, that's interesting about the howling fuel pump. If you've replaced the pump, are you sure it's the fuel pump that is howling?


Oh yeah, it is quite clear where the noise is coming from. Once I put the upgraded fuel pump in it's hard to not notice anything else. I replaced the fuel pump thinking it was going bad and to double check the feed lines for blockage. I just found that nothing was wrong with either.

_________________
07 Outback XT VF52
94 Legacy Sport, VF23, 550 RobTune, various other things
93 Legacy Touring Wagon EJ205 management and dash swap (in progress)
90 Loyale Turbo, EJ Turbo Swap, 2" lift
82 Brat, EJ22 swap, RX AWD trans w/ LSD rear, 5 lug 4 wheel disc.


Profile  Offline
Reply with quote  
 Post subject: Re: Burning up MAF's
PostPosted: Sat Jul 07, 2018 10:07 pm 
First Gear
Joined: Sat Sep 19, 2009 6:21 am
Posts: 220
Location: Orem, UT
Well, I made a new discovery today. I found that when I pinch off the IAC the car will idle. Thinking I had a bad IAC I swapped it out to find the same results. I'm wondering If maybe I have bad wiring perhaps. I'm going to test the continuity of the wiring to see if wiring has been damaged.

_________________
07 Outback XT VF52
94 Legacy Sport, VF23, 550 RobTune, various other things
93 Legacy Touring Wagon EJ205 management and dash swap (in progress)
90 Loyale Turbo, EJ Turbo Swap, 2" lift
82 Brat, EJ22 swap, RX AWD trans w/ LSD rear, 5 lug 4 wheel disc.


Profile  Offline
Reply with quote  
 Post subject: Re: Burning up MAF's
PostPosted: Tue Jul 10, 2018 6:01 pm 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 27267
Location: Houston, Tx
Are you saying that if you pinch off the line supplying air to the IAC valve the car will idle ok? Does it not idle when you don't pinch off that line?

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
Reply with quote  
 Post subject: Re: Burning up MAF's
PostPosted: Sun Jul 22, 2018 6:57 pm 
First Gear
Joined: Sat Sep 19, 2009 6:21 am
Posts: 220
Location: Orem, UT
Legacy777 wrote:
Are you saying that if you pinch off the line supplying air to the IAC valve the car will idle ok? Does it not idle when you don't pinch off that line?


Exactly right. However, it would not drive well. I could make it up my drive way and into the garage in low range but it was a bit of a struggle. So I tested the wiring for the IAC and found everything to be in good shape. Frustrated I started over with my diagnosis. Do I have spark, yes. Do I have fuel, yes, but... When the fuel pump primes I get 40-45 psi, and then instantly drops to 0 psi. With these results I determined that pinching off the extra air for the IAC will allow it to run with the limited fuel supply.

So my new direction is fuel pump wiring and new pump. With the swap I used the factory wiring and relay. I found that my ground for the fuel pump had melted the casing a little bit and I remember the relay ran warm. I'm thinking of now just running a wire straight to the fuel pump and grounding it to the body after I replace the fuel pump and see if I'm still getting a loud whine from the fuel pump after bypassing the factory wiring.

_________________
07 Outback XT VF52
94 Legacy Sport, VF23, 550 RobTune, various other things
93 Legacy Touring Wagon EJ205 management and dash swap (in progress)
90 Loyale Turbo, EJ Turbo Swap, 2" lift
82 Brat, EJ22 swap, RX AWD trans w/ LSD rear, 5 lug 4 wheel disc.


Profile  Offline
Reply with quote  
 Post subject: Re: Burning up MAF's
PostPosted: Wed Jul 25, 2018 6:48 pm 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 27267
Location: Houston, Tx
If the fuel pressure doesn't hold then I would look at the regulator. Fuel pressure should stay up after the pump is primed. Based on my logs from my Link ECU, fuel pressure was at 43.5 psi with the key in the ON position and engine not running on initial startup. The fuel pump primes like to stock ECU and then shuts off.

Have you modified the fuel system at all?

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
Reply with quote  
 Post subject: Re: Burning up MAF's
PostPosted: Thu Jul 26, 2018 6:47 am 
First Gear
Joined: Sat Sep 19, 2009 6:21 am
Posts: 220
Location: Orem, UT
Legacy777 wrote:
If the fuel pressure doesn't hold then I would look at the regulator. Fuel pressure should stay up after the pump is primed. Based on my logs from my Link ECU, fuel pressure was at 43.5 psi with the key in the ON position and engine not running on initial startup. The fuel pump primes like to stock ECU and then shuts off.

Have you modified the fuel system at all?


I installed a DeatschWerks 255 fuel pump but other wise nothing else has been changed. Last night I put a factory pump back in and found the pressure to be holding around 30-42 but still having trouble getting the engine to run without crimping the IAC inlet tube. So I'm thinking fueling is not the issue and maybe the aftermarket pump does not have some type of check valve.

_________________
07 Outback XT VF52
94 Legacy Sport, VF23, 550 RobTune, various other things
93 Legacy Touring Wagon EJ205 management and dash swap (in progress)
90 Loyale Turbo, EJ Turbo Swap, 2" lift
82 Brat, EJ22 swap, RX AWD trans w/ LSD rear, 5 lug 4 wheel disc.


Profile  Offline
Reply with quote  
 Post subject: Re: Burning up MAF's
PostPosted: Thu Jul 26, 2018 5:49 pm 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 27267
Location: Houston, Tx
Does your throttle body have this little needle valve screw in it? Do you know if the throttle plate/stops have ever been adjusted? Have checked/tested the TPS sensor's idle switch?

Have you checked all the wiring from the MAF and other sensors back to the ECU to verify they have 0 ohms / good continuity as well as verify they are not shorted?

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
Reply with quote  
 Post subject: Re: Burning up MAF's
PostPosted: Sat Sep 08, 2018 8:34 pm 
First Gear
Joined: Sat Sep 19, 2009 6:21 am
Posts: 220
Location: Orem, UT
I went ahead and made a new harness and replaced the old one. Car started right up and has been running pretty well. I still need to wire in the VSS wire, I keep getting a code for that after a little bit of driving. The other night when I got home from work I did notice the fuel pump had started to whine like before. I have some suspension and steering concerns to address as well so I've decided to park it for a little bit while I order parts.

I'm wondering if possibly my alternator is putting out too much and in turn damaging the wiring? I have a 90 amp two wire alternator from a late 90's legacy/outback wired into the body's harness. I'm curious if if my "conversion" was not wired properly or if maybe I just need an external regulator.

_________________
07 Outback XT VF52
94 Legacy Sport, VF23, 550 RobTune, various other things
93 Legacy Touring Wagon EJ205 management and dash swap (in progress)
90 Loyale Turbo, EJ Turbo Swap, 2" lift
82 Brat, EJ22 swap, RX AWD trans w/ LSD rear, 5 lug 4 wheel disc.


Profile  Offline
Reply with quote  
 Post subject: Re: Burning up MAF's
PostPosted: Mon Sep 10, 2018 6:00 pm 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 27267
Location: Houston, Tx
I have a similar 90 amp HO alternator and it's fine. Have you checked the voltage? If so, what is it outputting?

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
Reply with quote  
 Post subject: Re: Burning up MAF's
PostPosted: Tue Sep 11, 2018 6:19 am 
First Gear
Joined: Sat Sep 19, 2009 6:21 am
Posts: 220
Location: Orem, UT
Legacy777 wrote:
I have a similar 90 amp HO alternator and it's fine. Have you checked the voltage? If so, what is it outputting?


Last I remember I have 14v at the battery and am also reading on the dash.

_________________
07 Outback XT VF52
94 Legacy Sport, VF23, 550 RobTune, various other things
93 Legacy Touring Wagon EJ205 management and dash swap (in progress)
90 Loyale Turbo, EJ Turbo Swap, 2" lift
82 Brat, EJ22 swap, RX AWD trans w/ LSD rear, 5 lug 4 wheel disc.


Profile  Offline
Reply with quote  
 Post subject: Re: Burning up MAF's
PostPosted: Tue Sep 11, 2018 5:40 pm 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 27267
Location: Houston, Tx
That is a normal and regular voltage, so I don't know if I'd say that's your problem.

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
Reply with quote  
 Post subject: Re: Burning up MAF's
PostPosted: Tue Sep 11, 2018 5:41 pm 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 27267
Location: Houston, Tx
Out of curiosity have you checked the 5v reference voltage going to the MAF from the ECU? Maybe that is high or low.

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
Reply with quote  

Display posts from previous:  Sort by  

Post new topic Reply to topic  [ 18 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest

Panel

Top You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
Search for:
Jump to:  
 cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Dizayn Ercan Koc