Eratic idle?

Headlights to tailights and everything in between.

Moderators: Helpinators, Moderators

Post Reply
isleymerl
In Neutral
Posts: 7
Joined: Mon Dec 21, 2009 9:33 pm

Eratic idle?

Post by isleymerl » Mon May 16, 2011 6:54 am

My 1991 legacy turbo has been idling weird since doing some upgrades. Every once in a while it will idle low and act like it wants to die but at the last second it revs back up to about 2000 rpm's and does this over and over again. I can tell when it's staring to do this while driving cause it will accelerate up to wherever I have the throttle to but then it drops a tiny bit. Then if I barely touch the pedal it jumps a little and drive fine when accelerating. This only started happening after installing a larger turbo, intercooler, cold air intake, and replacing the IAC with one out of my old car. I also just replaced the Maf sensor with the one from my old car. My old car never had this problem. It is not showing any engine codes either.

Any thoughts?

kimokalihi
Fifth Gear
Posts: 8360
Joined: Mon Nov 06, 2006 3:41 am
Location: Tenino, WA

Re: Eratic idle?

Post by kimokalihi » Mon May 16, 2011 10:32 am

I would guess it's the IAC. Maybe try cleaning it? Check the factory service manual for the procedure to test it and get a multimeter and test to see if it's within spec.
98 Metro Hatch Daily Driver :)
91 SS EJ20G Engine/Tranny/Diff Swap Build Thread Here
"Your testes are close to your bottom but you still play with them all the time." Jeremy Clarkson

isleymerl
In Neutral
Posts: 7
Joined: Mon Dec 21, 2009 9:33 pm

Re: Eratic idle?

Post by isleymerl » Mon May 16, 2011 7:22 pm

Thanks. I'll check it out.

Post Reply