»  BC-BF Legacy Discussion »  Electrical
#Anyone else come across this ?

Custom Search
Login | Register




Post new topic Reply to topic  [ 9 posts ] 
Author Message
 Post subject: Anyone else come across this ?
PostPosted: Fri Jun 04, 2010 8:47 pm 
Second Gear
Joined: Tue Oct 14, 2008 6:33 am
Posts: 279
Location: Tantallon, NS
does the 1991 subaru legacy turbo from Japan have different stereo wiring than the legacys made in the US ?

the radio wires behind the original tapedeck - From Japan - do not match the diagrams found over the internet ?!

this is wht i find,

1990-93 Subaru Legacy Stereo Wiring
Constant 12V+ Red/Green
Switched 12V+ Blue/Yellow
Ground Black
Illumination Red
Dimmer n/a
Antenna Left Rear
Front Speakers 6 1/2" Doors
Left Front (+) Yellow
Left Front (-) Blue/Red
Right Front (+) White
Right Front (-) Blue/Black
Rear Speakers 6 1/2" Rear Deck
Left Rear (+) Yellow/White
Left Rear (-) Blue/Red
Right Rear (+) White/Blue
Right Rear (-) Blue/Black


for one i do not have a solid yellow , or red/green ?!

_________________
N1446 Brutus
91 Legacy SS 5mt 2.5GT Swap
Legacy GT Suspension, 16" Fozzy Wheels, 2.5RS OBX EL Headers, Gutted Mid-Pipe, Subaru Catback c/w AWD BABY !


Last edited by N1446 on Sat Jun 05, 2010 2:04 am, edited 2 times in total.

Profile  Offline
Reply with quote  
 Post subject: Re: Japan stereo wiring different than US ?
PostPosted: Fri Jun 04, 2010 11:25 pm 
Fourth Gear
Joined: Tue Jan 06, 2009 5:06 am
Posts: 1162
Location: Renton, WA
Don't really have an answer, but the red and black wires should be the same, and if the speaker wiring is stock all you need to do is take out the speaker to see what wire goes to what. That just leaves constand 12V and switched 12V which should be easy enough with a multimeter


Profile  Offline
Reply with quote  
 Post subject: Re: Japan stereo wiring different than US ?
PostPosted: Sat Jun 05, 2010 1:59 am 
Second Gear
Joined: Tue Oct 14, 2008 6:33 am
Posts: 279
Location: Tantallon, NS
It is all stock

I got it all installed and tested for balance and fader so it works almost perfect as the radio saves no memory

the head unit i have states that even with the ignition turned-off, when the main power wire to 12V+ the current to the memory will be constant so it will save the setting when the key is removed

the headunit does not save settings in this configuration and has zero power with the ignition off

leads me to believe when the ignition is turned off NO power passes to the radio

I removed this headunit from a newer car i have and it does operate like it should in that car, saving settings and everything



1991 Legacy Turbo 5mt stereo wiring loom

Constant 12V+ Yellow /Red these are the same
Switched 12V+ Yellow /Red
Ground Black
Front Speakers 6 1/2" Doors
Left Front (+) Green
Left Front (-) White/Brown
Right Front (+) Red/ Yellow
Right Front (-) White/Black
Rear Speakers 6 1/2" Rear Deck
Left Rear (+) Red/Black
Left Rear (-) White/Red
Right Rear (+) Blue/Yellow
Right Rear (-) White/Red

i m left with a few wires un-used from the wiring loom,

Yellow/Blue
Blue/Red
Green
Black/Green - this one has current with the ignition off as well

i have no clue about these wires tho i imagine one is for the power antenna that i do not use

_________________
N1446 Brutus
91 Legacy SS 5mt 2.5GT Swap
Legacy GT Suspension, 16" Fozzy Wheels, 2.5RS OBX EL Headers, Gutted Mid-Pipe, Subaru Catback c/w AWD BABY !


Profile  Offline
Reply with quote  
 Post subject: Re: Anyone else come across this ?
PostPosted: Tue Nov 16, 2010 9:05 pm 
First Gear
Joined: Tue May 04, 2010 1:45 am
Posts: 118
Location: Kamloops, BC
Did you ever resolve this issue? I'm having the same thing happen in my 92 T Leg.


Profile  Offline
Reply with quote  
 Post subject: Re: Anyone else come across this ?
PostPosted: Tue Nov 16, 2010 11:49 pm 
Fifth Gear
Joined: Mon Nov 06, 2006 3:41 am
Posts: 8352
Location: Tenino, WA
Only wire that should have constant 12v is blue/red. Black/green is power antenna.

Image

_________________
98 Metro Hatch Daily Driver :)
91 SS EJ20G Engine/Tranny/Diff Swap Build Thread Here
"Your testes are close to your bottom but you still play with them all the time." Jeremy Clarkson


Profile  Offline
Reply with quote  
 Post subject: Re: Anyone else come across this ?
PostPosted: Wed Nov 17, 2010 5:38 am 
First Gear
Joined: Tue May 04, 2010 1:45 am
Posts: 118
Location: Kamloops, BC
beauty, stupid me had the battery and switch power mixed up.


Profile  Offline
Reply with quote  
 Post subject: Re: Anyone else come across this ?
PostPosted: Thu May 31, 2012 11:29 pm 
In Neutral
Joined: Thu May 17, 2012 7:06 am
Posts: 10
Bringing this back from the dead. Some one should sticky this or something. All other diagrams other than the one kimokalihi posted, were incorrect. Thanks for the help :) installed my new Kenwood deck and component speakers today.


Profile  Offline
Reply with quote  
 Post subject: Re: Anyone else come across this ?
PostPosted: Sat Jun 09, 2012 7:13 pm 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 27306
Location: Houston, Tx
Added to the sticky compilation thread.

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
Reply with quote  
 Post subject: Re: Anyone else come across this ?
PostPosted: Sat Sep 30, 2017 2:03 am 
Knowledgeable
Knowledgeable
Joined: Tue Oct 15, 2002 8:16 pm
Posts: 4387
Location: SFCA
The arrows are fucking reversed on the diagram!
Image


Profile  Offline
Reply with quote  

Display posts from previous:  Sort by  

Post new topic Reply to topic  [ 9 posts ] 


Who is online

Users browsing this forum: No registered users and 4 guests

Panel

Top You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Dizayn Ercan Koc