Cutting at 3k RPM, Vacuum Leak?

That spinning thing that makes all of the cool noises. OE and Aftermarket.

Moderators: Helpinators, Moderators

swerveburd
In Neutral
Posts: 48
Joined: Wed Apr 03, 2013 6:48 pm
Location: Davenport, IA

Cutting at 3k RPM, Vacuum Leak?

Post by swerveburd »

Okay. So here's my issue. I installed a TD04 from a fellow legacy central user and a 06 TMIC. I used the Samco y-pipe and cut it to fit with the exhaust tube per other install posts. Everything seems to be hooked up but the 90 degree silicon coming from the compressor outlet could be better. Im going to replace it in the next few days.

PRIOR TO INSTALL MY CAR RAN GREAT

My problem is this:

First off, starting the car, it idles at aroun 1500 RPM and stays there in park. Once i put it in drive the idle cools down to 1000 rpm but jumps two 2500 randomly or in between 1st and 2nd gears. I believe this is due to me unscrewing the TPS and not installing it correctly again. I also adjusted the throttle cables due to the slack in the cable lines. I DID NOT touch the idle screw or stopper. FYI- the springs on my TB are old and rusted, with a small chunk of spring completely gone. I will replace the entire TB this weekend with a N/A 1990 EJ22 TB including the TPS. Hopefully this should solve my idle issue.

Secondly, I cannot hold and boost at all. Once the car hits 3,000 RPM the engine cuts. If I try to hold the gas down the car will not gain speed or power. I can accelerate to 3,000 rpm fine but once it hits 3k it just stops, as if the ECU is fuel cutting. I'm not hearing any major leaks but I imagine there is a leak somewhere.

I have done the old fashioned Carb Cleaner spray trick to look and listen for leaks without much success. I really need to get my car working again soon, any help would be great.

I ordered a cheap MBC from ebay which should be here soon. I am hoping that if my BCS is not working properly then this could solve my problem. From previous posts, I understand that if the BCS is not working then you get fuel cut at 0 psi.

I'm going to look for leaks and finish hooking up my boost gauge tonight.

Here's a video of my car running and cutting out at 3,000- RPM:



[url] [url]

I can post more pictures of my vacuum/boost lines this evening. Heading to the shop now. Any help or input would be great! Thanks guys!
1993 Legacy Turbo Touring Wagon....TD04, TMIC, HkS BOV, coffee can, De-snork, TB Exhaust, VLSD, MSD Coil, Walbro 255, Fresh Paint, WRX 16's, WRX Suspension, New Brakes....soon Robtune...
cj91legss
Fifth Gear
Posts: 6317
Joined: Fri Jun 20, 2008 8:17 am
Location: Lakewood, Wa 98439
Contact:

Re: Cutting at 3k RPM, Vacuum Leak?

Post by cj91legss »

More pictures would be really helpful for us to help you diagnose what is wrong. But you either have the MAP or Pressure Exchange Solenoid hooked up wrong OR you may have your boost lines backwards and the turbo is just trying to boost as much as possible... I'm leaning more towards my second option.

Make sure you have your vacuum lines going in the right direction per this EJ22t Vacuum Diagram
91 L-TW Wagon with a full Swap -RIP
92 SS Prefaced, GD dash swapped, 22T/205 Hybrid 20 psi - BEAST!
93 SS Bone Stock Gone!
94 TW Bone Stock Gone!
91 SS 4EAT Sold!
98 LGT 4EAT
98 LGT Wagon 4EAT
swerveburd
In Neutral
Posts: 48
Joined: Wed Apr 03, 2013 6:48 pm
Location: Davenport, IA

Re: Cutting at 3k RPM, Vacuum Leak?

Post by swerveburd »

Here's a pic of my current install. I have been hearing whooshing sounds which leads me to think its a leak on the intake side.

Picked up a used ej22 NA Throttle Body. Will the NA TPS work hooked up to my ej22t ecu?


Okay. Let me know if y'all think of anything. I'm gonna search for this leak. And yes I have been following the diagram the best I can. http://m.youtube.com/#/watch?feature=yo ... ata_player

Couldn't get photo to load via photobucket so please check my video.
1993 Legacy Turbo Touring Wagon....TD04, TMIC, HkS BOV, coffee can, De-snork, TB Exhaust, VLSD, MSD Coil, Walbro 255, Fresh Paint, WRX 16's, WRX Suspension, New Brakes....soon Robtune...
swerveburd
In Neutral
Posts: 48
Joined: Wed Apr 03, 2013 6:48 pm
Location: Davenport, IA

Re: Cutting at 3k RPM, Vacuum Leak?

Post by swerveburd »

Just changed the oil and noticed some heavy whooshing sounds. I'm guessing its a leak on the compressor side between the TB and the IC.

1.) These are my questions, I know legacy777 told me that the NA EJ22 TB will work with my car but can I use the NA TPS with my ecu?

2.) does a leak cause this quick of a cut per my video above?

Thanks
1993 Legacy Turbo Touring Wagon....TD04, TMIC, HkS BOV, coffee can, De-snork, TB Exhaust, VLSD, MSD Coil, Walbro 255, Fresh Paint, WRX 16's, WRX Suspension, New Brakes....soon Robtune...
cj91legss
Fifth Gear
Posts: 6317
Joined: Fri Jun 20, 2008 8:17 am
Location: Lakewood, Wa 98439
Contact:

Re: Cutting at 3k RPM, Vacuum Leak?

Post by cj91legss »

Yes the na tps will work. Dont know that a leak between the tb and the intercooler will cause fuel cut. Dont see your pic either...

Sent from my SGH-T989 using Tapatalk 2
91 L-TW Wagon with a full Swap -RIP
92 SS Prefaced, GD dash swapped, 22T/205 Hybrid 20 psi - BEAST!
93 SS Bone Stock Gone!
94 TW Bone Stock Gone!
91 SS 4EAT Sold!
98 LGT 4EAT
98 LGT Wagon 4EAT
swerveburd
In Neutral
Posts: 48
Joined: Wed Apr 03, 2013 6:48 pm
Location: Davenport, IA

Re: Cutting at 3k RPM, Vacuum Leak?

Post by swerveburd »

While driving home from the shop last night I could hear a fairly loud whooshing sound coming from around my turbo/intake area. I have de-snorkeled, coffee-canned, stock filter box, td04.

1.) Is this noise normal with these mods or is it the the leak i think it is?

2.) Are there replacement springs for the TB throttle cables?

3.) HAve others had trouble with the A/C line being in the way of the TMIC??? WHat do you do?




Here's a pic of my current setup. Thinking of rebuilding my install this weekend to search for leaks.

Image

(blue tape for placement reminders)
1993 Legacy Turbo Touring Wagon....TD04, TMIC, HkS BOV, coffee can, De-snork, TB Exhaust, VLSD, MSD Coil, Walbro 255, Fresh Paint, WRX 16's, WRX Suspension, New Brakes....soon Robtune...
Legacy777
Site Admin
Site Admin
Posts: 27750
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: Cutting at 3k RPM, Vacuum Leak?

Post by Legacy777 »

I would suggest fixing the known issues first before proceeding any further with troubleshooting. You know the TPS/TB is bad, so replace that and then see how the car runs. Have you checked the ECU for any stored codes and run the active diagnostic with the green connectors?
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
2020 Outback Limted XT

If you need to get a hold of me please email me rather then pm
swerveburd
In Neutral
Posts: 48
Joined: Wed Apr 03, 2013 6:48 pm
Location: Davenport, IA

Re: Cutting at 3k RPM, Vacuum Leak?

Post by swerveburd »

Legacy777 to the rescue once again...

I just got a used NA eJ22 TB yesterday. I will clean it and install it.

Can you replace the springs on the TB?

Okay I have cleared the ECU per the instructions found on this bbs.

When I turn the key to "on" without cranking, the CEL comes on but does not flash on and off. Once I turn on the engine, all lights turn off and stay off. I don't pull any CEL when running. The video on my first post shows the car running and cutting out at 3,000 Rpm. No power still!
1993 Legacy Turbo Touring Wagon....TD04, TMIC, HkS BOV, coffee can, De-snork, TB Exhaust, VLSD, MSD Coil, Walbro 255, Fresh Paint, WRX 16's, WRX Suspension, New Brakes....soon Robtune...
Legacy777
Site Admin
Site Admin
Posts: 27750
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: Cutting at 3k RPM, Vacuum Leak?

Post by Legacy777 »

Have you tried pulling the codes by connecting the diagnostic connectors?

www.surrealmirage.com/subaru/engine.html

I don't think the springs can be replaced without taking apart the TB. Are the springs on the non-turbo TB bad? If not, just swap the entire thing over.
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
2020 Outback Limted XT

If you need to get a hold of me please email me rather then pm
swerveburd
In Neutral
Posts: 48
Joined: Wed Apr 03, 2013 6:48 pm
Location: Davenport, IA

Re: Cutting at 3k RPM, Vacuum Leak?

Post by swerveburd »

Pulled everything off today. Found my problems I believe

The F-pipe breather was disconnected at the block. That sucker is hard to reach! Probably was causing my boost loss.

Disconnecting my TB now. Draining the coolant first. After examining the replacement TB I can see the factory paint marks which indicate factory presettings. I definantly messed the factory TPS position. The replacement has not been touched. Should fix my idle issue.

After a few more silicon parts arrive I should have most everything solved.

Last question.

Anyone have experience with the air conditioning ? I want to keep it but the damn line is in the way of my TMIC.
Can I replace the metal part with rubber? Anyone??
1993 Legacy Turbo Touring Wagon....TD04, TMIC, HkS BOV, coffee can, De-snork, TB Exhaust, VLSD, MSD Coil, Walbro 255, Fresh Paint, WRX 16's, WRX Suspension, New Brakes....soon Robtune...
Legacy777
Site Admin
Site Admin
Posts: 27750
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: Cutting at 3k RPM, Vacuum Leak?

Post by Legacy777 »

What most people do is loosen the line enough or bend it so it runs underneath the dog bone (trans mount)
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
2020 Outback Limted XT

If you need to get a hold of me please email me rather then pm
swerveburd
In Neutral
Posts: 48
Joined: Wed Apr 03, 2013 6:48 pm
Location: Davenport, IA

Re: Cutting at 3k RPM, Vacuum Leak?

Post by swerveburd »

So I installed a used TB, removed the a/c line, installed a MBC and a boost gauge.


I fixed the vacuum leak I thought I had.

Now when I start the car it Idles at 3k and then when I drive it still cuts out at 3,000 rpm


I have -20 at idle on my Gauge and it reads around 7 psi when it cuts out


Please help! I've been working so hard trying to fix my car!
1993 Legacy Turbo Touring Wagon....TD04, TMIC, HkS BOV, coffee can, De-snork, TB Exhaust, VLSD, MSD Coil, Walbro 255, Fresh Paint, WRX 16's, WRX Suspension, New Brakes....soon Robtune...
Legacy777
Site Admin
Site Admin
Posts: 27750
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: Cutting at 3k RPM, Vacuum Leak?

Post by Legacy777 »

You didn't answer my question from above, have you tried pulling the codes or doing the active diagnostic on the ECU? If not, give that a try and see if anything comes up.
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
2020 Outback Limted XT

If you need to get a hold of me please email me rather then pm
swerveburd
In Neutral
Posts: 48
Joined: Wed Apr 03, 2013 6:48 pm
Location: Davenport, IA

Re: Cutting at 3k RPM, Vacuum Leak?

Post by swerveburd »

21- water temp sensor
42- idle switch
45-pressure exchange solenoid
31- throttle sensor
1993 Legacy Turbo Touring Wagon....TD04, TMIC, HkS BOV, coffee can, De-snork, TB Exhaust, VLSD, MSD Coil, Walbro 255, Fresh Paint, WRX 16's, WRX Suspension, New Brakes....soon Robtune...
swerveburd
In Neutral
Posts: 48
Joined: Wed Apr 03, 2013 6:48 pm
Location: Davenport, IA

Re: Cutting at 3k RPM, Vacuum Leak?

Post by swerveburd »

I'm stumped. So many issues... I'm ready to being it to a shop.
1993 Legacy Turbo Touring Wagon....TD04, TMIC, HkS BOV, coffee can, De-snork, TB Exhaust, VLSD, MSD Coil, Walbro 255, Fresh Paint, WRX 16's, WRX Suspension, New Brakes....soon Robtune...
Legacy777
Site Admin
Site Admin
Posts: 27750
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: Cutting at 3k RPM, Vacuum Leak?

Post by Legacy777 »

Ok, try the green diagnostic connectors to see what active codes are stored. Then clear the codes, and see what comes back. If you're still getting the throttle & idle switch codes, then there may be a wiring issue.
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
2020 Outback Limted XT

If you need to get a hold of me please email me rather then pm
swerveburd
In Neutral
Posts: 48
Joined: Wed Apr 03, 2013 6:48 pm
Location: Davenport, IA

Re: Cutting at 3k RPM, Vacuum Leak?

Post by swerveburd »

Yea I think I have some vacuum hoses hooked up wrong but I will try again soon


I've been workin hard in the sun these days. I will run the green diagnostic tomorrow and try clearing the codes again


Last time I was in the process of resetting the ecu and during my 10+mph drive codes 21 and 45 kept flashing.

If I can get the car to run right by this weekend I'm taking to a dyno shop for help. Thanks for your patience and help. Respect
1993 Legacy Turbo Touring Wagon....TD04, TMIC, HkS BOV, coffee can, De-snork, TB Exhaust, VLSD, MSD Coil, Walbro 255, Fresh Paint, WRX 16's, WRX Suspension, New Brakes....soon Robtune...
Legacy777
Site Admin
Site Admin
Posts: 27750
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: Cutting at 3k RPM, Vacuum Leak?

Post by Legacy777 »

If you try and reset the codes or run the active diagnostic and you have specific codes that come up, those are probably active codes and need to be addressed.
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
2020 Outback Limted XT

If you need to get a hold of me please email me rather then pm
swerveburd
In Neutral
Posts: 48
Joined: Wed Apr 03, 2013 6:48 pm
Location: Davenport, IA

Re: Cutting at 3k RPM, Vacuum Leak?

Post by swerveburd »

Hey just wanted to finally follow up.

I've spent my whole summer and most of the winter rebuilding this rusty wagon. She's rust free and freaky painted. New brakes, suspension, rims, tires, and bov.

After not being able to find any solutions to my above problem I took my TW to Corbinn at CIT Performance in Peoria, IL. He helped track down my boost leaks and installed an HKS BOV.

The car pulls hard until about 5k now. The mechanic removed my cheap MBC and hooked up the stock BCS. I am running a max of 11 psi. According to my gauge. The vacuum leaks should all be fixed by now and there shouldn't be fuel cut I thought till around 14psi. On the stock pump and injectors.

After a Subie tech inspected and drove my car he said the 4EAT was fine but my front diff was leaking. I previously thought my tranny could be slipping but he confirmed that it was not. The engine is either cutting fuel from a knock sensor or something else is telling the ecu to cut fuel at 5k


I'm unable to downshift hard and when I do the car cuts power abruptly and only has minimal power. The boost gauge will drop to vacuum on hard down shifts and cut boost. If I accelerate slowly the TW glides along great. At WOT I'm barely moving.

Any suggestions Josh or anyone?

Once again thanks for all your patience. This has been a long road.

I will pull codes again for u josh cause I know u want me to
1993 Legacy Turbo Touring Wagon....TD04, TMIC, HkS BOV, coffee can, De-snork, TB Exhaust, VLSD, MSD Coil, Walbro 255, Fresh Paint, WRX 16's, WRX Suspension, New Brakes....soon Robtune...
turbo970
Third Gear
Posts: 859
Joined: Sun Jul 15, 2012 11:50 pm
Location: sw colorado

Re: Cutting at 3k RPM, Vacuum Leak?

Post by turbo970 »

make sure you tps wires are in the right order. that was my issue after a "professional shop put a new tps plug and put my rebuilt motor in.
turbo970
Third Gear
Posts: 859
Joined: Sun Jul 15, 2012 11:50 pm
Location: sw colorado

Re: Cutting at 3k RPM, Vacuum Leak?

Post by turbo970 »

Here is how they should be wired up.

http://www.main.experiencetherave.com/s ... connector/

Just to note that my pictures are from the opposite side of the electrical connector.
swerveburd
In Neutral
Posts: 48
Joined: Wed Apr 03, 2013 6:48 pm
Location: Davenport, IA

Re: Cutting at 3k RPM, Vacuum Leak?

Post by swerveburd »

That link you posted was broken turbo. I have replaced my TPS when I replaced the entire TB from a NA Legacy. Maybe the TPS is reading something wrong still. I can do the TPS test but I really don't think that's the issue.

Did u have the same issue as I did Turbo?
1993 Legacy Turbo Touring Wagon....TD04, TMIC, HkS BOV, coffee can, De-snork, TB Exhaust, VLSD, MSD Coil, Walbro 255, Fresh Paint, WRX 16's, WRX Suspension, New Brakes....soon Robtune...
turbo970
Third Gear
Posts: 859
Joined: Sun Jul 15, 2012 11:50 pm
Location: sw colorado

Re: Cutting at 3k RPM, Vacuum Leak?

Post by turbo970 »

yup and it turned out the wires into the tps connector were out of order. i'll try to get the link to so the proper order

heres the link

http://www.main.experiencetherave.com/s ... connector/
Legacy777
Site Admin
Site Admin
Posts: 27750
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: Cutting at 3k RPM, Vacuum Leak?

Post by Legacy777 »

Yeah, I'd like to know if there are any codes stored :)

If you bypass the boost control solenoid and plug the line from the compressor outlet on the turbo directly into the wastegate solenoid actuator it should limit boost to around 5 psi. Try this and see if you can rev past 5k.
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
2020 Outback Limted XT

If you need to get a hold of me please email me rather then pm
swerveburd
In Neutral
Posts: 48
Joined: Wed Apr 03, 2013 6:48 pm
Location: Davenport, IA

Re: Cutting at 3k RPM, Vacuum Leak?

Post by swerveburd »

Ok boys. I've been reading this forum so much that it rolls through my brain before I go to sleep. Man....I never thought I'd learn so much about subaru.

I did a ECU test and came up with codes 23 and 49.

After searching the site I found this : http://bbs.legacycentral.org/viewtopic. ... 6&start=50

This guy spent a lot of time running around trying to source a problem while avoiding the fuel pressure. Just like me. It turns out he just needed to clear his lines and he was good. I need a new pump I'm sure so it will be here in a few days. I have the exact same issues as the link above and the same codes. I know it's this now.

When the pump gets here I will let everyone know. Wow what a long hard road it's been.

Gonna install an MSD SRT4 Coil pack just because as well.

Thanks dudes!
1993 Legacy Turbo Touring Wagon....TD04, TMIC, HkS BOV, coffee can, De-snork, TB Exhaust, VLSD, MSD Coil, Walbro 255, Fresh Paint, WRX 16's, WRX Suspension, New Brakes....soon Robtune...
Post Reply