No boost and code 22 after fuel refill.

That spinning thing that makes all of the cool noises. OE and Aftermarket.

Moderators: Helpinators, Moderators

Post Reply
troymclee
In Neutral
Posts: 3
Joined: Wed Aug 14, 2013 10:54 am

No boost and code 22 after fuel refill.

Post by troymclee »

Hi ya ,im new around here and new to legacies.

I purchased my first 99 B4 RSK t/t 2.0 litre..she was totally doing fine,the boost was perfect .
On my way back i was forced to pump 95 octane there were no 98 fuel stations to be found,the car ran smooth until i did my second refill 2 days later with 98.I ran a few miles and stopped at work next time i cranked her up boom ! the engine light is on,Few miles down the road the engine light went off .

The car didn't boost much,i connected the black connectors and the code was 22 (knock sensor).
I just went for a ride with both green connector and black connector on the car was giving steady flashes,did the normal erase procedure, no engine lights nothing she boosts pretty well as she used to above 3k rpm.But she still feels sluggish between 1.5k-2.5 k

I am pretty much worried,its worth my whole student life earnings and i think the knock sensor is totally fine .
what caused the knock ? , Is it not good to mix 98 with 95 because she ran smooth on 95 but bad on 98 .
wtdash
Fifth Gear
Posts: 2326
Joined: Fri May 04, 2007 4:09 pm
Location: N. ID

Re: No boost and code 22 after fuel refill.

Post by wtdash »

Hi and Welcome!

Are U from the UK?

I'd pull the knock sensor and check for cracks. Your '99 should have the newer style, but I'd still check it.

When the KS is bad it'll cause a 'limp mode', which will affect performance.

When you use anything less than the 98 octane, drive it easy. Do you have 'octane booster' @ the local auto parts stores? I'd carry a bottle around in case you have to fill w/95 again.



GL,
TD.

(P.s. If you can get AWIC/WAIC systems and are willing to ship, please let me know!)
Turbo Subies:
'87 GL-10 Turbo - SOLD
'90 BJ EJ22T/DOHC & 5speed swap - SOLD
'04 FXT, Forged internals, VF39, STI TMIC, Cobb AP- SOLD
'93 Legacy SS - 5-speed, SOLD :-(
'02 WRX -SOLD
'96 BD-turbo'd-SOLD
'98 SF - NA-T
troymclee
In Neutral
Posts: 3
Joined: Wed Aug 14, 2013 10:54 am

Re: No boost and code 22 after fuel refill.

Post by troymclee »

hey thanks alot,i'm based in new zealand :-D

I'm running only 98 from now,
I cleared the fault codes by connecting the green and black connectors.
But i still feel there is less boost,should get a boost gauge
to confirm .
Legacy777
Site Admin
Site Admin
Posts: 27748
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: No boost and code 22 after fuel refill.

Post by Legacy777 »

More than likely the lower octane fuel just caused issues. Once you've gotten all the lower octane fuel out of the tank, reset the ECU, (disconnect battery for 45-60 minutes), and then drive the car around. The clear memory procedure just clears the codes and doesn't typically clear the learned fuel trims.
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
2020 Outback Limted XT

If you need to get a hold of me please email me rather then pm
troymclee
In Neutral
Posts: 3
Joined: Wed Aug 14, 2013 10:54 am

Re: No boost and code 22 after fuel refill.

Post by troymclee »

hi the car is doing pretty much fine now,back to its original boost conditions
I would like to know what RPM do the primary and secondary turbos kick in ,

From 2K-3.5K i get a strong 10-12 psi, i dont know which is the secondary which is the primary ,below 2 K i get just 1 psi !
Someperson
Fourth Gear
Posts: 1034
Joined: Wed Sep 19, 2012 3:58 am
Location: Plaistow,NH

Re: No boost and code 22 after fuel refill.

Post by Someperson »

Your turbos don't spool until 2k. They're always working.
Blue 94GT dead and steadily parting out.
Silver 93 Fwd N/A sedan undergoing repairs
93 Winestone TW project
92 SS scrapped by my landlord...
Post Reply