VF30 boost issue

That spinning thing that makes all of the cool noises. OE and Aftermarket.

Moderators: Helpinators, Moderators

Post Reply
92legacyawdturbo
First Gear
Posts: 74
Joined: Thu Aug 29, 2013 12:35 am
Location: Arvada, Colorado

VF30 boost issue

Post by 92legacyawdturbo »

Alright so I am curious and mind boggled and would like some of yours guys opinion on what I can try next to see if can fix the issue. Basically 1st gear only does like 10lbs which is normal I assume since its quick. 2nd and 3rd gear hit 14-15 lbs then after a second or two drop to about 6lbs. 4th gear holds 18lbs then will drop to 6lbs as well. So far I have tried going through the intercooler piping and put new t clamps on to make sure there were no issues there and made sure no holes were in the piping itself. Next I thought well maybe bad wastegate so replaced it with another wastegate and same issue. Ok well my next thought was maybe boost controller so I currently run a halman boost controller. Swapped it with another halman and even grimspeed, the issue is still there. There is no shaft play in the turbo at all either. So if I could get some other ideas where to go next on the issue would surely appreciate it as would like to hold a steady boost. Thanks
1992 Awd Legacy Turbo Sedan
cj91legss
Fifth Gear
Posts: 6317
Joined: Fri Jun 20, 2008 8:17 am
Location: Lakewood, Wa 98439
Contact:

Re: VF30 boost issue

Post by cj91legss »

Differences in boost under load always vary. That one thing that sick about a mbc. But not from 18 to 6 psi.

Maybe you should fork over the dough and get an electronic controller. It's a worthy investment.
91 L-TW Wagon with a full Swap -RIP
92 SS Prefaced, GD dash swapped, 22T/205 Hybrid 20 psi - BEAST!
93 SS Bone Stock Gone!
94 TW Bone Stock Gone!
91 SS 4EAT Sold!
98 LGT 4EAT
98 LGT Wagon 4EAT
wtdash
Fifth Gear
Posts: 2327
Joined: Fri May 04, 2007 4:09 pm
Location: N. ID

Re: VF30 boost issue

Post by wtdash »

Hi,

When I had a TD04 w/a hose that ran from the turbo to a 'coffee cup mod', I had a similar issue...the hose was collapsing.

If you're running a VF30 you must have fabbed up an intake that involves some silicone hoses? If you have any unsupported length of hose it likely will COLLAPSE under boost, which would drop your PSI's.


GL,
TD
Turbo Subies:
'87 GL-10 Turbo - SOLD
'90 BJ EJ22T/DOHC & 5speed swap - SOLD
'04 FXT, Forged internals, VF39, STI TMIC, Cobb AP- SOLD
'93 Legacy SS - 5-speed, SOLD :-(
'02 WRX -SOLD
'96 BD-turbo'd-SOLD
'98 SF - NA-T
92legacyawdturbo
First Gear
Posts: 74
Joined: Thu Aug 29, 2013 12:35 am
Location: Arvada, Colorado

Re: VF30 boost issue

Post by 92legacyawdturbo »

Well running a front mount and running basically a 90 off each side silicone hose wise. Will check some more on it tomorrow during daylight.
1992 Awd Legacy Turbo Sedan
kimokalihi
Fifth Gear
Posts: 8360
Joined: Mon Nov 06, 2006 3:41 am
Location: Tenino, WA

Re: VF30 boost issue

Post by kimokalihi »

Same thing happened to my friend Robert. He kept saying it was fuel cut. Turned out to be the turbo inlet hose he used was radiator hose and it was collapsing under load and suffocating the engine. Silicone hose fixed that.
98 Metro Hatch Daily Driver :)
91 SS EJ20G Engine/Tranny/Diff Swap Build Thread Here
"Your testes are close to your bottom but you still play with them all the time." Jeremy Clarkson
92legacyawdturbo
First Gear
Posts: 74
Joined: Thu Aug 29, 2013 12:35 am
Location: Arvada, Colorado

Re: VF30 boost issue

Post by 92legacyawdturbo »

I will check in the morning time. Running a fuel cut defender when had the TD04 was no issue with fuel cut once I installed that. I am thinking the VF30 pulls more than the TD04 and as why it may be possibly collapsing.
1992 Awd Legacy Turbo Sedan
kimokalihi
Fifth Gear
Posts: 8360
Joined: Mon Nov 06, 2006 3:41 am
Location: Tenino, WA

Re: VF30 boost issue

Post by kimokalihi »

My friend had a td04 he just installed when he had this issue so that's certainly capable depending on what hose you're using.
98 Metro Hatch Daily Driver :)
91 SS EJ20G Engine/Tranny/Diff Swap Build Thread Here
"Your testes are close to your bottom but you still play with them all the time." Jeremy Clarkson
92legacyawdturbo
First Gear
Posts: 74
Joined: Thu Aug 29, 2013 12:35 am
Location: Arvada, Colorado

Re: VF30 boost issue

Post by 92legacyawdturbo »

Alright after some more testing this is what I think appears to be happening, sorry havent had much time. basically it seems to me that after 4500rpm that is when boost drops. Your thoughts ?
1992 Awd Legacy Turbo Sedan
Post Reply