mild hesitation after fcd install

That spinning thing that makes all of the cool noises. OE and Aftermarket.

Moderators: Helpinators, Moderators

Post Reply
turbo970
Third Gear
Posts: 859
Joined: Sun Jul 15, 2012 11:50 pm
Location: sw colorado

mild hesitation after fcd install

Post by turbo970 » Wed Dec 31, 2014 2:11 am

well i made a fcd like morgie did. the did a new fuel filter and fuel injector clean. for the test drive it did well, but going up hill and hitting 12 psi it had hesitation. i 'm set at 14 psi. i also cleaned the maf. i read on line a weak coil could cause this issue. what else should i look for. i do have a spare coil just have to did it out

mike-tracy
Moderator
Moderator
Posts: 4873
Joined: Tue Aug 25, 2009 7:52 am
Location: Des Moines, Wa

Re: mild hesitation after fcd install

Post by mike-tracy » Sat Jan 03, 2015 12:14 am

I would replace the spark plugs with brand new NGK V-Power coppers, and gap them down a bit. Stock gap is .038-.042, I'd try high .020s-low .030s. I gapped mine down to .028 with a robtune (td05 at 18psi) and that fixed the hesitation that remained after running better grounds in the engine bay.
1992 Legacy SS 5mt, build in progress
Josh Colombo wrote:
Mon Jan 14, 2002 10:23 am
Wait....I'm confused now.

turbo970
Third Gear
Posts: 859
Joined: Sun Jul 15, 2012 11:50 pm
Location: sw colorado

Re: mild hesitation after fcd install

Post by turbo970 » Sat Jan 03, 2015 1:13 am

thanks. soon as it warms up a tad i'll re gap them. i just changed the plugs in june or july

Legacy777
Site Admin
Site Admin
Posts: 27466
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: mild hesitation after fcd install

Post by Legacy777 » Sun Jan 04, 2015 10:53 pm

Did you have this hesitation before installing the FCD? If not, I'd remove the FCD and see if the hesitation is still there or not. That will help you narrow down whether the hesitation is caused by the FCD or not.

I'd recommend resetting the ECU if you decide to remove the FCD for testing purposes.
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm

turbo970
Third Gear
Posts: 859
Joined: Sun Jul 15, 2012 11:50 pm
Location: sw colorado

Re: mild hesitation after fcd install

Post by turbo970 » Mon Jan 05, 2015 12:58 am

i re gapped the plugs to .028 ish also found the boot to the turbo inlet has a loose clamp. so i tightened it. pulls like a mofo now. even better than before the fcd. granted mine is a home made one for now. down side torque steer is massive lol

Legacy777
Site Admin
Site Admin
Posts: 27466
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: mild hesitation after fcd install

Post by Legacy777 » Mon Jan 05, 2015 1:32 am

You shouldn't have torque steer. Even as FWD I never had torque steer. If you have it, I suspect you may have worn motor/trans mounts or suspension bushings.
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm

turbo970
Third Gear
Posts: 859
Joined: Sun Jul 15, 2012 11:50 pm
Location: sw colorado

Re: mild hesitation after fcd install

Post by turbo970 » Mon Jan 05, 2015 4:00 am

i know the trans mouts are nee but i dout the motor mounts were done. all i know when i get on it it pulls to the right a bite then feels like its loosing traction on the road.

Legacy777
Site Admin
Site Admin
Posts: 27466
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: mild hesitation after fcd install

Post by Legacy777 » Mon Jan 05, 2015 6:32 pm

I'd look at the motor mounts. Also, bushings in the suspension or an improper alignment could cause it.
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm

James614
Fourth Gear
Posts: 1744
Joined: Sun Jun 10, 2007 4:35 am
Location: Arkansas

Re: mild hesitation after fcd install

Post by James614 » Mon Jan 12, 2015 10:43 pm

Uneven tire wear can cause it too.
93 Touring Wagon (EJ20G 5spd Swap) -- Finally back and running strong as ever!

05 Outback 2.5XT 5spd -- Now the wife can have her SUV and get in on the turbo Legacy goodness at the same time.

Post Reply