help, my engine is eating oil!!!!

That spinning thing that makes all of the cool noises. OE and Aftermarket.

Moderators: Helpinators, Moderators

Post Reply
93scoobynv
In Neutral
Posts: 7
Joined: Wed May 28, 2014 9:29 am

help, my engine is eating oil!!!!

Post by 93scoobynv » Sun Apr 26, 2015 9:51 pm

on the freeway climbing a hill, I lost power and my turbo gage spiked up and down like crazy. had it towed home. the seal in the turbo was leaking on top. I had oil from my filter to puddles in my manifold. I had a second turbo that came with my car so I installed that one. cleaned everything out I could. no spark turned the motor a few times to push oil out before firing it up. fired him up, warmed him up, and did a sea foam treatment. by the end of the treatment, oil was coming out of my turbo at the seal again with oil all through my intake system again.

I have a 93 legacy RS turbo. stock 2.2 with stock turbo.

Legacy777
Site Admin
Site Admin
Posts: 27466
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: help, my engine is eating oil!!!!

Post by Legacy777 » Sun Apr 26, 2015 10:09 pm

Welcome to the BBS.

Have you done any additional diagnostic checks to see if your oil pressure is ok? Are you running the stock turbo oil feed line? Is the oil drain line free and open to allow oil to drain back into the oil pan?

Any additional information you can provide will be helpful.
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm

93scoobynv
In Neutral
Posts: 7
Joined: Wed May 28, 2014 9:29 am

Re: help, my engine is eating oil!!!!

Post by 93scoobynv » Sun Apr 26, 2015 10:53 pm

I ran a diagnostic and I got 4 codes..

11 crank angle sensor

23 air flow sensor

24 air control valve

49 air flow sensor



it pushed most all the oil out through the exhaust. dripping out of the bottom of my headers that connect to the cat. conv. both sides.

Legacy777
Site Admin
Site Admin
Posts: 27466
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: help, my engine is eating oil!!!!

Post by Legacy777 » Mon Apr 27, 2015 12:15 am

Hi Sean,

I really think you've got a plugged oil drain line back into the oil pan or something has dramatically increased the oil supply. I would probably lean towards the oil drain line being plugged. Have you looked into that?

I don't think the codes are going to tell you much at this point as this problem is more mechanical than electrical.

Before the oil issue did the car run fine?
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm

93scoobynv
In Neutral
Posts: 7
Joined: Wed May 28, 2014 9:29 am

Re: help, my engine is eating oil!!!!

Post by 93scoobynv » Tue Apr 28, 2015 3:48 am

thanks for all your help. Im pulling the turbo back out and ill replace the oil out line.

Legacy777
Site Admin
Site Admin
Posts: 27466
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: help, my engine is eating oil!!!!

Post by Legacy777 » Wed Apr 29, 2015 5:46 pm

I would recommend inspecting it first to see if it's blocked. If it's not blocked, there may be something else going on.
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm

93scoobynv
In Neutral
Posts: 7
Joined: Wed May 28, 2014 9:29 am

Re: help, my engine is eating oil!!!!

Post by 93scoobynv » Fri May 01, 2015 3:29 am

okay, todays progress. turbo out, oil drain line has no build up or gunk in it. the metal line going into the crankcase had no gunk in it to the elbow.

it appears to be the original oil feed line.

it ran okay before this happened. it had symptoms of a bad pcv valve. rough idling, some loss of power sometimes.

bcmaxx
First Gear
Posts: 218
Joined: Wed Oct 24, 2012 6:30 pm

Re: help, my engine is eating oil!!!!

Post by bcmaxx » Fri May 01, 2015 7:32 am

Pull your oil cap after its been run to temp and shut off. Lots of smoke??

93scoobynv
In Neutral
Posts: 7
Joined: Wed May 28, 2014 9:29 am

Re: help, my engine is eating oil!!!!

Post by 93scoobynv » Fri May 01, 2015 12:46 pm

Yes, smoke out of dip stick and oil cap.

Post Reply