»  BC-BF Legacy Discussion »  Turbo
#O2 Sensor Location

Custom Search
Login | Register




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: O2 Sensor Location
PostPosted: Thu Dec 29, 2016 10:03 pm 
In Neutral
Joined: Sun Feb 15, 2015 11:25 pm
Posts: 9
I have a 92 Legacy wagon that I recently boosted. ej22e bottom end with 25d heads. I am running a td04 on waste gate pressure. The question I have is should my O2 sensor be on the uppipe or the downpipe? It is currently on the downpipe which is what made sense to me.

I have an idling issue where the car feels like it is going to stall out and sometimes does. If I do not have to move the O2 sensor location, I have a lot of diagnosing to do. Thanks in advance.


Profile  Offline
Reply with quote  
 Post subject: Re: O2 Sensor Location
PostPosted: Fri Dec 30, 2016 3:10 pm 
Fifth Gear
Joined: Fri Jun 20, 2008 8:17 am
Posts: 6214
Location: Lakewood, Wa 98439
In the down pipe is the stock location for turbo legacy.

What kind of BPV/BOV (bypass valve/blow off valve) do you have and is it plumbed back into the intake correctly?

_________________
91 L-TW Wagon with a full Swap -RIP
92 SS Prefaced, GD dash swapped, 22T/205 Hybrid 20 psi - BEAST!
93 SS Bone Stock Gone!
94 TW Bone Stock Gone!
91 SS 4EAT Sold!
98 LGT 4EAT
98 LGT Wagon 4EAT


Profile  Offline
Reply with quote  
 Post subject: Re: O2 Sensor Location
PostPosted: Sat Dec 31, 2016 12:49 am 
In Neutral
Joined: Sun Feb 15, 2015 11:25 pm
Posts: 9
cj91legss wrote:
In the down pipe is the stock location for turbo legacy.

What kind of BPV/BOV (bypass valve/blow off valve) do you have and is it plumbed back into the intake correctly?


Thank you. I kind of figured that I had it in the right place, but wasn't positive. I am running a stock WRX BPV that is venting to atmosphere at the moment. I had an HKS knockoff on there and the boost kept blowing it off of the intercooler. Not to mention the only time it opened was when it was flopping around in the engine bay lol. This is an extremely low budget "build". Kind of my introduction into forced induction. I will be looking for vacuum leaks tomorrow to try to rule that out. After that, it could be any number of things. The turbo blows a lot of oil out of it so the o2 sensor is getting quite a bit of oil on it. I am also fairly certain that my up pipe and down pipe are leaking so that will probably be the next test. If all of that doesn't fix anything, then I will probably do a leak down test. This motor is the first one I replaced valve seals so there is a possibility that I messed those up. There is no oil in the up pipe though, so that is a good sign.


Profile  Offline
Reply with quote  
 Post subject: Re: O2 Sensor Location
PostPosted: Sat Dec 31, 2016 7:00 pm 
Fifth Gear
Joined: Fri May 04, 2007 4:09 pm
Posts: 2235
Location: N. ID
The ECU doesn't know what to do w/that 'lost air' venting to Atmos. Read up on here about that.

Sounds like your TD04 is bad, too...?
Td

_________________
Turbo Subies:
'87 GL-10 Turbo 4WD Wagon (pre-Loyale) - SOLD
'90 BJ, EJ22T/DOHC and 5-speed swap - SOLD
'04 FXT, Forged internals, VF39, STI TMIC, Cobb AP- SOLD
'93 Legacy SS - 5-speed, SOLD :-(
'02 WRX GG-SOLD
'96 BD - turbo'd-SOLD


Profile  Offline
Reply with quote  

Display posts from previous:  Sort by  

Post new topic Reply to topic  [ 4 posts ] 


Who is online

Users browsing this forum: No registered users and 2 guests

Panel

Top You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Dizayn Ercan Koc