Joe's 93 RHD Legacy Wagon Build

Information about specific car builds.

Moderator: Moderators

Post Reply
Sublimejoe
Third Gear
Posts: 578
Joined: Sat Mar 22, 2014 3:10 am
Location: Northern Virginia, USA
Contact:

Re: Joe's 93 RHD Legacy Wagon Build

Post by Sublimejoe » Sun May 26, 2019 3:44 pm

allnines' wrote:
Sun May 26, 2019 2:18 am
I though the corner marker lights I sold you were not broken :(
They weren’t broken when I got them, but they somehow are now. I plan to just fix them since I haven’t been able to find another set of non broken ones.
Parts Needed:

Upper & Lower Rear Window Molding, Corner Lights without broken tabs

Sublimejoe
Third Gear
Posts: 578
Joined: Sat Mar 22, 2014 3:10 am
Location: Northern Virginia, USA
Contact:

Re: Joe's 93 RHD Legacy Wagon Build

Post by Sublimejoe » Tue May 28, 2019 4:16 am

Fixed the rear wheel camber today. Put hood back on.

Image

Image
Parts Needed:

Upper & Lower Rear Window Molding, Corner Lights without broken tabs

nosyt
Second Gear
Posts: 287
Joined: Wed Nov 19, 2008 6:31 am
Location: Otsego, Minnesota
Contact:

Re: Joe's 93 RHD Legacy Wagon Build

Post by nosyt » Wed May 29, 2019 2:30 pm

are you going to roll your rear fenders? looks so clean! you need the G-square lip Brad has for sale for the G1S2 non turbo bumper

Sublimejoe
Third Gear
Posts: 578
Joined: Sat Mar 22, 2014 3:10 am
Location: Northern Virginia, USA
Contact:

Re: Joe's 93 RHD Legacy Wagon Build

Post by Sublimejoe » Wed May 29, 2019 3:29 pm

Yeah I am going to roll them for sure. Should have had the painter do it before he painted the car but oh well.

I keep considering that lip but I don’t really like the look, but that rarity really makes me want to buy it.
Parts Needed:

Upper & Lower Rear Window Molding, Corner Lights without broken tabs

Sublimejoe
Third Gear
Posts: 578
Joined: Sat Mar 22, 2014 3:10 am
Location: Northern Virginia, USA
Contact:

Re: Joe's 93 RHD Legacy Wagon Build

Post by Sublimejoe » Wed May 29, 2019 3:50 pm

Hopefully I am able to get this on without removing the rear window, thoughts on this NOSYT?

Image
Parts Needed:

Upper & Lower Rear Window Molding, Corner Lights without broken tabs

nosyt
Second Gear
Posts: 287
Joined: Wed Nov 19, 2008 6:31 am
Location: Otsego, Minnesota
Contact:

Re: Joe's 93 RHD Legacy Wagon Build

Post by nosyt » Wed May 29, 2019 5:01 pm

The upper one I was able to get back in decent enough that it's not going anywhere plus the spoiler holds it in too now. It was the lower one there is no way I could get it to stay on

Sublimejoe
Third Gear
Posts: 578
Joined: Sat Mar 22, 2014 3:10 am
Location: Northern Virginia, USA
Contact:

Re: Joe's 93 RHD Legacy Wagon Build

Post by Sublimejoe » Fri May 31, 2019 4:27 am

Image
Parts Needed:

Upper & Lower Rear Window Molding, Corner Lights without broken tabs

mike-tracy
Moderator
Moderator
Posts: 4913
Joined: Tue Aug 25, 2009 7:52 am
Location: Des Moines, Wa

Re: Joe's 93 RHD Legacy Wagon Build

Post by mike-tracy » Fri May 31, 2019 4:47 am

Needs the sticker back, otherwise perfect!
1992 Legacy SS 5mt, build in progress
Josh Colombo wrote:
Mon Jan 14, 2002 10:23 am
Wait....I'm confused now.

Sublimejoe
Third Gear
Posts: 578
Joined: Sat Mar 22, 2014 3:10 am
Location: Northern Virginia, USA
Contact:

Re: Joe's 93 RHD Legacy Wagon Build

Post by Sublimejoe » Fri May 31, 2019 1:35 pm

Yeah it does! I still have that door skin hanging in my garage.
Parts Needed:

Upper & Lower Rear Window Molding, Corner Lights without broken tabs

Sublimejoe
Third Gear
Posts: 578
Joined: Sat Mar 22, 2014 3:10 am
Location: Northern Virginia, USA
Contact:

Re: Joe's 93 RHD Legacy Wagon Build

Post by Sublimejoe » Tue Jun 04, 2019 5:43 am

I am going to need this lip:

Image
Parts Needed:

Upper & Lower Rear Window Molding, Corner Lights without broken tabs

Legacy777
Site Admin
Site Admin
Posts: 27512
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: Joe's 93 RHD Legacy Wagon Build

Post by Legacy777 » Tue Jun 04, 2019 6:01 pm

Joe,

That's quite the before and after picture! Great work!
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm

Sublimejoe
Third Gear
Posts: 578
Joined: Sat Mar 22, 2014 3:10 am
Location: Northern Virginia, USA
Contact:

Re: Joe's 93 RHD Legacy Wagon Build

Post by Sublimejoe » Wed Jun 05, 2019 3:38 pm

Legacy777 wrote:
Tue Jun 04, 2019 6:01 pm
Joe,

That's quite the before and after picture! Great work!
Thanks Josh!
Parts Needed:

Upper & Lower Rear Window Molding, Corner Lights without broken tabs

Sublimejoe
Third Gear
Posts: 578
Joined: Sat Mar 22, 2014 3:10 am
Location: Northern Virginia, USA
Contact:

Re: Joe's 93 RHD Legacy Wagon Build

Post by Sublimejoe » Fri Jun 07, 2019 2:48 am

New vs Old. I was able to find a brand new one for the driver side, but have had no such luck for the passenger side.

Image
Image
Parts Needed:

Upper & Lower Rear Window Molding, Corner Lights without broken tabs

Sublimejoe
Third Gear
Posts: 578
Joined: Sat Mar 22, 2014 3:10 am
Location: Northern Virginia, USA
Contact:

Re: Joe's 93 RHD Legacy Wagon Build

Post by Sublimejoe » Wed Jun 12, 2019 2:41 pm

Yesterday with the help of Josh I was able to wire my reverse lights and neutral switch.

My list of things to do has dwindled down to almost nothing. As of now the only things keeping me from driving is the tie rod end that I cant break loose and having a piece of exhaust fabbed, although I could drive it with just an open header.

Image
Parts Needed:

Upper & Lower Rear Window Molding, Corner Lights without broken tabs

Legacy777
Site Admin
Site Admin
Posts: 27512
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: Joe's 93 RHD Legacy Wagon Build

Post by Legacy777 » Wed Jun 12, 2019 7:20 pm

Have you tried a torch to the tie rod end?
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm

Sublimejoe
Third Gear
Posts: 578
Joined: Sat Mar 22, 2014 3:10 am
Location: Northern Virginia, USA
Contact:

Re: Joe's 93 RHD Legacy Wagon Build

Post by Sublimejoe » Wed Jun 12, 2019 7:47 pm

Yeah, all I had was propane though. I will try and get some map gas
Parts Needed:

Upper & Lower Rear Window Molding, Corner Lights without broken tabs

Sublimejoe
Third Gear
Posts: 578
Joined: Sat Mar 22, 2014 3:10 am
Location: Northern Virginia, USA
Contact:

Re: Joe's 93 RHD Legacy Wagon Build

Post by Sublimejoe » Sat Jun 22, 2019 7:19 pm

Ok gentleman! I finally was able to remove the old tie rod and replace with the help of a friend, so both sides are now connected to the knuckles and straightened up with a hillbilly alignment.

Also, was able to back the car from the driveway into the garage! It drives!!

Idle is too high, at 2k rpm's. Any ideas?
Parts Needed:

Upper & Lower Rear Window Molding, Corner Lights without broken tabs

ride_child
Third Gear
Posts: 885
Joined: Thu May 03, 2012 6:24 am
Location: Enumclaw, WA
Contact:

Re: Joe's 93 RHD Legacy Wagon Build

Post by ride_child » Sun Jun 23, 2019 12:40 am

oh man, its not even my car and im so excited!!!
Kris

'91 Mica White SS - R.I.P.
'88 White RX Turbo sedan - SOLD
'91 Black SS - SOLD
'93 Silver Turbo Wagon - Hibernation/Project Mode
'91 Black Camry Alltrac - R.I.P.
'09 DGM Forester XT Limited - Daily

Sublimejoe
Third Gear
Posts: 578
Joined: Sat Mar 22, 2014 3:10 am
Location: Northern Virginia, USA
Contact:

Re: Joe's 93 RHD Legacy Wagon Build

Post by Sublimejoe » Wed Jul 03, 2019 3:02 am

Ugh. On Sunday I started the car, first turn of the key, drove it out of the garage and turned it off. Cleaned out the garage and two hours later it would not start again. I didnt touch anything on the car while it was out of garage, but something has stopped working.

I investigated the items I wired (jumper for 11&12 pins) and they were good, looked at the crank sensor and its pretty fucked up, photos below. I tried wiring them like I would normally wire anything but the shielding wire is making me confused. Josh has helped me of course, it would have been impossible without him explaining this to me.


Image

This is factory wiring. What a mess, the shielding wire wraps around the other two wires, then it kinda converts into a standard wire and goes to the middle pin of the connector. See connector picture below.
Image

Image
Parts Needed:

Upper & Lower Rear Window Molding, Corner Lights without broken tabs

Sublimejoe
Third Gear
Posts: 578
Joined: Sat Mar 22, 2014 3:10 am
Location: Northern Virginia, USA
Contact:

Re: Joe's 93 RHD Legacy Wagon Build

Post by Sublimejoe » Mon Jul 08, 2019 3:06 am

So frustrated with this car right now. I wired the crank sensor using an XLR microphone cable from microcenter. It was $14 for 25 feet.

Image
Image
Image

This did not change the no start situation. However it did clear codes 11 & 13 which are the crank position sensor & cam position sensor. Good enough for me.

Today I checked everything for the seemingly hundredth time and find nothing to be amiss. I pulled the hose from the inlet on intake manifold to clean the fuel filter and lines. I sprayed air into the lines and it seems to be fine. Blew air into the hard lines on the firewall back towards the tank.

While I had the fuel lines off I ran a line from the inlet line directly into this smart water bottle and tried to start the car. The fuel pump seems to be pumping just fine, this was how much fuel is pumped when cranking the car for ten seconds. Oddly enough the car turned over and sputtered for about ten seconds before stalling out. This was the only time today I got the car to turn over and run. With nothing connected to inlet or return on intake manifold.

Image

Anyone have any ideas on what could be the issue? I am getting a code 42 on the cluster, which is idle switch. The throttle body was messed with a little, but could small adjustments cause enough of a difference that the car doesn't even try to start? It seems to be something is preventing the car from knowing its ok to start, rather than an issue of it not getting spark/fuel.

Thank you in advance my friends.
Parts Needed:

Upper & Lower Rear Window Molding, Corner Lights without broken tabs

Sublimejoe
Third Gear
Posts: 578
Joined: Sat Mar 22, 2014 3:10 am
Location: Northern Virginia, USA
Contact:

Re: Joe's 93 RHD Legacy Wagon Build

Post by Sublimejoe » Tue Jul 09, 2019 4:40 pm

Update.

Took plugs out, they are soaked in gas from trying to start it so much on Sunday I guess. The weird thing is the plugs still smell like bad gas. I have already drained the tank twice using the fuel pump. Am I going to need to remove tank and lines to clean properly?

Also, a friend of mine pointed out that I dont have an oxygen sensor connected. It never even crossed my mind that I should have one since I dont remember removing one from the old motor. Ordered the sensor and it should be here tomorrow.
Parts Needed:

Upper & Lower Rear Window Molding, Corner Lights without broken tabs

Legacy777
Site Admin
Site Admin
Posts: 27512
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: Joe's 93 RHD Legacy Wagon Build

Post by Legacy777 » Wed Jul 10, 2019 6:43 pm

Joe,

Are the spark plugs new? The fact the plugs are soaked and what you saw with the fuel in the smart water bottle seem to indicate fueling is okay. Did you look on the fuel tank to see if there are drain holes/bolts on it? The 90 Legacy donor car I used had them which was very convenient. How much new fuel did you add?

Now that you fixed the crank & cam sensors does the rpm needle always bounce a little while cranking?

I don't think either the idle switch or O2 sensor would keep the engine from starting. I think your issue may be more spark/ignition related. Are the spark plugs & wires new? Have you checked the coil pack & igniter?
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm

Sublimejoe
Third Gear
Posts: 578
Joined: Sat Mar 22, 2014 3:10 am
Location: Northern Virginia, USA
Contact:

Re: Joe's 93 RHD Legacy Wagon Build

Post by Sublimejoe » Thu Jul 11, 2019 2:23 am

After I put the motor in the car I got brand new plugs and wires.

I didnt check for that but I will tomorrow. I drained about six gallons maybe, then put another six gallons in.

Yes the needle bounces now that I fixed the sensors. :)

I haven't checked the coil pack or ignitor beyond making sure everything was plugged in correctly. Is there a way to test the coil pack?

Thanks!
Parts Needed:

Upper & Lower Rear Window Molding, Corner Lights without broken tabs

Legacy777
Site Admin
Site Admin
Posts: 27512
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: Joe's 93 RHD Legacy Wagon Build

Post by Legacy777 » Fri Jul 12, 2019 5:48 pm

Here are scans for the coil pack test. I can't find the specific test for the igniter.

https://www.experiencetherave.com/subar ... cktest.jpg

I would recommend you download the 92 factory manual info from me if you haven't. Look at section 2-7 and "Troubleshooting for Engine Starting Failure". It lays out a systematic step by step approach on what to check.

https://www.experiencetherave.com/subar ... lectrical)
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm

Sublimejoe
Third Gear
Posts: 578
Joined: Sat Mar 22, 2014 3:10 am
Location: Northern Virginia, USA
Contact:

Re: Joe's 93 RHD Legacy Wagon Build

Post by Sublimejoe » Mon Jul 15, 2019 2:35 am

IT IS ALIVE!!

I soldered the connections for the crank position sensor and tucked it all away nicely. Wire brushed the plugs before I put them back in, and boom it started up on the first turn of the key.

I am still throwing a CEL, code 42.

Parts Needed:

Upper & Lower Rear Window Molding, Corner Lights without broken tabs

Post Reply