Tony's 91 SS 29Dec R.I.P.

Information about specific car builds.

Moderator: Moderators

Post Reply
SILINC3R
quasi-mod-o
quasi-mod-o
Posts: 2763
Joined: Wed May 30, 2007 6:11 am
Location: Charlotte, NC

Re: Tony's 91 SS 29Nov Now with Robtune

Post by SILINC3R »

Alright the EJ20 ECU is in, with 440s, JECs MAF and its running. Currently running very rich and keeps wanting to overheat so working on burping the system in the middle of the street. AFR at idle is 10, hoping once the cooling issue is resolved the ECU will learn to run the injectors. Although it should know how to run these as these are what are run with this ECU.
Tony
90 LS Spec rio red sold
91 SS rio red R.I.P
90 Mazda Miata
2005 GT SWP
92ss satinsvoice wrote:LOL! that block was like F*** THIS! IM OUT!
mike-tracy wrote:Word. I'd love to get my hands on one of those trannies, but I just can't stomach the cost
mike-tracy
Moderator
Moderator
Posts: 4986
Joined: Tue Aug 25, 2009 7:52 am
Location: Des Moines, Wa

Re: Tony's 91 SS 29Nov Now with Robtune

Post by mike-tracy »

Did you snip the resistor on the tuned ecu?
1992 Legacy SS 5mt, build in progress
Josh Colombo wrote: Mon Jan 14, 2002 10:23 am Wait....I'm confused now.
SILINC3R
quasi-mod-o
quasi-mod-o
Posts: 2763
Joined: Wed May 30, 2007 6:11 am
Location: Charlotte, NC

Re: Tony's 91 SS 29Nov Now with Robtune

Post by SILINC3R »

mike-tracy wrote:Did you snip the resistor on the tuned ecu?
Uhh, don't remember reading that and I am running a stock EJ20 ECU. I jumped the gun on puting "Robtune".
Tony
90 LS Spec rio red sold
91 SS rio red R.I.P
90 Mazda Miata
2005 GT SWP
92ss satinsvoice wrote:LOL! that block was like F*** THIS! IM OUT!
mike-tracy wrote:Word. I'd love to get my hands on one of those trannies, but I just can't stomach the cost
SILINC3R
quasi-mod-o
quasi-mod-o
Posts: 2763
Joined: Wed May 30, 2007 6:11 am
Location: Charlotte, NC

Re: Tony's 91 SS 12Dec EJ20ECU running rich

Post by SILINC3R »

Alright so CEL is saying codes, 21 Coolant Temp Sensor, 31 TPS and 45 Atmospheric Pressure Sensor.
Prior to the install didn't have any codes.

Have cleared codes by disconnecting battery but either they are indeed there are they aren't clearing.

Code 31, Adjusted but still seeing the code.

Working on the other 2.

Hoping these will fix my running rich condition.
Tony
90 LS Spec rio red sold
91 SS rio red R.I.P
90 Mazda Miata
2005 GT SWP
92ss satinsvoice wrote:LOL! that block was like F*** THIS! IM OUT!
mike-tracy wrote:Word. I'd love to get my hands on one of those trannies, but I just can't stomach the cost
kimokalihi
Fifth Gear
Posts: 8360
Joined: Mon Nov 06, 2006 3:41 am
Location: Tenino, WA

Re: Tony's 91 SS 12Dec EJ20ECU running rich

Post by kimokalihi »

You need one of these :

Connect it to the reservoir filler neck, fill the system until the funnel is at least half full and let it idle for half an hour. The bubbles will work their way out once the car gets to operating temp and you can help it do so by manually squeezing the hoses on the radiator. Don't get impatient like I see most people do and only burp the car for 10 mins. This won't work and you'll wind up with air bubbles still in the system.
98 Metro Hatch Daily Driver :)
91 SS EJ20G Engine/Tranny/Diff Swap Build Thread Here
"Your testes are close to your bottom but you still play with them all the time." Jeremy Clarkson
cj91legss
Fifth Gear
Posts: 6317
Joined: Fri Jun 20, 2008 8:17 am
Location: Lakewood, Wa 98439
Contact:

Re: Tony's 91 SS 12Dec EJ20ECU running rich

Post by cj91legss »

+1 That's what I use every time.
91 L-TW Wagon with a full Swap -RIP
92 SS Prefaced, GD dash swapped, 22T/205 Hybrid 20 psi - BEAST!
93 SS Bone Stock Gone!
94 TW Bone Stock Gone!
91 SS 4EAT Sold!
98 LGT 4EAT
98 LGT Wagon 4EAT
SILINC3R
quasi-mod-o
quasi-mod-o
Posts: 2763
Joined: Wed May 30, 2007 6:11 am
Location: Charlotte, NC

Re: Tony's 91 SS 12Dec EJ20ECU running rich

Post by SILINC3R »

kimokalihi wrote:You need one of these :

Connect it to the reservoir filler neck, fill the system until the funnel is at least half full and let it idle for half an hour. The bubbles will work their way out once the car gets to operating temp and you can help it do so by manually squeezing the hoses on the radiator. Don't get impatient like I see most people do and only burp the car for 10 mins. This won't work and you'll wind up with air bubbles still in the system.
I do need one of those but I have had many coolant issues with this car but never had it rise as quickly. I always leave the car off first then add fluid squeezing the hose until the expansion tank is full. Then I start the car and continue adding and squeezing. The issue right now is it wants to keep over heating so I have to shut it off when the gauge gets to 3/4. and it the fans never kick on indicating that it is at the right temperature and the thermostat is open.

Oh and Kimo any tool you post I am probably going to buy, so lets keep it to a minimum please haha.
Tony
90 LS Spec rio red sold
91 SS rio red R.I.P
90 Mazda Miata
2005 GT SWP
92ss satinsvoice wrote:LOL! that block was like F*** THIS! IM OUT!
mike-tracy wrote:Word. I'd love to get my hands on one of those trannies, but I just can't stomach the cost
kimokalihi
Fifth Gear
Posts: 8360
Joined: Mon Nov 06, 2006 3:41 am
Location: Tenino, WA

Re: Tony's 91 SS 12Dec EJ20ECU running rich

Post by kimokalihi »

Well if it's overheating it's likely due to air in the system. You can do the same thing without the funnel by just standing around watching the filler neck and when it drops keep adding more for half an hour. On a flat surface! Or slightly elevated with the front of the car up but I just do it in my garage. It's much easier with the funnel because it's full of coolant mix so it adds water on it's own.
98 Metro Hatch Daily Driver :)
91 SS EJ20G Engine/Tranny/Diff Swap Build Thread Here
"Your testes are close to your bottom but you still play with them all the time." Jeremy Clarkson
SILINC3R
quasi-mod-o
quasi-mod-o
Posts: 2763
Joined: Wed May 30, 2007 6:11 am
Location: Charlotte, NC

Re: Tony's 91 SS 12Dec EJ20ECU running rich

Post by SILINC3R »

Well, I understand all that but I need to figure out why it is running so rich, never had a injector stuck open and these are brand new so that should be an issue. Not sure how to check. I listened to them with the screwdriver method and they all clicked.
Tony
90 LS Spec rio red sold
91 SS rio red R.I.P
90 Mazda Miata
2005 GT SWP
92ss satinsvoice wrote:LOL! that block was like F*** THIS! IM OUT!
mike-tracy wrote:Word. I'd love to get my hands on one of those trannies, but I just can't stomach the cost
kimokalihi
Fifth Gear
Posts: 8360
Joined: Mon Nov 06, 2006 3:41 am
Location: Tenino, WA

Re: Tony's 91 SS 12Dec EJ20ECU running rich

Post by kimokalihi »

Well it could be just the fact that your ecu is still running a jap tune and that tune is designed for jap fuel and their fuel is a different octane than ours...or I might not know what I'm talking about. Just an idea I'm throw in out there. I would get it Rob tuned asap. There's no fuel leak into the manifold? I seem to recall someone trying to use different injectors that didn't fit properly and it was leaking fuel into the intake manifold and they weren't aware of it causing it to run super rich. What's your injector setup? Which rails are you using? Did you use an adapter kit like I have? Or do the 440s drop right in to ej22t rails? Just brainstorming. I think it's a leak or the tune or lack of proper tune. I'd get some 550s and na 92-94 rails or adapter kit and get robs 550 tune.
98 Metro Hatch Daily Driver :)
91 SS EJ20G Engine/Tranny/Diff Swap Build Thread Here
"Your testes are close to your bottom but you still play with them all the time." Jeremy Clarkson
SILINC3R
quasi-mod-o
quasi-mod-o
Posts: 2763
Joined: Wed May 30, 2007 6:11 am
Location: Charlotte, NC

Re: Tony's 91 SS 12Dec EJ20ECU running rich

Post by SILINC3R »

I thought I had spoke with Mike or read it that it would run fine. Maybe a little rich but it's at 10 AFR at idle. That's crazy, if I can fix the cooling issue than maybe driving it around will get the ECU to learn and adjust more.

Yes I am running 440 in the EJ22T rails. I followed the write up and only had a leak on the outside of one. Removed it reseated and no issues. No I am not using an adapter didn't read about that in the write up. I chose not to go with a Robtune at the moment so I could enjoy the car for a bit and wanted to keep the driveability. When I go Robtune I will probably stick with the 440 tune. The LGT was bought for more horsepower.

And brainstorm away that's what leads to answers.

Also Kimo I was just going through your build thread and noticed you had code 31 and 45. You found the reason for the pressure sensor, but what about the TPS issue? Or did that fix that as well?
Tony
90 LS Spec rio red sold
91 SS rio red R.I.P
90 Mazda Miata
2005 GT SWP
92ss satinsvoice wrote:LOL! that block was like F*** THIS! IM OUT!
mike-tracy wrote:Word. I'd love to get my hands on one of those trannies, but I just can't stomach the cost
kimokalihi
Fifth Gear
Posts: 8360
Joined: Mon Nov 06, 2006 3:41 am
Location: Tenino, WA

Re: Tony's 91 SS 12Dec EJ20ECU running rich

Post by kimokalihi »

Either the rewiring when I did the cop conversion fixed the Tps code or magically it was fixed when I found that massive vacuum leak. No code since.

As for driveability, it will be much more driveable with robs tune.

The adapter kit I mentioned was for running phase 2 injectors in phase one rails. The 525cc yellowtop sidefeeds from the usdm Sti.

Have you replaced your coolant sensor? If it's bad you may be stuck in cold start fuel mode and dumping too much fuel into the engine. It won't have a code even if it's bad either. Cheap fix I recommend everyone with an older Subaru to do just because they're so commonly bad at this age.
98 Metro Hatch Daily Driver :)
91 SS EJ20G Engine/Tranny/Diff Swap Build Thread Here
"Your testes are close to your bottom but you still play with them all the time." Jeremy Clarkson
kimokalihi
Fifth Gear
Posts: 8360
Joined: Mon Nov 06, 2006 3:41 am
Location: Tenino, WA

Re: Tony's 91 SS 12Dec EJ20ECU running rich

Post by kimokalihi »

I still vote Rob tune so at least you can eliminate the improper tune from being a possible cause.
98 Metro Hatch Daily Driver :)
91 SS EJ20G Engine/Tranny/Diff Swap Build Thread Here
"Your testes are close to your bottom but you still play with them all the time." Jeremy Clarkson
SILINC3R
quasi-mod-o
quasi-mod-o
Posts: 2763
Joined: Wed May 30, 2007 6:11 am
Location: Charlotte, NC

Re: Tony's 91 SS 12Dec EJ20ECU running rich

Post by SILINC3R »

if the coolant temp sensor is bad it will throw a code since it goes to the ECU. If you are reffereing to the gauge sensor than yes you are correct. However I do have a code so that could be possible. Just sucks due to the location I'll probably have to remvoe the intake manifold which means the car will be down for some time.
Tony
90 LS Spec rio red sold
91 SS rio red R.I.P
90 Mazda Miata
2005 GT SWP
92ss satinsvoice wrote:LOL! that block was like F*** THIS! IM OUT!
mike-tracy wrote:Word. I'd love to get my hands on one of those trannies, but I just can't stomach the cost
kimokalihi
Fifth Gear
Posts: 8360
Joined: Mon Nov 06, 2006 3:41 am
Location: Tenino, WA

Re: Tony's 91 SS 12Dec EJ20ECU running rich

Post by kimokalihi »

Whys that? I replaced mine a while back. No need to remove anything but maybe the alternator. It's easy. It doesn't throw a code unless it's outside the parameters of normal readings I think which means so long as it's giving a reading that could be a possible coolant temp it probably won't throw a code.
98 Metro Hatch Daily Driver :)
91 SS EJ20G Engine/Tranny/Diff Swap Build Thread Here
"Your testes are close to your bottom but you still play with them all the time." Jeremy Clarkson
SILINC3R
quasi-mod-o
quasi-mod-o
Posts: 2763
Joined: Wed May 30, 2007 6:11 am
Location: Charlotte, NC

Re: Tony's 91 SS 12Dec EJ20ECU running rich

Post by SILINC3R »

My sensors are on the aft side facing the firewall. Otherwsie I owuld have tested it already.
Tony
90 LS Spec rio red sold
91 SS rio red R.I.P
90 Mazda Miata
2005 GT SWP
92ss satinsvoice wrote:LOL! that block was like F*** THIS! IM OUT!
mike-tracy wrote:Word. I'd love to get my hands on one of those trannies, but I just can't stomach the cost
SILINC3R
quasi-mod-o
quasi-mod-o
Posts: 2763
Joined: Wed May 30, 2007 6:11 am
Location: Charlotte, NC

Re: Tony's 91 SS 12Dec EJ20ECU running rich

Post by SILINC3R »

Alright so I ended up asking Rob and we got it sorted out. he asked if I followed his write up and I said yes. He then asked if I de-pinned and merge the wire. I said yes but I would double check. Well I had in facted depinned and merged the wire but in doing so I moved the pin21 to spot from 20, Repositioned and codes gone.

However, now I have code 23 wrong MAF. So I searched and searched. All the write say it's plug and play but I had remembered reading something about splicing the blue wire to ground, so I found the thread and did just that. Didn't clear the code though. So I went ahead and took the car for a drive hoping it would learn but it is still pig rich. Idle is fine, temp is fine but doesn't want to make power since it is so rich. Going to swap plugs and see if that changes anuthing.
Tony
90 LS Spec rio red sold
91 SS rio red R.I.P
90 Mazda Miata
2005 GT SWP
92ss satinsvoice wrote:LOL! that block was like F*** THIS! IM OUT!
mike-tracy wrote:Word. I'd love to get my hands on one of those trannies, but I just can't stomach the cost
SILINC3R
quasi-mod-o
quasi-mod-o
Posts: 2763
Joined: Wed May 30, 2007 6:11 am
Location: Charlotte, NC

Re: Tony's 91 SS 12Dec EJ20ECU running rich

Post by SILINC3R »

So swapped in new Vpowers and no change. Gapped them to .030 as the old ones.

I'M RICHHHHH BIATCHHESSSSSS
Image

So tried swapping in the old turbo metal MAF, of course no change. I also tried unplugging the MAF and it didn't even want to start. Going to try and hit the junkyard Monday and get another JECs from a 95 they have. This has to be the answer but I guess I'll find out once I get another one in.

No code for the 02 sensor but wondering if I'll need to replace it once I get the rich problem fixed. Also why isn't the 02 able to tell the car to stop dumping fuel?
Tony
90 LS Spec rio red sold
91 SS rio red R.I.P
90 Mazda Miata
2005 GT SWP
92ss satinsvoice wrote:LOL! that block was like F*** THIS! IM OUT!
mike-tracy wrote:Word. I'd love to get my hands on one of those trannies, but I just can't stomach the cost
Legacy777
Site Admin
Site Admin
Posts: 27750
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: Tony's 91 SS 12Dec EJ20ECU running rich

Post by Legacy777 »

Tony,

As I mentioned in your other thread, I'd try a different MAF. Have you verified the MAF wiring to make sure it's good, and have you checked the MAF against the tests in the FSM?
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
2020 Outback Limted XT

If you need to get a hold of me please email me rather then pm
SILINC3R
quasi-mod-o
quasi-mod-o
Posts: 2763
Joined: Wed May 30, 2007 6:11 am
Location: Charlotte, NC

Re: Tony's 91 SS 12Dec EJ20ECU running rich

Post by SILINC3R »

I forgot that my roommate has a 98 GT which I think have the JECs so I will put my JECs on his car and see if it throws a code. I checked for 12V and that was good. I only checked the Haynes, I'll have to look at the FSM tomorrow.
Tony
90 LS Spec rio red sold
91 SS rio red R.I.P
90 Mazda Miata
2005 GT SWP
92ss satinsvoice wrote:LOL! that block was like F*** THIS! IM OUT!
mike-tracy wrote:Word. I'd love to get my hands on one of those trannies, but I just can't stomach the cost
mike-tracy
Moderator
Moderator
Posts: 4986
Joined: Tue Aug 25, 2009 7:52 am
Location: Des Moines, Wa

Re: Tony's 91 SS 12Dec EJ20ECU running rich

Post by mike-tracy »

Due to the differences between the two cars and their ecus, your maf may not cause a cel on his car without extensive driving, or at all.
1992 Legacy SS 5mt, build in progress
Josh Colombo wrote: Mon Jan 14, 2002 10:23 am Wait....I'm confused now.
SILINC3R
quasi-mod-o
quasi-mod-o
Posts: 2763
Joined: Wed May 30, 2007 6:11 am
Location: Charlotte, NC

Re: Tony's 91 SS 12Dec EJ20ECU running rich

Post by SILINC3R »

As soon as I put the car to ON, not started, it gives the code 23.
Tony
90 LS Spec rio red sold
91 SS rio red R.I.P
90 Mazda Miata
2005 GT SWP
92ss satinsvoice wrote:LOL! that block was like F*** THIS! IM OUT!
mike-tracy wrote:Word. I'd love to get my hands on one of those trannies, but I just can't stomach the cost
cj91legss
Fifth Gear
Posts: 6317
Joined: Fri Jun 20, 2008 8:17 am
Location: Lakewood, Wa 98439
Contact:

Re: Tony's 91 SS 12Dec EJ20ECU running rich

Post by cj91legss »

So your maf is dead?
91 L-TW Wagon with a full Swap -RIP
92 SS Prefaced, GD dash swapped, 22T/205 Hybrid 20 psi - BEAST!
93 SS Bone Stock Gone!
94 TW Bone Stock Gone!
91 SS 4EAT Sold!
98 LGT 4EAT
98 LGT Wagon 4EAT
mike-tracy
Moderator
Moderator
Posts: 4986
Joined: Tue Aug 25, 2009 7:52 am
Location: Des Moines, Wa

Re: Tony's 91 SS 12Dec EJ20ECU running rich

Post by mike-tracy »

SILINC3R wrote:As soon as I put the car to ON, not started, it gives the code 23.
Please specify wHich car you're talking about.
1992 Legacy SS 5mt, build in progress
Josh Colombo wrote: Mon Jan 14, 2002 10:23 am Wait....I'm confused now.
SILINC3R
quasi-mod-o
quasi-mod-o
Posts: 2763
Joined: Wed May 30, 2007 6:11 am
Location: Charlotte, NC

Re: Tony's 91 SS 12Dec EJ20ECU running rich

Post by SILINC3R »

The 91 SS. Haven't tocuhed the 98 GT yet. Going through the FSM at the moment as Josh recommended.
Tony
90 LS Spec rio red sold
91 SS rio red R.I.P
90 Mazda Miata
2005 GT SWP
92ss satinsvoice wrote:LOL! that block was like F*** THIS! IM OUT!
mike-tracy wrote:Word. I'd love to get my hands on one of those trannies, but I just can't stomach the cost
Post Reply