2006 wrx intercooling woes, unique setup, almost done !

Front, Top, Air, Water.

Moderators: Helpinators, Moderators

Post Reply
joshm
First Gear
Posts: 81
Joined: Wed Jul 02, 2008 10:35 pm

2006 wrx intercooling woes, unique setup, almost done !

Post by joshm » Thu Aug 07, 2008 8:10 am

Alright here, so im intercooling my 91 ss (ej22t) with a 2006 wrx TMIC. I custom fabbed my Y pipe, hopeing to have less issues, with little luck. I have cut my clutch master cylinder down about 2" intercooler will clear this. There is a black box that says hitachi (assuming this is the ignitor :( but have no clue, it was mounted near the center of engine compartment against a plate coming off the firewall). Anyways, does that have to be mounted against anything, or can it just hang free ?

Also, there is a large pack of wires running along the firewall (assuming these are from computer..), and this if the main thing preventing me from from lowering my intercooler, allowing it to clear the hood. How do i go about relocating them ?

Next, the throttle cable/cruise cable, where they mount to the arm on the engine, seem to be VERY close to the BOV flange, which is currently not Installed, when installed i fear it will hit. Again, what do i have to move to push the IC back

One final thing, theres an oil line coming off my turbo directly below there i need to run a hose. I loosened the bolt (bolt with hole, banjo bolt), but it doesnt appear that i can rotate the fitting (90 degree metal elbow). How do i rotate this ?

I know these things are a 100% custom job, but I have all day off tomorrow and hope to finish it. Today i fabbed my Y pipe, relocated coolant res, bought all my parts, and cut my clutch res 2" (too little? too much ?)

Thanks for the help

- Josh

joshm
First Gear
Posts: 81
Joined: Wed Jul 02, 2008 10:35 pm

Post by joshm » Thu Aug 07, 2008 8:18 am

One final thing, if i take the plastic off the IC will it make install much easier, or not ?

joshm
First Gear
Posts: 81
Joined: Wed Jul 02, 2008 10:35 pm

Post by joshm » Thu Aug 07, 2008 8:25 am

For the record, these questions seem repetitive from other threads, but im going to make a comprehensive tutorial once this thing is in properly. I also did an AC delete. My coolant tank is mounted where my AC pump once was. Doesnt sound like unique intercooling setup, but how ive done things is different from others and these are the last few things holding me up !!!

Also, have any of you got away from this without cutting the throttle body, it really doesnt look like i have to as some other threads have suggested

BlockerImp
First Gear
Posts: 107
Joined: Sun Oct 09, 2005 8:16 am
Location: Seattle, Wa

Post by BlockerImp » Thu Aug 07, 2008 8:34 am

ok, well i had the same problems as you did. It seems like everything your posting is exactly what i went through.

The clutch resivoir, thats just about as much as i cut it. My coolant resivoir is just moved over to the right a bit, if you look at how subaru nation did it. As for the BOV flange, as long it shouldnt get much inthe way, the problem i came across was on the other side, on the turbo inlet pipe, getting it to properly match up with its inlet. I have a 90* brass fitting to get it to work.

The ignitor chip does need a ground, find some place to get this mounted up to, or else you might be looking at problems in the future. Also once your intercooled, you will probably want to look into a manual boost controller, cause whats the point in intercooling if you dont do much more after that? lol.

I couldnt get my ypipe to fit properly, so i only have it running on a single pipe from the furthest side. Im running 10lbs of boost, and i have no heat problems, and the SS is running like a beauty, once i can figure a y pipe solution, ill get that worked out.

BlockerImp
First Gear
Posts: 107
Joined: Sun Oct 09, 2005 8:16 am
Location: Seattle, Wa

Post by BlockerImp » Thu Aug 07, 2008 8:35 am

also, with the 06 intercooler, there is no need to cut/trim your throttle body.

joshm
First Gear
Posts: 81
Joined: Wed Jul 02, 2008 10:35 pm

Post by joshm » Thu Aug 07, 2008 8:48 am

Alright, thanks for all the help buddy.

I can easily remount the ignitor, ill add it to the list of "fun"

My MBC is going in hopefully tomorrow night, i wanna make sure it runs good before i boost the hell out of it.

What did you do about all the wiring in the way ? Thanks

Also, the hose from my y pipe outlet to turbo outlet isnt a big problem at all, its a bit of a beech, but essentially, its just going to be about a 70* bend in a hose i have, so shouldnt be a big problem. Tried to mount it up today, but couldnt get the IC to lay flat enough. My coolant res is WAY out of the way

BlockerImp
First Gear
Posts: 107
Joined: Sun Oct 09, 2005 8:16 am
Location: Seattle, Wa

Post by BlockerImp » Thu Aug 07, 2008 9:40 am

i tucked the wiring under my pitch stop, along with everything else.

Make sure you take pictures. I need another example of a y pipe to see what i can do to make it fit perfectly

joshm
First Gear
Posts: 81
Joined: Wed Jul 02, 2008 10:35 pm

Post by joshm » Sat Aug 09, 2008 6:39 am

Shes done, read my other thread ^^^

Post Reply