Emissions question

Headers, cats, uppipes, downpipes, midpipes and mufflers.

Moderators: Helpinators, Moderators

Post Reply
SignusPrime
In Neutral
Posts: 3
Joined: Mon Feb 23, 2015 10:38 pm
Location: Scottsdale, AZ

Emissions question

Post by SignusPrime » Mon Feb 23, 2015 10:52 pm

New to the forum, just acquired my first Subaru about a month ago, and had been lurking here since then in hopes of finding some info, but had a more specific needs than the threads I've seen.

I have a 1993 Legacy wagon, 220k on the odometer, and it refuses to pass emissions. It has new plugs and wires, a recent oil change, and isn't throwing any codes. The only problem I'm having is with the idle HC numbers, even after doing 30 minutes of highway driving beforehand to get to a testing station without any waiting, so I'm sure it was up to temp. I'm just out of ideas, and feel like I'm beating my head against the wall. Any help would be appreciated!

rallyak
Third Gear
Posts: 895
Joined: Wed Oct 26, 2011 7:02 am
Location: Anchorage,Alaska

Re: Emissions question

Post by rallyak » Tue Feb 24, 2015 12:11 am

I would change the violent sensor, that won't throw a code and it is one of the major sensors that directly effects air/fuel mixture and its cheep 20$-25$.

Stupid autocorrect: coolant sensor
Charles

90' White/Gray Outback DD workhorse (670,xxx) miles
92' Onyx Metallic (430,xxx) Wife's DD
68' Barracuda formula S 340 4spd coupe (ongoing project)
66' Mustang 2+2 4spd wife's (ongoing project)

SignusPrime
In Neutral
Posts: 3
Joined: Mon Feb 23, 2015 10:38 pm
Location: Scottsdale, AZ

Re: Emissions question

Post by SignusPrime » Tue Feb 24, 2015 12:47 am

Thanks, I'll give that a shot, and see how it goes!

None of the shops near me have them in stock, so I get to wait. :-/

Legacy777
Site Admin
Site Admin
Posts: 27487
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: Emissions question

Post by Legacy777 » Tue Feb 24, 2015 6:33 pm

Welcome to the BBS!

Yeah, I'd try the coolant temp sensor and see if that changes anything.

How badly are you failing on HC's? Do you have any of the other emissions numbers and their limits you can share?
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm

Alphius
Fourth Gear
Posts: 1204
Joined: Mon Aug 31, 2009 9:09 pm
Location: Rochester, WA

Re: Emissions question

Post by Alphius » Tue Feb 24, 2015 7:12 pm

Run it down to an eighth of a tank and dump a couple bottles of 99% isopropyl alcohol in. Get it as hot as you can and go get tested.

cj91legss
Fifth Gear
Posts: 6306
Joined: Fri Jun 20, 2008 8:17 am
Location: Lakewood, Wa 98439
Contact:

Re: Emissions question

Post by cj91legss » Wed Feb 25, 2015 1:52 pm

rallyak wrote:I would change the violent sensor, that won't throw a code and it is one of the major sensors that directly effects air/fuel mixture and its cheep 20$-25$.

Stupid autocorrect: coolant sensor
I don't see a problem with it being called the violent sensor.... :-D
91 L-TW Wagon with a full Swap -RIP
92 SS Prefaced, GD dash swapped, 22T/205 Hybrid 20 psi - BEAST!
93 SS Bone Stock Gone!
94 TW Bone Stock Gone!
91 SS 4EAT Sold!
98 LGT 4EAT
98 LGT Wagon 4EAT

SignusPrime
In Neutral
Posts: 3
Joined: Mon Feb 23, 2015 10:38 pm
Location: Scottsdale, AZ

Re: Emissions question

Post by SignusPrime » Mon Mar 16, 2015 6:34 pm

Sorry for not replying sooner guys, been pretty busy with school lately. Changed the coolant sensor, and it helped some, but not a whole lot. All my numbers are good aside from HC's, which are still high.

1st idle reading: 247 (down from 292), Final reading: 284 (down from 321) / Idle Standard: 220
Precondition reading: 58 (down from 69) / Precondition standard: 100

Going to have my neighbor look at it later this week (he used to run an auto shop until a few years back) and see what he says,. I guess I'll run the alcohol so it'll at least pass, then actually fix whatever the problem is later on when I have more free time (or money if it has anything to do with the cats).

Legacy777
Site Admin
Site Admin
Posts: 27487
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: Emissions question

Post by Legacy777 » Mon Mar 16, 2015 6:40 pm

Yeah...that's what I'd do....get it to pass and then you can try and fix the issue as time permits.
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm

volny
First Gear
Posts: 173
Joined: Wed Mar 23, 2011 4:19 am

Re: Emissions question

Post by volny » Tue Aug 04, 2015 2:04 am

Is a bad coolant temperature sensor really obvious to diagnose? just curious...

Legacy777
Site Admin
Site Admin
Posts: 27487
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: Emissions question

Post by Legacy777 » Tue Sep 08, 2015 5:38 pm

No, sometimes the issues can be subtle and not so easy to diagnose.
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm

Post Reply