»  BC-BF Legacy Discussion »  Exhaust
#Emissions question

Custom Search
Login | Register




Post new topic Reply to topic  [ 10 posts ] 
Author Message
 Post subject: Emissions question
PostPosted: Mon Feb 23, 2015 10:52 pm 
In Neutral
Joined: Mon Feb 23, 2015 10:38 pm
Posts: 3
Location: Scottsdale, AZ
New to the forum, just acquired my first Subaru about a month ago, and had been lurking here since then in hopes of finding some info, but had a more specific needs than the threads I've seen.

I have a 1993 Legacy wagon, 220k on the odometer, and it refuses to pass emissions. It has new plugs and wires, a recent oil change, and isn't throwing any codes. The only problem I'm having is with the idle HC numbers, even after doing 30 minutes of highway driving beforehand to get to a testing station without any waiting, so I'm sure it was up to temp. I'm just out of ideas, and feel like I'm beating my head against the wall. Any help would be appreciated!


Profile  Offline
Reply with quote  
 Post subject: Re: Emissions question
PostPosted: Tue Feb 24, 2015 12:11 am 
Third Gear
Joined: Wed Oct 26, 2011 7:02 am
Posts: 892
Location: Anchorage,Alaska
I would change the violent sensor, that won't throw a code and it is one of the major sensors that directly effects air/fuel mixture and its cheep 20$-25$.

Stupid autocorrect: coolant sensor

_________________
Charles

90' White/Gray Outback DD workhorse (670,xxx) miles
92' Onyx Metallic (430,xxx) Wife's DD
68' Barracuda formula S 340 4spd coupe (ongoing project)
66' Mustang 2+2 4spd wife's (ongoing project)


Profile  Offline
Reply with quote  
 Post subject: Re: Emissions question
PostPosted: Tue Feb 24, 2015 12:47 am 
In Neutral
Joined: Mon Feb 23, 2015 10:38 pm
Posts: 3
Location: Scottsdale, AZ
Thanks, I'll give that a shot, and see how it goes!

None of the shops near me have them in stock, so I get to wait. :-/


Profile  Offline
Reply with quote  
 Post subject: Re: Emissions question
PostPosted: Tue Feb 24, 2015 6:33 pm 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 27347
Location: Houston, Tx
Welcome to the BBS!

Yeah, I'd try the coolant temp sensor and see if that changes anything.

How badly are you failing on HC's? Do you have any of the other emissions numbers and their limits you can share?

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
Reply with quote  
 Post subject: Re: Emissions question
PostPosted: Tue Feb 24, 2015 7:12 pm 
Fourth Gear
Joined: Mon Aug 31, 2009 9:09 pm
Posts: 1204
Location: Rochester, WA
Run it down to an eighth of a tank and dump a couple bottles of 99% isopropyl alcohol in. Get it as hot as you can and go get tested.

_________________
2005 Legacy GT Limited Wagon 5-Speed. Stock-ish ;)


Profile  Offline
Reply with quote  
 Post subject: Re: Emissions question
PostPosted: Wed Feb 25, 2015 1:52 pm 
Fifth Gear
Joined: Fri Jun 20, 2008 8:17 am
Posts: 6301
Location: Lakewood, Wa 98439
rallyak wrote:
I would change the violent sensor, that won't throw a code and it is one of the major sensors that directly effects air/fuel mixture and its cheep 20$-25$.

Stupid autocorrect: coolant sensor


I don't see a problem with it being called the violent sensor.... :-D

_________________
91 L-TW Wagon with a full Swap -RIP
92 SS Prefaced, GD dash swapped, 22T/205 Hybrid 20 psi - BEAST!
93 SS Bone Stock Gone!
94 TW Bone Stock Gone!
91 SS 4EAT Sold!
98 LGT 4EAT
98 LGT Wagon 4EAT


Profile  Offline
Reply with quote  
 Post subject: Re: Emissions question
PostPosted: Mon Mar 16, 2015 6:34 pm 
In Neutral
Joined: Mon Feb 23, 2015 10:38 pm
Posts: 3
Location: Scottsdale, AZ
Sorry for not replying sooner guys, been pretty busy with school lately. Changed the coolant sensor, and it helped some, but not a whole lot. All my numbers are good aside from HC's, which are still high.

1st idle reading: 247 (down from 292), Final reading: 284 (down from 321) / Idle Standard: 220
Precondition reading: 58 (down from 69) / Precondition standard: 100

Going to have my neighbor look at it later this week (he used to run an auto shop until a few years back) and see what he says,. I guess I'll run the alcohol so it'll at least pass, then actually fix whatever the problem is later on when I have more free time (or money if it has anything to do with the cats).


Profile  Offline
Reply with quote  
 Post subject: Re: Emissions question
PostPosted: Mon Mar 16, 2015 6:40 pm 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 27347
Location: Houston, Tx
Yeah...that's what I'd do....get it to pass and then you can try and fix the issue as time permits.

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
Reply with quote  
 Post subject: Re: Emissions question
PostPosted: Tue Aug 04, 2015 2:04 am 
First Gear
Joined: Wed Mar 23, 2011 4:19 am
Posts: 173
Is a bad coolant temperature sensor really obvious to diagnose? just curious...


Profile  Offline
Reply with quote  
 Post subject: Re: Emissions question
PostPosted: Tue Sep 08, 2015 5:38 pm 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 27347
Location: Houston, Tx
No, sometimes the issues can be subtle and not so easy to diagnose.

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
Reply with quote  

Display posts from previous:  Sort by  

Post new topic Reply to topic  [ 10 posts ] 


Who is online

Users browsing this forum: No registered users and 5 guests

Panel

Top You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
Search for:
Jump to:  
 cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Dizayn Ercan Koc