»  BC-BF Legacy Discussion »  Engine
#Misfire and stuttering under load.

Custom Search
Login | Register




Post new topic Reply to topic  [ 57 posts ]  Go to page Previous  1, 2, 3
Author Message
 Post subject: Re: Misfire and stuttering under load.
PostPosted: Tue Jul 04, 2017 7:16 pm 
Fifth Gear
Joined: Tue Mar 13, 2007 12:56 am
Posts: 2330
Location: 10-9-oh(!), wa
Well... she runs smoother and the hesitation seems to be gone after swapping out the coil pack. I just filled up, so I'll be able to see if my mileage went back up from the ~21-23mpg it was down to.

Oldandslow, did you install a new replacement coil pack?

_________________
93 legacy wagon L, 22T swapped (TW imitator) now with five forward speeds.
johndrivesabox wrote:
Rally, my kyboard is brok, his has nohing o do wih h liquor.

Originalcyn wrote:
Apparently everyone hates Gabe.


Profile  Offline
Reply with quote  
 Post subject: Re: Misfire and stuttering under load.
PostPosted: Thu Jul 06, 2017 12:42 am 
In Neutral
Joined: Sun May 14, 2017 1:21 pm
Posts: 11
Location: New Mexico, USA
beatersubi wrote:
Well... she runs smoother and the hesitation seems to be gone after swapping out the coil pack. I just filled up, so I'll be able to see if my mileage went back up from the ~21-23mpg it was down to.

Oldandslow, did you install a new replacement coil pack?


Definitely keep us updated, I have the exact same issue as y'all do, if I keep it under 10% throttle or so it'll rev to redline however. I took the coilpacks out and redid the wiring (GD coils) to them, it seemed to help some. The coils looked ok but maybe there was hairline cracks.

_________________
1993 Legacy Touring Wagon - EJ20G and 02 WRX 5SP Swapped


Profile  Offline
Reply with quote  
 Post subject: Re: Misfire and stuttering under load.
PostPosted: Sun Jul 16, 2017 6:29 am 
Fifth Gear
Joined: Tue Mar 13, 2007 12:56 am
Posts: 2330
Location: 10-9-oh(!), wa
Filled up today to find that the car got 25.4MPG. Not the best that she's ever done, but a definite improvement. And the with the stuttering/hesitation gone when she gets into positive manifold pressure, I'm less hesitant to take her there.

_________________
93 legacy wagon L, 22T swapped (TW imitator) now with five forward speeds.
johndrivesabox wrote:
Rally, my kyboard is brok, his has nohing o do wih h liquor.

Originalcyn wrote:
Apparently everyone hates Gabe.


Profile  Offline
Reply with quote  
 Post subject: Re: Misfire and stuttering under load.
PostPosted: Tue Jul 18, 2017 6:56 pm 
First Gear
Joined: Sun Dec 08, 2013 7:57 pm
Posts: 121
Location: Northern New Jersey
beatersubi wrote:
Filled up today to find that the car got 25.4MPG. Not the best that she's ever done, but a definite improvement. And the with the stuttering/hesitation gone when she gets into positive manifold pressure, I'm less hesitant to take her there.



I read through the whole thread and realized that you never smoke tested the car. I had almost the same exact issues which is on here due to the intake manifold being cracked. Try smoking the car to see if there is any leaks.

Thought I would throw that in since I experienced a lot of issue like you and would of never thought it was my manifold (I even changed the manifold gaskets and didn't see the crack :shock: )

This is my thread with similar issues:
viewtopic.php?f=5&t=53649

_________________
91 Mica Ruby Legacy Sport 550 Robtune
94 White Pearl Legacy L SOLD
04 San Remo Red Impreza WRX
04 Java Black Pearl Impreza STI
94 Crimson Pearl Legacy Sport Partout


Profile  Offline
Reply with quote  
 Post subject: Re: Misfire and stuttering under load.
PostPosted: Tue Jul 25, 2017 12:36 am 
Fifth Gear
Joined: Tue Mar 13, 2007 12:56 am
Posts: 2330
Location: 10-9-oh(!), wa
subiedoutlegacy wrote:
beatersubi wrote:
Filled up today to find that the car got 25.4MPG. Not the best that she's ever done, but a definite improvement. And the with the stuttering/hesitation gone when she gets into positive manifold pressure, I'm less hesitant to take her there.



I read through the whole thread and realized that you never smoke tested the car. I had almost the same exact issues which is on here due to the intake manifold being cracked. Try smoking the car to see if there is any leaks.

Thought I would throw that in since I experienced a lot of issue like you and would of never thought it was my manifold (I even changed the manifold gaskets and didn't see the crack :shock: )

This is my thread with similar issues:
viewtopic.php?f=5&t=53649


That's a good suggestion. But I think replacing the coilpack has resolved my issue. This might help the OP, though. Oldandslow, did you ever check for leaks under positive manifold pressure?

_________________
93 legacy wagon L, 22T swapped (TW imitator) now with five forward speeds.
johndrivesabox wrote:
Rally, my kyboard is brok, his has nohing o do wih h liquor.

Originalcyn wrote:
Apparently everyone hates Gabe.


Profile  Offline
Reply with quote  
 Post subject: Re: Misfire and stuttering under load.
PostPosted: Mon Sep 18, 2017 11:24 pm 
In Neutral
Joined: Sat Dec 03, 2016 5:23 pm
Posts: 29
Well I finally figured it out. Took it to a local speed shop and the dude there was super knowledgeable. Had a whole table of spare parts ready for when I got there. He threw a used maf on and voila! Car runs great now! Check engine light has gone off as well and stays off. It's still slow haha but at least the drive-ability is there. Now the only thing wrong is my speedo reads 12 mph too fast. At least that's not a huge issue.

_________________
1991 Legacy SS 5spd


Profile  Offline
Reply with quote  
 Post subject: Re: Misfire and stuttering under load.
PostPosted: Mon Oct 09, 2017 4:41 pm 
Fifth Gear
Joined: Tue Mar 13, 2007 12:56 am
Posts: 2330
Location: 10-9-oh(!), wa
Oldandslow wrote:
Well I finally figured it out. Took it to a local speed shop and the dude there was super knowledgeable. Had a whole table of spare parts ready for when I got there. He threw a used maf on and voila! Car runs great now! Check engine light has gone off as well and stays off. It's still slow haha but at least the drive-ability is there. Now the only thing wrong is my speedo reads 12 mph too fast. At least that's not a huge issue.


Good to hear.

_________________
93 legacy wagon L, 22T swapped (TW imitator) now with five forward speeds.
johndrivesabox wrote:
Rally, my kyboard is brok, his has nohing o do wih h liquor.

Originalcyn wrote:
Apparently everyone hates Gabe.


Profile  Offline
Reply with quote  

Display posts from previous:  Sort by  

Post new topic Reply to topic  [ 57 posts ]  Go to page Previous  1, 2, 3


Who is online

Users browsing this forum: Google [Bot] and 1 guest

Panel

Top You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Dizayn Ercan Koc