Code 35 resolved still running rich

Heads, valves, pistons, rods, crankshaft, etc...

Moderators: Helpinators, Moderators

Post Reply
Plazma
First Gear
Posts: 83
Joined: Mon Sep 16, 2013 1:28 pm

Code 35 resolved still running rich

Post by Plazma » Wed Oct 12, 2016 9:37 pm

Hey folks, quick question,


I had a code 35 Canister Purge Valve Solenoid pop up the other night and sure enough I had a really rough idle, misfires, and stalling the whole 9 yards. When I put a meter to the solenoid I got no reading at all just OL on my meter.

Flash forward, I just finished swapping out the solenoid for a working one, it showed about 42 ohms at a little over 70 degrees.

The engine was running smoothly for few moments, but then it seems like the mixture got enriched I could smell raw fuel, and the idle seemed low and rough.

I'm in the process of resetting the computer to see if that will readjust the mixture.

My question is this, can unplugging the canister purge valve solenoid cause your mixture to go out of balance? it was unplugged for about a day.

Legacy777
Site Admin
Site Admin
Posts: 27460
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: Code 35 resolved still running rich

Post by Legacy777 » Thu Oct 13, 2016 5:26 pm

What is possible is that fuel vapors were stored in the charcoal canister and since they weren't being drawn into the engine that may be what you're smelling.
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm

Plazma
First Gear
Posts: 83
Joined: Mon Sep 16, 2013 1:28 pm

Re: Code 35 resolved still running rich

Post by Plazma » Thu Oct 13, 2016 7:08 pm

Quick update. After leaving the computer to reset the 35 code disappeared and was replaced with a Code 15. I'll be trouble shooting the injector tomorrow.

Plazma
First Gear
Posts: 83
Joined: Mon Sep 16, 2013 1:28 pm

Re: Code 35 resolved still running rich

Post by Plazma » Fri Oct 14, 2016 8:10 pm

Turns out it was a bad injector. I swapped with a working one from my donor engine. No more misfires no more related codes.

I still have the issue where my RPMs drop really low and then climb back up after a few seconds.

Legacy777
Site Admin
Site Admin
Posts: 27460
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: Code 35 resolved still running rich

Post by Legacy777 » Mon Oct 24, 2016 5:31 pm

When does the rpm fluctuation you describe occur and does it happen frequently?
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm

tinyturbo10
First Gear
Posts: 58
Joined: Sat Feb 01, 2014 10:49 pm

Re: Code 35 resolved still running rich

Post by tinyturbo10 » Mon Mar 20, 2017 3:13 am

Did you ever figure out what the idle issue was? I'm having the same problem. I have a whole new intake manifold to swap on with all new sensors and injectors and what not that are on it. I have code 35 flashing as well and my car idles rough. I think it's an injector as well.


Sent from my iPhone using Tapatalk

Legacy777
Site Admin
Site Admin
Posts: 27460
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: Code 35 resolved still running rich

Post by Legacy777 » Mon Mar 27, 2017 5:46 pm

Have you checked to verify the canister purge valve and the associated wiring is good?

It's always a good idea to make the ECU happy so if it thinks there is a bad canister purge valve I'd suggest investigating/replacing it even if you don't think that is the problem.
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm

MonteC
In Neutral
Posts: 1
Joined: Sat Apr 29, 2017 12:34 pm

Re: Code 35 resolved still running rich

Post by MonteC » Fri May 05, 2017 7:55 am

Plazma wrote:Quick update. After leaving the computer to reset the 35 code disappeared and was replaced with a Code 15. So click here to get Xtrasize. I'll be trouble shooting the injector tomorrow.
What is a code 15?
Last edited by MonteC on Sat Sep 30, 2017 9:47 am, edited 2 times in total.

Legacy777
Site Admin
Site Admin
Posts: 27460
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: Code 35 resolved still running rich

Post by Legacy777 » Fri May 05, 2017 6:03 pm

Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm

Subpurparu
In Neutral
Posts: 15
Joined: Sun Mar 10, 2019 9:00 am

Re: Code 35 resolved still running rich

Post by Subpurparu » Sun Mar 10, 2019 9:31 am

What I did was I cut the ends of the hoses for a more snug fit and it worked great. My code was gone after the first ecu reset.

Post Reply