25d manifold sti injector issue

Heads, valves, pistons, rods, crankshaft, etc...

Moderators: Helpinators, Moderators

Post Reply
91Legacyresto
In Neutral
Posts: 41
Joined: Sun Feb 24, 2019 6:16 am

25d manifold sti injector issue

Post by 91Legacyresto »

i feel like a dummy. I keep flooding the engine with the injectors. I bought new orings and it feels like they all seal fine inside the fuel rails. Now, all of my injectors are missing the center rubber pieces in the caps, ontop that cover the pin sticking upwards. As i prime my fuel system i can hear a very loud hissing noise and i end up filling all 4 cylinders with fuel. All 4 fuel injectors are unplugged. By keeping the spark plugs removed i turn the motor over by hand to push the fuel back out.

By not having those center caps ontop...is that causing my injectors to open and force fuel into my intake and cylinders? Ive tried 2 sets of injectors and both sets are missing the center caps ontop. Both sets also have all new orings. If its not the center caps then im starting to lean towards the fuel rail to manifold seals are bad? Though i thought if those were bad it would leak externally onto the engine, not internally. Ive been battling this for a few weeks and havent figured it out.

22e/25d hybrid. Removed the red top injectors in favor of the 550cc yellow top sti injectors. Having one hell of a hard time figuring out why so much fuel is being forced into the cylinders. ImageImage

Sent from my SM-N975U using Tapatalk

91 LS Turbo Project

Legacy777
Site Admin
Site Admin
Posts: 27629
Joined: Tue Oct 15, 2002 11:37 am
Location: Houston, Tx
Contact:

Re: 25d manifold sti injector issue

Post by Legacy777 »

Those top gray caps are just dust caps and shouldn't be on when you put the metal caps on.

I have a couple questions/comments for you.

Just to confirm you are using this setup on a turbo motor correct?

Was the intake manifold and injector fuel rail from a 92-94 non-turbo EJ22?

If you are using a 92-94 non-turbo EJ22 fuel rail then take a look at these pictures and see if you have all the correct o-rings installed on the injectors.

https://main.experiencetherave.com/suba ... injectors/

Assuming you have all the correct o-rings on and the correct fuel rails then my suspicion is you don't have the injectors properly seated in the fuel rails. It takes a decent amount of force to get them seated in the rails. You should use some Vaseline or injector o-ring lube. The injectors will snap/pop into place when they are properly seated.

Here are some pictures of the yellow tops when I installed them. You can see in one of the pictures I left one dust cap off an another on just showing the difference. But as I mentioned above you should take the dust caps off when you install the injector caps.

https://main.experiencetherave.com/suba ... efault.htm
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
2020 Outback Limted XT

If you need to get a hold of me please email me rather then pm

Post Reply