»  BC-BF Legacy Discussion »  Drivetrain
#Detailed AWD & 5MT Swap Write-up completed

Custom Search
Login | Register




Post new topic Reply to topic  [ 121 posts ]  Go to page Previous  1, 2, 3, 4, 5  Next
Author Message
 Post subject:
PostPosted: Wed Jun 20, 2007 1:57 am 
Fourth Gear
Joined: Tue Sep 12, 2006 6:49 am
Posts: 1636
Location: Seattle, WA
Well after correcting my mistake, only took a few minutes to wire up the real cruise relay. Took it for a test drive and it works!

_________________

'11 WRX Limited
'94 SS | 3" TBE, 07 TMIC, TD05H-16G, Revtronix Stage 2, Walbro -- Sold
'94 TW | R.I.P.


Profile  Offline
Reply with quote  
 Post subject:
PostPosted: Wed Jun 20, 2007 2:45 pm 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 27422
Location: Houston, Tx
Glad you got it sorted out.

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
Reply with quote  
 Post subject:
PostPosted: Thu Jun 21, 2007 12:18 am 
Fourth Gear
Joined: Sat Aug 09, 2003 5:02 pm
Posts: 1897
Location: Greenville, SC
Pssht! Who needs cruise?

I kinda lost mine when I replaced the steering wheel. I still haven't gotten around to removing the computer yet, but all of the underhood stuff is gone.

_________________
Disclaimer: If anything I post is inaccurate, please correct me. I do not wish to add to the misinformation floating around on the internet.

That being said, everything I post is accurate to the best of my knowledge.

Rio Red '91 Legacy SS


Profile  Offline
Reply with quote  
 Post subject:
PostPosted: Thu Jun 21, 2007 5:34 pm 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 27422
Location: Houston, Tx
Go on a long trip....you'll want one.

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
Reply with quote  
 Post subject:
PostPosted: Sun Oct 21, 2007 7:07 am 
In Neutral
Joined: Tue Oct 16, 2007 8:37 pm
Posts: 22
Location: MN
Im doing a swap to a 5mt from a 99 rs-turbo with an ej20g and 5mt. The guy I'm buying everything from (tranny, clutch, flywheel, linkages, pedals, driveshaft, etc) said that the current tranny uses an electrical speedo cable where my '92 ss uses a mechanical cable. Any proof or workaround to this?

If I don't care about cruise or reverse lights, am I correct that there's really only 1 cable that needs to be spliced to get up and running?

Thanks,
Bryan

_________________
~Bryan

'92 Legacy Sport Sedan - Winter fun
Stock 4EAT
5Speed swap and other goodies in the works : )

'03 Cobra - Summer trouble
All the bolt ons
463 WHP
480 WTq.

'02 WRX - Sold long ago :(


Profile  Offline
Reply with quote  
 Post subject:
PostPosted: Mon Oct 22, 2007 7:06 pm 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 27422
Location: Houston, Tx
You can remove the electrical speed sensor from the tranny, unscrew the mechanical from the old tranny, and put it in the new tranny.

At a minimum, you need to splice the wires together for the starter interlock circuit to work. You should also hook up the neutral switch wires (this is for the ECU), also you need to snip the AT/MT identifier pin, and pull the TCU. That would be the minimum IMO.....and if I'm doing that, I'd hook the reverse lights up....it's just two more wires.

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
Reply with quote  
 Post subject:
PostPosted: Fri Apr 18, 2008 8:24 pm 
First Gear
Joined: Fri Feb 08, 2008 6:58 am
Posts: 58
hey, awesome description of the swap. i blew my auto trans last week and am starting my swap today to a 5mt. any giant tips you have to give me????


Profile  Offline
Reply with quote  
 Post subject:
PostPosted: Sat Apr 19, 2008 4:09 am 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 27422
Location: Houston, Tx
Not really any big tips that I can think of. Just take your time and make sure you label hoses and wires if you undo any.

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
Reply with quote  
 Post subject:
PostPosted: Fri Apr 25, 2008 7:40 am 
First Gear
Joined: Fri Feb 08, 2008 6:58 am
Posts: 58
is the harness that you frankensteined yourself the one that runs from the top of the trans down the side of it on the drivers side of the 5 mt??


Profile  Offline
Reply with quote  
 Post subject:
PostPosted: Sat Apr 26, 2008 9:45 pm 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 27422
Location: Houston, Tx
No, that harness is/should be already on the 5mt.

You can see in this pic that the harness is already there.
http://www.surrealmirage.com/subaru/ima ... P_3337.JPG

I made a short harness to connect that one on the 5mt to the AT plug in the engine bay.

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
Reply with quote  
 Post subject:
PostPosted: Sun Apr 27, 2008 4:49 pm 
First Gear
Joined: Fri Feb 08, 2008 6:58 am
Posts: 58
so if i dont have to extra harness to to that, what are my options, or do i need to go get an extra harness.

there are two big harnesses that plugged into the auto tranny what do i do with those


Profile  Offline
Reply with quote  
 Post subject:
PostPosted: Sun Apr 27, 2008 10:04 pm 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 27422
Location: Houston, Tx
What I'd suggest doing is cutting the harness on the auto trans, so you can some what make a custom harness. You can cut the harness on the MT, and splice into it.

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
Reply with quote  
 Post subject:
PostPosted: Sun Apr 27, 2008 10:58 pm 
First Gear
Joined: Fri Feb 08, 2008 6:58 am
Posts: 58
yah thats what i was thinking of doing. do i absolutely need the harness that goes to the neutral switch???


Profile  Offline
Reply with quote  
 Post subject:
PostPosted: Mon Apr 28, 2008 5:55 pm 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 27422
Location: Houston, Tx
You mean, do you absolutely need to wire up the neutral switch?

I think others have gone without, but if you're wiring something up for the reverse lights, I don't see what the big deal is to add another wire or two for the neutral switch.

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
Reply with quote  
 Post subject:
PostPosted: Tue Apr 29, 2008 12:46 am 
First Gear
Joined: Fri Feb 08, 2008 6:58 am
Posts: 58
thanks alot man ill let you know how it goes, or if i screw up somewhere i will be back


Profile  Offline
Reply with quote  
 Post subject:
PostPosted: Wed May 07, 2008 5:26 am 
First Gear
Joined: Fri Feb 08, 2008 6:58 am
Posts: 58
dude, i need, some help. so i got the tranny in and everthing to do with it and wired like you said to.


it does not start. the starter wont turn. I checked all the grounds and all my wiring and nothing.

please help me


Profile  Offline
Reply with quote  
 Post subject:
PostPosted: Thu May 08, 2008 9:29 pm 
Fourth Gear
Joined: Tue Sep 12, 2006 6:49 am
Posts: 1636
Location: Seattle, WA
Did you wire up that starter interlock relay harness? If that's not wired up properly, the car won't turn over.

_________________

'11 WRX Limited
'94 SS | 3" TBE, 07 TMIC, TD05H-16G, Revtronix Stage 2, Walbro -- Sold
'94 TW | R.I.P.


Profile  Offline
Reply with quote  
 Post subject:
PostPosted: Fri May 09, 2008 7:09 am 
First Gear
Joined: Fri Feb 08, 2008 6:58 am
Posts: 58
okay, so what i did:

spliced two b15 connectors together, pins 9AT to 2MT, 10AT to 4MT, 1AT to 1MT, 4At to 3MT.


took out key lock controller and the tcu.

i got the car started by roll starting it today, drives like a beaut.

but i have no back up lights or starting??


Profile  Offline
Reply with quote  
 Post subject:
PostPosted: Sat May 10, 2008 11:38 pm 
First Gear
Joined: Fri Feb 08, 2008 6:58 am
Posts: 58
could someone help me please


Profile  Offline
Reply with quote  
 Post subject:
PostPosted: Tue May 13, 2008 5:45 pm 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 27422
Location: Houston, Tx
Chances are you wired things incorrectly at the B15 connector.

When reading the wiring diagram, the B15 connector is the one connected to the car chassis side. You read the pins by looking directly at the connector. So for B15, looking directly at it. Pins 11 & 12 are in the bottom right hand corner.

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
Reply with quote  
 Post subject:
PostPosted: Tue May 13, 2008 7:12 pm 
First Gear
Joined: Fri Feb 08, 2008 6:58 am
Posts: 58
Thanks alot man, yah i think i was looking at it from the back of the connector.


Profile  Offline
Reply with quote  
 Post subject:
PostPosted: Wed May 14, 2008 1:03 am 
First Gear
Joined: Fri Feb 08, 2008 6:58 am
Posts: 58
so if you are looking directly at the chassis side connector the pins are bottom right??

and for the mt/ at pin is that looking into the ecu or looking at the harness??


Profile  Offline
Reply with quote  
 Post subject:
PostPosted: Fri May 16, 2008 5:53 pm 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 27422
Location: Houston, Tx
Yeah the two bottom right pins are the ones that need to be jumpered together or tied into a "starter interlock relay setup".

For the mt/at pin, that is looking at the ECU.

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
Reply with quote  
 Post subject:
PostPosted: Sat Oct 04, 2008 1:17 am 
First Gear
Joined: Thu Jul 24, 2003 3:01 am
Posts: 79
Location: Pennsylvania
Has anyone done the swap on a newer Legacy.

I finished the swap on my 97 today, it runs great, but seems to use a lot of gas so far. Mileage has dropped to about 15mpg.

For wiring all I've done is to splice the wires for the starter, and wire in the reverse light switch. According to the FSM's for 97, pin 20 of the ECU harness goes to the TPS and the CTS, so I doubt that's the one I want to cut.

Thanks

_________________
Dave
-97 Legacy (ain't never gonna die)
-92 SVX (attention whore)
-86 Brat (more fun than the SVX)
-92 SVX Racer (lightest SVX)


Profile  Offline
Reply with quote  
 Post subject:
PostPosted: Wed Oct 08, 2008 12:28 am 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 27422
Location: Houston, Tx
How does it idle? It still should have a MT/AT ident switch, or you may have to swap ECU's.

I would not expect the ecu pins to be the same.

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
Reply with quote  

Display posts from previous:  Sort by  

Post new topic Reply to topic  [ 121 posts ]  Go to page Previous  1, 2, 3, 4, 5  Next


Who is online

Users browsing this forum: No registered users and 1 guest

Panel

Top You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Dizayn Ercan Koc