»  BC-BF Legacy Discussion »  Drivetrain
#Clutch wont engage help!

Custom Search
Login | Register




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Clutch wont engage help!
PostPosted: Mon Oct 05, 2015 4:46 am 
In Neutral
Joined: Tue Sep 29, 2015 7:27 am
Posts: 5
Alright so i just finished swapping motors from my 92 legacy ss into my 91 ss. Everything is great except for the fact that my clutch wont engage. I can start the car but i have no clutch pedal. Im not sure what happend becuase neither of the cars had amd issues with the tranny prior to the swap so it has to be something i did wrong but what could it be? I know i put the throw out bearing in the correct way and ive bleed the clutch but im not sure where to go from here

_________________
2003 wrx wagon (stock),1992 subaru legacy SS, built 1991 subaru legacy SS


Profile  Offline
Reply with quote  
 Post subject: Re: Clutch wont engage help!
PostPosted: Mon Oct 05, 2015 6:40 pm 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 27243
Location: Houston, Tx
Can you provide any additional information as to what you've done to troubleshoot the problem?

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
Reply with quote  
 Post subject: Re: Clutch wont engage help!
PostPosted: Mon Mar 20, 2017 12:31 am 
First Gear
Joined: Fri Mar 25, 2016 2:48 pm
Posts: 191
Location: Beautiful Downtown Goode, VA
I'm having the same trouble....at a total loss to understand it


Profile  Offline
Reply with quote  
 Post subject: Re: Clutch wont engage help!
PostPosted: Mon Mar 20, 2017 7:12 am 
First Gear
Joined: Sun Jan 22, 2012 8:16 am
Posts: 127
Location: Yakima WA
Did you recently do anything with the clutch and does your car have a turbo transmission or a na trans?

_________________
91 ss Ej22t dohc td04 sti Slanty haltech elite 1500


Profile  Offline
Reply with quote  
 Post subject: Re: Clutch wont engage help!
PostPosted: Mon Mar 27, 2017 6:16 pm 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 27243
Location: Houston, Tx
WRXish wrote:
I'm having the same trouble....at a total loss to understand it


I thought you had a non-turbo car with cable transmission? If so this would likely be a completely different issue than what the turbo transmission was likely dealing with.

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
Reply with quote  

Display posts from previous:  Sort by  

Post new topic Reply to topic  [ 5 posts ] 


Who is online

Users browsing this forum: No registered users and 2 guests

Panel

Top You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Dizayn Ercan Koc