ABS pump stuck on

Where the power meets the road.

Moderators: Helpinators, Moderators

Post Reply
Mpgingerson
First Gear
Posts: 97
Joined: Mon Sep 28, 2015 12:05 pm

ABS pump stuck on

Post by Mpgingerson » Mon Nov 02, 2015 10:43 pm

On my way home I did a couple of pulls, and the ABS light came on and it has happened before, but simply disconnecting the battery terminal and putting it on again removed the problem for a period of time, but now it's on all the time, I even tried letting the car reset for three hours and depressing the brake pedal a couple of times, but the problem still occurs... Sometimes when standing still and being on the brake it makes a horrible grinding noise and I can feel the stutter in the pedal itself.

I removed the ABS fuse and the sound went away and no light in the dash, but I don't want to drive without ABS, so please.. Heeelp :(

mike-tracy
Moderator
Moderator
Posts: 4945
Joined: Tue Aug 25, 2009 7:52 am
Location: Des Moines, Wa

Re: ABS pump stuck on

Post by mike-tracy » Tue Nov 03, 2015 12:08 am

Search how to check ABS codes. The abs computer is under the passenger seat. My guess is one of the wheel sensors was intermittent before, and its just a coincidence about the timing in relation to your driving.
1992 Legacy SS 5mt, build in progress
Josh Colombo wrote:
Mon Jan 14, 2002 10:23 am
Wait....I'm confused now.

Mpgingerson
First Gear
Posts: 97
Joined: Mon Sep 28, 2015 12:05 pm

Re: ABS pump stuck on

Post by Mpgingerson » Tue Nov 03, 2015 2:30 pm

mike-tracy wrote:Search how to check ABS codes. The abs computer is under the passenger seat. My guess is one of the wheel sensors was intermittent before, and its just a coincidence about the timing in relation to your driving.
Error code "9" (Faulty motor and/or motor relay or broken or shorted harness circuit) it makes sense that this code exists, since when I shut the car off the pump is humming like a fan and is draining the battery.. Is there some way I can try to fix it or do I have to buy a new one? And if I have to buy a new one, is there any improved replacement like a newer pump from a new WRX or something?

mike-tracy
Moderator
Moderator
Posts: 4945
Joined: Tue Aug 25, 2009 7:52 am
Location: Des Moines, Wa

Re: ABS pump stuck on

Post by mike-tracy » Tue Nov 03, 2015 6:45 pm

Underneath the plastic ABS cover in the engine bay is 2 relays. For my last car with the same symptoms as yours, it was the relay with the raised 'cross' on it. The dealer was able to find the part number and get me the relay. Iirc it was around $40.

My current car also has code 9, replaced the relays but I dont have the abs pump running at any time, so I think the pump is dead.
1992 Legacy SS 5mt, build in progress
Josh Colombo wrote:
Mon Jan 14, 2002 10:23 am
Wait....I'm confused now.

Mpgingerson
First Gear
Posts: 97
Joined: Mon Sep 28, 2015 12:05 pm

Re: ABS pump stuck on

Post by Mpgingerson » Tue Nov 03, 2015 11:08 pm

mike-tracy wrote:Underneath the plastic ABS cover in the engine bay is 2 relays. For my last car with the same symptoms as yours, it was the relay with the raised 'cross' on it. The dealer was able to find the part number and get me the relay. Iirc it was around $40.

My current car also has code 9, replaced the relays but I dont have the abs pump running at any time, so I think the pump is dead.

Okay thanks! I'll try bleeding all the brakes first and flushing with new fluid since the old one looks a little brownish and hasy, but I think a new relay is in order yes.

impostor
First Gear
Posts: 60
Joined: Sat Mar 29, 2003 5:57 am
Location: Omaha, NE

Re: ABS pump stuck on

Post by impostor » Tue Feb 09, 2016 2:30 am

I'm having the same issue. I pulled the relay and noticed the terminal layout is very similar to the air pump relay on the newer ej255's. I'll know for sure tomorrow. If it's the same it would be great because a lot of folks around here ditch the secondary air system when the valves go bad.

Edit: Relay is functionally the same, the case is slightly different shape but still fits just fine.

Post Reply