»  Community »  Build Journals
#Tyler's Legacy SS.... under an impreza shell

Custom Search
Login | Register




Post new topic Reply to topic  [ 126 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6  Next
Author Message
 Post subject:
PostPosted: Wed Apr 22, 2009 4:33 am 
Third Gear
Joined: Sun Apr 03, 2005 6:01 am
Posts: 728
Location: Casper, WY
I worked at the dealership for a while and got ahold of a really bad head from a new legacy turbo. I scrapped the head and cut out the oil return and cleaned it up really well. As fo the coolant I just ordered one for an 07 sti and one ffrom an early WRX. THey guy who ported my heads machined/ tapped the the heads and I did the install.

_________________
1970 Honda Ct90
2001 Forester S of Doom
1994/5/6/01/02/03/04/06/07/08 Impregacy OUtback SS STi Type R money pit- NEW RALLYCAR!!


Profile  Offline
 
 Post subject:
PostPosted: Thu Apr 23, 2009 2:10 am 
Third Gear
Joined: Sun Apr 03, 2005 6:01 am
Posts: 728
Location: Casper, WY
I am successful!!!!

After priming the oil pump I hit the starter and she fired up first try. I bled the cooling system and had to go cause they were closing up shop.

I am going to install the dash in the morning and Plate it Now Its time for break in.

The twin scroll setup sounds so smooth and so sweet. No boxer burble here... Which I bet I will miss

_________________
1970 Honda Ct90
2001 Forester S of Doom
1994/5/6/01/02/03/04/06/07/08 Impregacy OUtback SS STi Type R money pit- NEW RALLYCAR!!


Profile  Offline
 
 Post subject:
PostPosted: Thu Apr 23, 2009 2:15 am 
Fourth Gear
Joined: Sat Nov 08, 2008 10:57 pm
Posts: 1018
Location: Damariscotta, Maine
;-)

_________________
94SS.Wiseco forged pistons,TD04,TMIC,WALBRO 225,440's,3" all the way,revtronix stage 2,enough other crap to fill the internet.

THE TRIBUTE BUILD>>>LINKY LINK>>> viewtopic.php?p=295455#295455


Profile  Offline
 
 Post subject:
PostPosted: Thu Apr 23, 2009 2:29 am 
Third Gear
Joined: Sun Apr 03, 2005 6:01 am
Posts: 728
Location: Casper, WY
Thanks! I really can't believe how quite the engine itself is. Even with forged pistons, the loudest part in the engine bay is the boost control solenoid. Who would have thought?

_________________
1970 Honda Ct90
2001 Forester S of Doom
1994/5/6/01/02/03/04/06/07/08 Impregacy OUtback SS STi Type R money pit- NEW RALLYCAR!!


Profile  Offline
 
 Post subject:
PostPosted: Thu Apr 23, 2009 7:39 pm 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 24630
Location: Houston, Tx
Congrats Tyler!

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
 
 Post subject:
PostPosted: Thu Apr 23, 2009 8:07 pm 
Third Gear
Joined: Sun Apr 03, 2005 6:01 am
Posts: 728
Location: Casper, WY
Thanks josh.

This thing is amazing and I haven't got to push it yet. I have a bit of hesitation that I am trying to figure out. I think it has to do with how I had to mount the TPS.

I drove it to work this morning and just got back from getting plates. Once I get more than a down pipe on it I will post some more pictures and video.

It definitley doesn't sound like a subaru. I think with the exhaust I have planned for it it should be much more like the WRC car sound, which wouldn't bother me a bit :lol:

I plan to get alot of miles on it tonight and this weekend so I can hook up more than just wastegate boost pressure.

I owe a big thanks to everyone on this board. I learned a lot from others' builds and Matt Monson provided most of my parts.

_________________
1970 Honda Ct90
2001 Forester S of Doom
1994/5/6/01/02/03/04/06/07/08 Impregacy OUtback SS STi Type R money pit- NEW RALLYCAR!!


Profile  Offline
 
 Post subject:
PostPosted: Fri Apr 24, 2009 5:49 pm 
First Gear
Joined: Mon Feb 27, 2006 11:30 pm
Posts: 123
Location: centennial co/wyotech
sweet, you gonna have it at the next rally-x??:)

_________________
92 SVX LSL tour- 5spd swap baby
92 turbo touring wagon now also 5-speed swapped
89 xt6 stock
danetrain wrote:
Fuck wyoming


Profile  Offline
 
 Post subject:
PostPosted: Sun Apr 26, 2009 12:28 am 
Third Gear
Joined: Sun Apr 03, 2005 6:01 am
Posts: 728
Location: Casper, WY
Finished up the exhaust today. I spent about $100 on ebay on 2.5" pipeing, a few bends and a Catalytic converter. Pretty good deal I think. ANyway I just cut and welded the pipe myself. That cat goes on the end just like the WRC and Rally America guys do it.

So here is what it looks like:

Image

Image

Check out the clearance. its really close but the exhaust does NOt move. THought I did pretty well for not having a bender

Image

oh and it sounds like a Rally car. But more liveable around town. WOT however sounds so good. I will try to get a sound clip up this weekend.

_________________
1970 Honda Ct90
2001 Forester S of Doom
1994/5/6/01/02/03/04/06/07/08 Impregacy OUtback SS STi Type R money pit- NEW RALLYCAR!!


Profile  Offline
 
 Post subject:
PostPosted: Sun Apr 26, 2009 7:21 am 
Fifth Gear
Joined: Wed Aug 04, 2004 3:52 am
Posts: 2738
Location: Colorado
glad the rtv worked for you, that teflon tape really isnt worth crap. I think it's illegal to use it on gas line now. hopefully i'll get to check out your car sometime.

_________________
///M
'93 Legacy SS - part out


Profile  Offline
 
 Post subject:
PostPosted: Sun Apr 26, 2009 7:58 am 
Third Gear
Joined: Sun Apr 03, 2005 6:01 am
Posts: 728
Location: Casper, WY
definitely. You're Still in boulder right?

Don't know how I feel about the diffs in th the snow/slush...

_________________
1970 Honda Ct90
2001 Forester S of Doom
1994/5/6/01/02/03/04/06/07/08 Impregacy OUtback SS STi Type R money pit- NEW RALLYCAR!!


Profile  Offline
 
 Post subject:
PostPosted: Sun Apr 26, 2009 8:30 am 
Fifth Gear
Joined: Tue Jan 25, 2005 9:14 pm
Posts: 3050
Location: Twin Cities, MN
Looks nice. You guys and your everyday clean shells that I'm jealous of.



What wiring harness and ECU are you using? I'm curious of what route you went to run the cop's and all that.



This thing should spool like there almost isn't a turbo there. I can't wait to see a dyno plot from this beast.

_________________
→Dan

piddster34 at h0tma1l d0t c0m


Profile  Offline
 
 Post subject:
PostPosted: Sun Apr 26, 2009 5:56 pm 
Third Gear
Joined: Sun Apr 03, 2005 6:01 am
Posts: 728
Location: Casper, WY
I used the ej20g harness from a V2 Wrx and the 6k STi ecu. The ecu is capable of revving to 8000rpm.

I just followed the COP conversion on nasioc, but i had an 07 STI engine harness laying around.

Spool does seem odd. I push the throttle and it's there. Granted i am only runnin waste gate pressure right now, it drives like a big na car. it will be interesting to hook up the boost controller once i am sure of everything.

_________________
1970 Honda Ct90
2001 Forester S of Doom
1994/5/6/01/02/03/04/06/07/08 Impregacy OUtback SS STi Type R money pit- NEW RALLYCAR!!


Profile  Offline
 
 Post subject:
PostPosted: Mon Apr 27, 2009 9:17 pm 
Fifth Gear
Joined: Wed Aug 04, 2004 3:52 am
Posts: 2738
Location: Colorado
yep still in boulder. Hopefully once school gets out i'll have a chance to put my other engine in. The one now had the stud holding the exhaust manifold up strip out so it sounds awful.

_________________
///M
'93 Legacy SS - part out


Profile  Offline
 
 Post subject:
PostPosted: Mon Apr 27, 2009 11:09 pm 
Fourth Gear
Joined: Sat Nov 08, 2008 10:57 pm
Posts: 1018
Location: Damariscotta, Maine
Quote:
Spool does seem odd. I push the throttle and it's there.


Poooor poooor you,i sure hope you get that fixed...sure sounds like a problem :lol:

_________________
94SS.Wiseco forged pistons,TD04,TMIC,WALBRO 225,440's,3" all the way,revtronix stage 2,enough other crap to fill the internet.

THE TRIBUTE BUILD>>>LINKY LINK>>> viewtopic.php?p=295455#295455


Profile  Offline
 
 Post subject:
PostPosted: Tue Apr 28, 2009 12:13 am 
Third Gear
Joined: Sun Apr 03, 2005 6:01 am
Posts: 728
Location: Casper, WY
Ha ha ha! oh sorry... I mean... well I drove a forester XT yesterday and that has teh turbo "hit" nothing than lots of pulling. MIne just pulls and is smooth, but that was what I was hoping for.

Need to get a wideband an guage and a something to detect knock before I hook up the boost controller.

Took a quick spin in gravel yesterday and I think What I like most about the car is how "complete" it feels. Power output matches the brakes and suspension. But with Gravel tires, that extra 7psi might be just the ticket.

_________________
1970 Honda Ct90
2001 Forester S of Doom
1994/5/6/01/02/03/04/06/07/08 Impregacy OUtback SS STi Type R money pit- NEW RALLYCAR!!


Profile  Offline
 
 Post subject:
PostPosted: Wed May 06, 2009 5:13 am 
Third Gear
Joined: Sun Apr 03, 2005 6:01 am
Posts: 728
Location: Casper, WY
So I have been running a bit on the rich side, judging by the black come out.

I have 2 CELs. Throttle position sensor and Knock sensor. Knock sensor I don't understand since it is brand new.

As far as the TPS goes, closed is reading 5.08Volts and WOT is reading about 1.2v. So someone correct me if I am wrong, but I need to switch the Positive and the ground wire.

But first, The transmission is not letting me shift into first. I took a look at all the linkage and everything is OK, so It looks like I am pulling it out to fix something inside. Doesn't feel like the broken shift fork in wour original rallycross car. Would really like to swap in something with 4.11 or 4.44. But that will have to wait.
What really bugs me is that, I wasn't doing anything aggressive, I was pulling into a parking spot. If it had to go, it should have been a bit more spectacular :(

_________________
1970 Honda Ct90
2001 Forester S of Doom
1994/5/6/01/02/03/04/06/07/08 Impregacy OUtback SS STi Type R money pit- NEW RALLYCAR!!


Profile  Offline
 
 Post subject:
PostPosted: Wed May 06, 2009 5:05 pm 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 24630
Location: Houston, Tx
The older TPS's had a reversed voltage setup. That is correct. The only thing that looks a little odd is the 5.08 volts. Typically that should be around 4.7 volts closed, and 0.8 volts open. You sure your wiring is correct and you've got the reference voltage wired up properly?

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
 
 Post subject:
PostPosted: Wed May 06, 2009 5:06 pm 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 24630
Location: Houston, Tx
Here's some scans which may help diagnosing the issue

http://main.experiencetherave.com/subar ... sting1.jpg
http://main.experiencetherave.com/subar ... sting2.jpg
http://main.experiencetherave.com/subar ... sting3.jpg

http://main.experiencetherave.com/subar ... ns/TPS.jpg
http://main.experiencetherave.com/subar ... es/tps.jpg

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
 
 Post subject:
PostPosted: Wed May 06, 2009 7:00 pm 
Fourth Gear
Joined: Tue Oct 18, 2005 3:52 pm
Posts: 1526
Location: Massillon, Ohio
Legacy777 wrote:
The older TPS's had a reversed voltage setup. That is correct. The only thing that looks a little odd is the 5.08 volts. Typically that should be around 4.7 volts closed, and 0.8 volts open. You sure your wiring is correct and you've got the reference voltage wired up properly?


Josh is right. I also think the voltage reads too high. Where did you source the ground for the TPS from? When I wired my EJ22T in my impreza I had a problem with my signal and it was due to a problem with the ground I had running to the ECU. I ended up grounding the sensor to a short ground running to the body and then grounded the pin for the sensor out at the ECU it fixed my problems right up.

_________________
SUBARUEHS Racing


Profile  Offline
 
 Post subject:
PostPosted: Thu May 07, 2009 5:55 pm 
Third Gear
Joined: Sun Apr 03, 2005 6:01 am
Posts: 728
Location: Casper, WY
I don't having to do any wiring for the TPS, since I used the whole wiring harness for the WRX. with the voltage that high, Could it just be a matter of adjusting the TPS?

Also what might be the side effects of the TPS being off? I think I am running a bit on the rich side as I have quite a bit of soot in the exhaust and gas milage is not so great.

THe odd voltage of the tps probably explains the surging while cruising at low throttle openings.

_________________
1970 Honda Ct90
2001 Forester S of Doom
1994/5/6/01/02/03/04/06/07/08 Impregacy OUtback SS STi Type R money pit- NEW RALLYCAR!!


Profile  Offline
 
 Post subject:
PostPosted: Fri May 08, 2009 3:21 pm 
Fourth Gear
Joined: Wed Jan 10, 2007 4:23 pm
Posts: 1301
Location: Bx, NY
I think you can adjust the TPS some, I'd set it to 4.7v closed as was said above.

_________________
94 Legacy SS
96 Impreza OBS
99 Impreza OBS-T
04 Sienna XLE Limited AWD


Profile  Offline
 
 Post subject:
PostPosted: Fri May 08, 2009 7:18 pm 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 24630
Location: Houston, Tx
What is the reference voltage from the ECU?

The signal voltage coming back to the ECU should ALWAYS be less than the reference voltage.

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
 
 Post subject:
PostPosted: Tue May 26, 2009 8:21 am 
Third Gear
Joined: Sun Apr 03, 2005 6:01 am
Posts: 728
Location: Casper, WY
Damn I really need to update some pictures...

I am still looking into my TPS issues and my knock sensor issues. TH knock sensor shouldn't be bad since its new. Does the ECU fire off a CEL when it sees knock. I just found an audible tick and I don't know exactly what it is. The engine wasn't super warm, so I am thinking it was just the forged pistons.

I just fixd some tranny issues. Long story short I only had 2nd and 4th and reverse. Lost a pin on the shaft for reverse gear, shaft slid back, thrust washer jammed shift forks. Consider it fixed.

Now i have an oil leak. You know the oil return pipe that was pressed into the head? My machinist went too big on that hole and it was no longer a press fit... I originally tried RTV sealant... lasted 600 miles. NOw I am looking for a permanent solution. ONe friend suggested basically chamfering the hole and using an o-ring. Someone on here mentioned epoxy which got me thinking JB weld.

Suggestions?

_________________
1970 Honda Ct90
2001 Forester S of Doom
1994/5/6/01/02/03/04/06/07/08 Impregacy OUtback SS STi Type R money pit- NEW RALLYCAR!!


Profile  Offline
 
 Post subject:
PostPosted: Tue May 26, 2009 6:06 pm 
Site Admin
Site Admin
Joined: Tue Oct 15, 2002 11:37 am
Posts: 24630
Location: Houston, Tx
Knock sensor shouldn't throw a CEL if it hears knock.

_________________
Josh

surrealmirage.com/subaru
1990 Legacy (AWD, 6MT, & EJ22T Swap)
1997 Impreza OBS

If you need to get a hold of me please email me rather then pm


Profile  Offline
 
 Post subject:
PostPosted: Fri May 29, 2009 4:20 am 
Third Gear
Joined: Sun Apr 03, 2005 6:01 am
Posts: 728
Location: Casper, WY
ok thanks josh.

I am rethinking my oil leak. I think there are two cuts in the psv lines.

So with the car idling, I pulled each pcv line off the head. the driver's side has air pulsing out of it the passenger side does not. why is this? is this a problem?

_________________
1970 Honda Ct90
2001 Forester S of Doom
1994/5/6/01/02/03/04/06/07/08 Impregacy OUtback SS STi Type R money pit- NEW RALLYCAR!!


Profile  Offline
 

Display posts from previous:  Sort by  

Post new topic Reply to topic  [ 126 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6  Next


Who is online

Users browsing this forum: mike-tracy and 4 guests

Panel

Top You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Dizayn Ercan Koc