Search found 2225 matches

by Tleg93
Fri Jul 24, 2015 11:08 am
Forum: Car Lot
Topic: 1993 Turbo Legacy Wagon
Replies: 3
Views: 1364

Re: 1993 Turbo Legacy Wagon

Hmm, one thing is that I may be coming out to Eugene area for some seasonal work and if I'm up that way I'd like to at least look at it. If I thought it could make the trip I'd come check it out and drive it back to the east coast. This just sounds like an interesting car. Some pics would be nice.
by Tleg93
Mon Nov 26, 2012 3:03 pm
Forum: Parts Shed
Topic: Selling 91 turbo engine - PA
Replies: 3
Views: 504

Re: Selling 91 turbo engine - PA

I'm in williamsport. I could maybe load it up and meet you somewhere. Feel free to ask any questions. I can try to get some pics too.
by Tleg93
Tue Nov 20, 2012 11:26 pm
Forum: Parts Shed
Topic: 22t parts last call before scrap
Replies: 10
Views: 1177

Re: 22t parts last call before scrap

Don't scrap yet! I'm digging for funds for some of this stuff. I need it badly.
by Tleg93
Tue Nov 20, 2012 11:23 pm
Forum: Parts Shed
Topic: Looking for (turbo) leggy parts - PA
Replies: 1
Views: 379

Looking for (turbo) leggy parts - PA

I recently had an encounter with a deer and I need some parts. Looking for the following:

- Hood, preferably turbo but a 91 hood will do.
- Front right headlight
- Driver side door card buttons intact.
- Heating A/C unit
- Glove box
- Purge Canister.
by Tleg93
Tue Nov 20, 2012 11:18 pm
Forum: Parts Shed
Topic: Selling 91 turbo engine - PA
Replies: 3
Views: 504

Selling 91 turbo engine - PA

Ok, so I've had this turbo engine from my 91 leggy hanging around for a while and I've finally decided it's time to sell it. I had tentative plans to rebuild and stroke it etc. but now I just need the cash. Here's the details: - Crank turns easy with a wrench so it's not frozen. - Had good power and...
by Tleg93
Sun Sep 16, 2012 8:09 pm
Forum: Electrical
Topic: Gremlins in the turn signals
Replies: 4
Views: 857

Re: Gremlins in the turn signals

Yeah, I'm inclined to agree. I hate chasing down bad grounds but I'm going to have to it seems. Shorted wires seem like the more likely culprit though. Time to get the megger out and look for shorts.
by Tleg93
Wed Sep 12, 2012 11:58 am
Forum: Electrical
Topic: Gremlins in the turn signals
Replies: 4
Views: 857

Re: Gremlins in the turn signals

Oh cool man. Thanks for the diagram. That will help a lot once I start tearing things apart. Removing both of the bulbs has kept the fuse from blowing. This is important as it gives me turn signals. That's all the farther I've gotten with it at this point. I'll start tracking it down from the revers...
by Tleg93
Fri Sep 07, 2012 9:17 pm
Forum: Electrical
Topic: Gremlins in the turn signals
Replies: 4
Views: 857

Gremlins in the turn signals

Hello all. I don't know if anyone is still out there but what the heck, I'll give it a shot. The problem I'm having is this: I keep blowing the turn signal fuse. It seems to happen whenever I put the car in reverse. The reason for this is because the fuse that has the turn signals on it also has the...
by Tleg93
Sat Sep 03, 2011 7:35 pm
Forum: Ashtray
Topic: My SS has (re)arisen!
Replies: 3
Views: 658

Re: My SS has (re)arisen!

Heh. Yeah. I'll get some posted as soon as I get the chance. I think you'll all like it. The whole car was flat blackd', even the trim. So no silver streak along the doors...or anywhere. He also painted the grill all black. All I'm missing is the legacy logo that sits underneath the rear side window...
by Tleg93
Sat Sep 03, 2011 4:13 pm
Forum: Parts Shed
Topic: WTB: Stock legacy turbo wheels.
Replies: 4
Views: 642

Re: WTB: Stock legacy turbo wheels.

Come on guys! I know someone out there has stock wheels or other 15"wheels they would part with. :) Help a brotha out.
by Tleg93
Sat Sep 03, 2011 12:36 am
Forum: Ashtray
Topic: My SS has (re)arisen!
Replies: 3
Views: 658

My SS has (re)arisen!

Just being dramatic but I did just have all the rust repaired and had it painted flat black. It looks awesome! So no more rio red, now I've faded to black.
by Tleg93
Sat Sep 03, 2011 12:32 am
Forum: Parts Shed
Topic: WTB: Stock legacy turbo wheels.
Replies: 4
Views: 642

WTB: Stock legacy turbo wheels.

The post title says it all. I need stock SS wheels but other 15" wheels would be cool as well.
by Tleg93
Sat Sep 03, 2011 12:30 am
Forum: Parts Shed
Topic: 91 SS KYB struts and WRX
Replies: 20
Views: 1704

Re: 91 SS KYB struts and WRX

I'm interested. My rear shocks are hosed and leak.
by Tleg93
Sat Jun 25, 2011 4:52 am
Forum: Electrical
Topic: More issues from the sensor grid...
Replies: 9
Views: 1007

Re: More issues from the sensor grid...

The engine would spin, as in it the crank would turn but the sound of it trying to turn over was all wrong. It didn't sound like the timing was right when trying to turn over. The problem was resolved after a couple tries. It turns out that the tensioner pulley was shot on both sides and the one of ...
by Tleg93
Fri Jun 03, 2011 7:41 pm
Forum: Electrical
Topic: More issues from the sensor grid...
Replies: 9
Views: 1007

Re: More issues from the sensor grid...

It wasn't the MAF. A guy I know came and looked at it and it looks like it either jumped time drastically or a cam went out on me. I pray it's a slipped belt, although it's tight, the cam angle or crank sensor because if it isn't I might as well throw myself under a bus.
by Tleg93
Thu Jun 02, 2011 1:52 pm
Forum: Electrical
Topic: More issues from the sensor grid...
Replies: 9
Views: 1007

Re: More issues from the sensor grid...

Thanks for the input, I'll check that out. It's weird, it just kind of sputtered to a halt and that was it. I HATE to think the ECU went as I don't have another anymore. But it is still throwing codes. Judging by the content of the codes it does seem likely to be the maf but we'll see.
by Tleg93
Thu Jun 02, 2011 2:33 am
Forum: Electrical
Topic: More issues from the sensor grid...
Replies: 9
Views: 1007

Re: More issues from the sensor grid...

Nope. What I'm wondering is will a car not start due to an opened MAF?
by Tleg93
Wed Jun 01, 2011 9:56 pm
Forum: Electrical
Topic: More issues from the sensor grid...
Replies: 9
Views: 1007

Re: More issues from the sensor grid...

I'm off to replace the knock sensor.
by Tleg93
Wed Jun 01, 2011 8:34 pm
Forum: Electrical
Topic: More issues from the sensor grid...
Replies: 9
Views: 1007

Re: More issues from the sensor grid...

Update: I found the code for 49. I just overlooked it. That too is an air flow sensor code. That really makes me suspect an open circuit.
by Tleg93
Wed Jun 01, 2011 8:32 pm
Forum: Electrical
Topic: More issues from the sensor grid...
Replies: 9
Views: 1007

More issues from the sensor grid...

Hello all, man it's been a long time since I've been on the board. I hope all is well with the board members. I haven't parsed through the posts so I don't know who's active anymore but I think about the speed n feed's that Matt used to have sometimes. Anyway... here's my dealio. My car died last ni...
by Tleg93
Sat Sep 25, 2010 10:29 pm
Forum: Electrical
Topic: Trouble codes
Replies: 12
Views: 863

Re: Trouble codes

Ok, a big duh here. I finally removed the maf and found it caked with black soot from my K&N probably... But I cleaned it with some MAF cleaner and now it runs properly. It's fixed! yay!
by Tleg93
Sat Sep 25, 2010 9:26 pm
Forum: Electrical
Topic: Trouble codes
Replies: 12
Views: 863

Re: Trouble codes

Thanks again Josh. I ran the car with the MAP unplugged just to see if it made a difference and it ran the way it's been running, bogging down at 2.5k to 3k rpm. I don't know if the means the sensor is opened or not. I'm going to dig for the schematics, it's time to get my troubleshooting on. I'm go...
by Tleg93
Thu Sep 16, 2010 4:34 pm
Forum: Electrical
Topic: Trouble codes
Replies: 12
Views: 863

Re: Trouble codes

Ok, the local subaru shop is being retarted about this which is normal for them. They are asking for a part number. Now, I told them I need a MAF off of a 90-91 NA legacy. She said "oh you can't use that!" to which I said that I had it on good information that you could. So she's asking fo...
by Tleg93
Tue Sep 14, 2010 3:21 pm
Forum: Electrical
Topic: Trouble codes
Replies: 12
Views: 863

Re: Trouble codes

Thanks Josh. Someone told me I couldn't but I swore I remembered hearing you could use one.
by Tleg93
Wed Sep 08, 2010 8:04 pm
Forum: Electrical
Topic: Trouble codes
Replies: 12
Views: 863

Re: Trouble codes

Thanks for the tips. Matt (legacyej22t) told me that I can't use an NA MAF in my car. I believe him but I was hoping it might work temporarily or at least to test it. I haven't tried anything yet but I'm going to have to soon it's running very lean at times.